aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLorenzo Salvadore <salvadore@FreeBSD.org>2024-02-24 08:45:25 +0000
committerLorenzo Salvadore <salvadore@FreeBSD.org>2024-02-24 09:34:52 +0000
commitb1b2712440d93ea3c636266309bf9c1b518c595b (patch)
treeb9e2fc677551464482563cc8556ee3c21f39d3cb
parent5be767bb2c71f8e76c3886f8a2aa05bb51d5586f (diff)
downloadports-b1b2712440d93ea3c636266309bf9c1b518c595b.tar.gz
ports-b1b2712440d93ea3c636266309bf9c1b518c595b.zip
graphics/darktable: Force building with GCC 12
Second attempt to set USE_GCC=12 properly, so that the GCC_DEFAULT update can get forward. PR: 273681 Approved by: portmgr (blanket) Fixes: c97005f74a5b graphics/darktable: Set USE_GCC=12
-rw-r--r--graphics/darktable/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 26fab18b0ce3..7ea31ac65604 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -42,7 +42,7 @@ LIB_DEPENDS= libavif.so:graphics/libavif \
libtiff.so:graphics/tiff \
libwebp.so:graphics/webp
-USES= cmake compiler:gcc-c++11-lib desktop-file-utils gl gnome jpeg \
+USES= cmake compiler:c++11-lib desktop-file-utils gl gnome jpeg \
llvm:15,build lua:54 perl5 pkgconfig sdl shebangfix sqlite \
tar:xz xorg
USE_GCC= 12
@@ -61,6 +61,7 @@ CMAKE_BOOL+= BUILD_CMSTEST USE_AVIF USE_CAMERA_SUPPORT USE_HEIF \
USE_OPENJPEG USE_WEBP RAWSPEED_ENABLE_LTO
CFLAGS+= -fopenmp -I${LOCALBASE}/include/Imath
+CXXFLAGS+= -stdlib=libc++
LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:C/\.rc/~rc/}