aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2005-12-07 16:19:48 +0000
committerErwin Lansing <erwin@FreeBSD.org>2005-12-07 16:19:48 +0000
commitb23f9f7c22ce4066a51dec7693f740b87923e6a9 (patch)
tree0fd34fd0c8bb2a271ffea218714a0a2b4c15741d
parent1b7485cc6dbeddc10224334bc94168add8c48943 (diff)
downloadports-b23f9f7c22ce4066a51dec7693f740b87923e6a9.tar.gz
ports-b23f9f7c22ce4066a51dec7693f740b87923e6a9.zip
Want to use a Mason component in your views? No problem!
Catalyst::View::Mason comes to the rescue. WWW: http://search.cpan.org/dist/Catalyst-View-Mason/ PR: ports/90076 Submitted by: Lars Balker Rasmussen <lars@balker.dk>
Notes
Notes: svn path=/head/; revision=150606
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-View-Mason/Makefile31
-rw-r--r--www/p5-Catalyst-View-Mason/distinfo3
-rw-r--r--www/p5-Catalyst-View-Mason/pkg-descr4
-rw-r--r--www/p5-Catalyst-View-Mason/pkg-plist6
5 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d20cf3697b56..a3ee0e679a52 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -512,6 +512,7 @@
SUBDIR += p5-Catalyst-Plugin-Textile
SUBDIR += p5-Catalyst-Plugin-XMLRPC
SUBDIR += p5-Catalyst-View-HTML-Template
+ SUBDIR += p5-Catalyst-View-Mason
SUBDIR += p5-Catalyst-View-TT
SUBDIR += p5-Class-DBI-FromForm
SUBDIR += p5-Compress-LeadingBlankSpaces
diff --git a/www/p5-Catalyst-View-Mason/Makefile b/www/p5-Catalyst-View-Mason/Makefile
new file mode 100644
index 000000000000..44b0ea59c3a6
--- /dev/null
+++ b/www/p5-Catalyst-View-Mason/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: www/p5-Catalyst-View-Mason
+# Date created: 07 Dec 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-View-Mason
+PORTVERSION= 0.08
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Mason view class for Catalyst
+
+BUILD_DEPENDS= p5-Catalyst>=5.0:${PORTSDIR}/www/p5-Catalyst \
+ p5-HTML-Mason>=0:${PORTSDIR}/www/p5-HTML-Mason
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Helper::View::Mason.3 \
+ Catalyst::View::Mason.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500801
+IGNORE= requires Perl 5.8. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-View-Mason/distinfo b/www/p5-Catalyst-View-Mason/distinfo
new file mode 100644
index 000000000000..d44a6e77a6d9
--- /dev/null
+++ b/www/p5-Catalyst-View-Mason/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-View-Mason-0.08.tar.gz) = 7bdb780c8a2326be894564861344d2ba
+SHA256 (Catalyst-View-Mason-0.08.tar.gz) = b234d52225eb11b16065e95da444d5c557b32a0d5d5a5a76c752182509ad8125
+SIZE (Catalyst-View-Mason-0.08.tar.gz) = 4053
diff --git a/www/p5-Catalyst-View-Mason/pkg-descr b/www/p5-Catalyst-View-Mason/pkg-descr
new file mode 100644
index 000000000000..599df0a06d64
--- /dev/null
+++ b/www/p5-Catalyst-View-Mason/pkg-descr
@@ -0,0 +1,4 @@
+Want to use a Mason component in your views? No problem!
+Catalyst::View::Mason comes to the rescue.
+
+WWW: http://search.cpan.org/dist/Catalyst-View-Mason/
diff --git a/www/p5-Catalyst-View-Mason/pkg-plist b/www/p5-Catalyst-View-Mason/pkg-plist
new file mode 100644
index 000000000000..a538eda6b900
--- /dev/null
+++ b/www/p5-Catalyst-View-Mason/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Catalyst/Helper/View/Mason.pm
+%%SITE_PERL%%/Catalyst/View/Mason.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Helper/View 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Helper 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/View 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true