aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Hein <jcfyecrayz@liamekaens.com>2023-09-05 04:45:14 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-05 04:56:13 +0000
commitb242d6d26f2b3820c9fad44e5f98133c0d3c7b42 (patch)
treeaf3944533723aae305fe10e8b9e2436211dd04b8
parente4209b62c53bce5deec1abb2581c6425cb8a0c2e (diff)
devel/capstone: Fix runtime permissions
bin/cstool is installed with 0644 perissions instead of 0755 which gives permission denied error. This patch fixes this. PR: 273570
-rw-r--r--devel/capstone/Makefile1
-rw-r--r--devel/capstone/files/patch-Makefile11
2 files changed, 12 insertions, 0 deletions
diff --git a/devel/capstone/Makefile b/devel/capstone/Makefile
index 269ca0241aeb..ef8d174373ce 100644
--- a/devel/capstone/Makefile
+++ b/devel/capstone/Makefile
@@ -1,5 +1,6 @@
PORTNAME= capstone
DISTVERSION= 5.0.1
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= bofh@FreeBSD.org
diff --git a/devel/capstone/files/patch-Makefile b/devel/capstone/files/patch-Makefile
new file mode 100644
index 000000000000..157051ed79f7
--- /dev/null
+++ b/devel/capstone/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2023-08-22 16:03:55 UTC
++++ Makefile
+@@ -503,7 +503,7 @@ endif
+ $(INSTALL_DATA) $(PKGCFGF) $(PKGCFGDIR)
+ ifeq (,$(findstring yes,$(CAPSTONE_BUILD_CORE_ONLY)))
+ mkdir -p $(BINDIR)
+- $(INSTALL_LIB) cstool/cstool $(BINDIR)
++ $(INSTALL_BIN) cstool/cstool $(BINDIR)
+ endif
+
+ uninstall: