aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Bowling <kbowling@FreeBSD.org>2021-09-29 16:27:04 +0000
committerKevin Bowling <kbowling@FreeBSD.org>2021-09-29 17:21:09 +0000
commitb25605cc0ccf7645daba0a9a1448440748bc2e5c (patch)
tree165251fbeaa6f4edc9d196acbe50b835a42e3223
parentab1c2c47aba883c63f6763fbee1d9a1bf86ed2a0 (diff)
downloadports-b25605cc0ccf7645daba0a9a1448440748bc2e5c.tar.gz
ports-b25605cc0ccf7645daba0a9a1448440748bc2e5c.zip
sysutils/ltfs: Update to 2.4.4.0
Port changes: Add options for DEBUG and SNMP, reformat. ltfs changes: * Support LTO9 drives * Fixed and improved MAM handling in cases where MAM might not update correctly during write errors, so that LTFS correctly searches for the latest index position of the tape for these cases. * FreeBSD 12 build fix Changes: https://github.com/LinearTapeFileSystem/ltfs/compare/v2.4.3.1-10461...v2.4.4.0-10470
-rw-r--r--sysutils/ltfs/Makefile45
-rw-r--r--sysutils/ltfs/distinfo6
-rw-r--r--sysutils/ltfs/pkg-plist5
3 files changed, 37 insertions, 19 deletions
diff --git a/sysutils/ltfs/Makefile b/sysutils/ltfs/Makefile
index 802924d559f6..4767f7f85042 100644
--- a/sysutils/ltfs/Makefile
+++ b/sysutils/ltfs/Makefile
@@ -1,32 +1,49 @@
# Created by: Kevin Bowling <kbowling@FreeBSD.org>
-PORTNAME= ltfs
+PORTNAME= ltfs
DISTVERSIONPREFIX= v
-DISTVERSION= 2.4.3.1
-DISTVERSIONSUFFIX= -10461
-PORTREVISION= 1
-CATEGORIES= sysutils
+DISTVERSION= 2.4.4.0
+DISTVERSIONSUFFIX= -10470
+CATEGORIES= sysutils
MAINTAINER= kbowling@FreeBSD.org
COMMENT= Reference implementation of LTFS for stand-alone tape drive
LICENSE= BSD3CLAUSE
-LICENSE_FILE = ${WRKSRC}/LICENSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libicudata.so:devel/icu \
- libnetsnmp.so:net-mgmt/net-snmp \
libpkg.so:${PKG_ORIGIN} \
libuuid.so:misc/e2fsprogs-libuuid
-USES= autoreconf compiler:c11 fuse gnome libtool:build pkgconfig ssl
+USES= autoreconf compiler:c11 fuse gnome libtool:build pkgconfig \
+ python shebangfix ssl
+
+USE_GITHUB= yes
+GH_ACCOUNT= LinearTapeFileSystem
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+
+SHEBANG_FILES= src/utils/ltfs_ordered_copy
+
+GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-icu-6x
-GH_ACCOUNT= LinearTapeFileSystem
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USE_GITHUB= yes
-USE_GNOME= libxml2
-USE_LDCONFIG= yes
+
+INSTALL_TARGET= install-strip
+
+OPTIONS_DEFINE= DEBUG SNMP
+OPTIONS_SUB= yes
+
+DEBUG_DESC= Build without optimization and extended debug flags
+SNMP_DESC= SNMP trap support
+
+DEBUG_CONFIGURE_ON= --enable-debug
+DEBUG_CONFIGURE_OFF= --enable-fast
+
+SNMP_LIB_DEPENDS= libnetsnmp.so:net-mgmt/net-snmp
+SNMP_USES= perl5
+SNMP_CONFIGURE_ENABLE= snmp
post-install:
@${RM} ${STAGEDIR}${DATADIR}/ltfs
diff --git a/sysutils/ltfs/distinfo b/sysutils/ltfs/distinfo
index 197e70036adf..ef2223b78ad6 100644
--- a/sysutils/ltfs/distinfo
+++ b/sysutils/ltfs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1613673367
-SHA256 (LinearTapeFileSystem-ltfs-v2.4.3.1-10461_GH0.tar.gz) = ae39778a47cb09c126fd394c269cbf464f7b43c876ea71a9c880e1159ce87066
-SIZE (LinearTapeFileSystem-ltfs-v2.4.3.1-10461_GH0.tar.gz) = 614066
+TIMESTAMP = 1632932667
+SHA256 (LinearTapeFileSystem-ltfs-v2.4.4.0-10470_GH0.tar.gz) = 840989bb50e4cd752473fa3b2f69bb2b844a7c89b8a7f55a4560fa8672709792
+SIZE (LinearTapeFileSystem-ltfs-v2.4.4.0-10470_GH0.tar.gz) = 624915
diff --git a/sysutils/ltfs/pkg-plist b/sysutils/ltfs/pkg-plist
index eda1d1eb099b..9c0eee273883 100644
--- a/sysutils/ltfs/pkg-plist
+++ b/sysutils/ltfs/pkg-plist
@@ -43,8 +43,9 @@ lib/ltfs/libtape-cam.so
lib/ltfs/libtape-file.so
lib/ltfs/libtape-itdtimg.so
libdata/pkgconfig/ltfs.pc
+man/man1/ltfs_ordered_copy.1.gz
man/man8/ltfs-sde.8.gz
man/man8/ltfsck.8.gz
man/man8/mkltfs.8.gz
-share/snmp/LTFS-MIB.txt
-share/snmp/LtfsSnmpTrapDef.txt
+%%SNMP%%share/snmp/LTFS-MIB.txt
+%%SNMP%%share/snmp/LtfsSnmpTrapDef.txt