aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2023-02-01 14:45:40 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2023-02-01 14:46:13 +0000
commitb27c3767332c70e1f9bd0788c9cb1af4f17121e9 (patch)
treed82e9327b765c88ef7dd9e5cb30940a99e4438cf
parent2299c6bef64670900195e7c86bcdc2e368b0a55b (diff)
downloadports-b27c3767332c70e1f9bd0788c9cb1af4f17121e9.tar.gz
ports-b27c3767332c70e1f9bd0788c9cb1af4f17121e9.zip
gnome: remove libwnck from the gnome framework
libwnck is a leftover from gnome2 time and almost unused
-rw-r--r--Mk/Uses/gnome.mk5
-rw-r--r--x11-wm/compiz/Makefile3
-rw-r--r--x11-wm/emerald/Makefile5
-rw-r--r--x11/keyboardcast/Makefile4
-rw-r--r--x11/lxpanel/Makefile5
5 files changed, 12 insertions, 10 deletions
diff --git a/Mk/Uses/gnome.mk b/Mk/Uses/gnome.mk
index c6dc9eeccb02..b3950b7dc2fc 100644
--- a/Mk/Uses/gnome.mk
+++ b/Mk/Uses/gnome.mk
@@ -63,7 +63,7 @@ _USE_GNOME_ALL+= atk cairo \
gtk-update-icon-cache gtk20 \
gtksharp20 gtksourceview2 gvfs libartlgpl2 \
libglade2 libgnomecanvas \
- libgsf libidl librsvg2 libwnck \
+ libgsf libidl librsvg2 \
libxml2 libxslt \
pango pangox-compat \
vte
@@ -215,9 +215,6 @@ libartlgpl2_LIB_DEPENDS= libart_lgpl_2.so:graphics/libart_lgpl
gnomedesktop3_LIB_DEPENDS= libgnome-desktop-3.so:x11/gnome-desktop
gnomedesktop3_USE_GNOME_IMPL= gtk30
-libwnck_LIB_DEPENDS= libwnck-1.so:x11-toolkits/libwnck
-libwnck_USE_GNOME_IMPL= gtk20
-
libwnck3_LIB_DEPENDS= libwnck-3.so:x11-toolkits/libwnck3
libwnck3_USE_GNOME_IMPL=gtk30
diff --git a/x11-wm/compiz/Makefile b/x11-wm/compiz/Makefile
index 80c4eb3681de..f7bc458cbea5 100644
--- a/x11-wm/compiz/Makefile
+++ b/x11-wm/compiz/Makefile
@@ -62,7 +62,8 @@ FUSE_CONFIGURE_ENABLE= fuse
FUSE_USES= fuse
GTK2_CONFIGURE_ENABLE= gtk
-GTK2_USE= GNOME=glib20,libwnck
+GTK2_USE= GNOME=glib20
+GTK2_LIB_DEPENDS= libwnck-1.so:x11-toolkits/libwnck
SVG_CONFIGURE_ENABLE= librsvg
SVG_USE= GNOME=librsvg2
diff --git a/x11-wm/emerald/Makefile b/x11-wm/emerald/Makefile
index e0ab9acf2eee..eea31fe725e2 100644
--- a/x11-wm/emerald/Makefile
+++ b/x11-wm/emerald/Makefile
@@ -13,14 +13,15 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/compiz.pc:x11-wm/compiz
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
+ libfreetype.so:print/freetype2 \
+ libwnck-1.so:x11-toolkits/libwnck
RUN_DEPENDS:= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
USES= desktop-file-utils gl gmake gnome libtool pathfix \
pkgconfig shared-mime-info tar:bzip2 xorg
USE_GL= gl
-USE_GNOME= cairo gtk20 intltool libwnck pango
+USE_GNOME= cairo gtk20 intltool pango
USE_XORG= x11 xrender
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
diff --git a/x11/keyboardcast/Makefile b/x11/keyboardcast/Makefile
index 6f2b6d192659..f202d0c182c6 100644
--- a/x11/keyboardcast/Makefile
+++ b/x11/keyboardcast/Makefile
@@ -11,11 +11,13 @@ WWW= https://launchpad.net/keyboardcast
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+LIB_DEPENDS= libwnck-1.so:x11-toolkits/libwnck
+
USE_GITHUB= yes
GH_ACCOUNT= ekoort
USES= gnome pkgconfig xorg
USE_XORG= xmu x11
-USE_GNOME= libwnck libglade2 gtk20
+USE_GNOME= libglade2 gtk20
.include <bsd.port.mk>
diff --git a/x11/lxpanel/Makefile b/x11/lxpanel/Makefile
index e7f1a0c4abca..12b8d3ac91c5 100644
--- a/x11/lxpanel/Makefile
+++ b/x11/lxpanel/Makefile
@@ -16,11 +16,12 @@ LIB_DEPENDS= libmenu-cache.so:x11/menu-cache \
libkeybinder.so:x11/keybinder \
libfm-gtk.so:x11/libfm@gtk2 \
libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2
+ libfreetype.so:print/freetype2 \
+ libwnck-1.so:x11-toolkits/libwnck
RUN_DEPENDS= ${LOCALBASE}/etc/xdg/menus/lxde-applications.menu:x11/lxmenu-data
USES= gmake gnome libtool localbase pathfix pkgconfig tar:xz xorg
-USE_GNOME= glib20 gtk20 cairo gdkpixbuf2 gdkpixbuf2xlib libwnck intltool
+USE_GNOME= glib20 gtk20 cairo gdkpixbuf2 gdkpixbuf2xlib intltool
USE_XORG= x11
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \