aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLewis Cook <lcook@FreeBSD.org>2022-12-19 05:05:02 +0000
committerLewis Cook <lcook@FreeBSD.org>2022-12-19 05:07:06 +0000
commitb2dc69c0153f1d16549950550a8aeafb78adeda0 (patch)
tree4d4bdf789914314b800db7f03941aec32bdd7508
parent9bf432b7476dfb46682e876f0f11e484193e0e52 (diff)
downloadports-b2dc69c0153f1d16549950550a8aeafb78adeda0.tar.gz
ports-b2dc69c0153f1d16549950550a8aeafb78adeda0.zip
security/osv-scanner: Vulnerability scanner written in Go which uses the OSV database
Use OSV-Scanner to find existing vulnerabilities affecting your projects dependencies. OSV-Scanner provides an officially supported frontend to the OSV database that connects a projects list of dependencies with the vulnerabilities that affect them. Since the OSV.dev database is open source and distributed, it has several benefits in comparison with closed source advisory databases and scanners: * Each advisory comes from an open and authoritative source. * Anyone can suggest improvements to advisories, resulting in a very high quality database. * The OSV format unambiguously stores information about affected versions in a machine-readable format that precisely maps onto a developers list of packages. The above all results in fewer, more actionable vulnerability notifications, which reduces the time needed to resolve them. WWW: https://github.com/google/osv-scanner
-rw-r--r--security/Makefile1
-rw-r--r--security/osv-scanner/Makefile35
-rw-r--r--security/osv-scanner/distinfo5
-rw-r--r--security/osv-scanner/pkg-descr18
4 files changed, 59 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 45dca716f0c4..fac5e5b6805e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -423,6 +423,7 @@
SUBDIR += ossec-hids-server
SUBDIR += ossec-hids-server-config
SUBDIR += osslsigncode
+ SUBDIR += osv-scanner
SUBDIR += otpw
SUBDIR += owasp-dependency-check
SUBDIR += p11-kit
diff --git a/security/osv-scanner/Makefile b/security/osv-scanner/Makefile
new file mode 100644
index 000000000000..4c2440900318
--- /dev/null
+++ b/security/osv-scanner/Makefile
@@ -0,0 +1,35 @@
+PORTNAME= osv-scanner
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.1
+CATEGORIES= security
+
+MAINTAINER= lcook@FreeBSD.org
+COMMENT= Vulnerability scanner written in Go which uses the OSV database
+WWW= https://github.com/google/osv-scanner
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+_BUILD_VERSION= ${DISTVERSION}
+_BUILD_COMMIT= ac28fb9
+
+GO_MODULE= github.com/google/${PORTNAME}
+GO_TARGET= ./cmd/${PORTNAME}
+GO_BUILDFLAGS= -ldflags "\
+ -s -w \
+ -X main.version=${_BUILD_VERSION} \
+ -X main.commit=${_BUILD_COMMIT}"
+
+PORTDOCS= README.md
+PLIST_FILES= ${GO_TARGET:C/.\/cmd/bin/}
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} \
+ ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/security/osv-scanner/distinfo b/security/osv-scanner/distinfo
new file mode 100644
index 000000000000..df1493dc740d
--- /dev/null
+++ b/security/osv-scanner/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1671425146
+SHA256 (go/security_osv-scanner/osv-scanner-v1.0.1/v1.0.1.mod) = 41cc1f1962a203e7608947fd522c919db6f412d9ac679a11992eda093f523380
+SIZE (go/security_osv-scanner/osv-scanner-v1.0.1/v1.0.1.mod) = 850
+SHA256 (go/security_osv-scanner/osv-scanner-v1.0.1/v1.0.1.zip) = 3267c46f44d241939baf5e855b0b74b8eb9a31e5bca0285e22f71204d0472b2b
+SIZE (go/security_osv-scanner/osv-scanner-v1.0.1/v1.0.1.zip) = 169996
diff --git a/security/osv-scanner/pkg-descr b/security/osv-scanner/pkg-descr
new file mode 100644
index 000000000000..647c27762382
--- /dev/null
+++ b/security/osv-scanner/pkg-descr
@@ -0,0 +1,18 @@
+Use OSV-Scanner to find existing vulnerabilities affecting your projects
+dependencies.
+
+OSV-Scanner provides an officially supported frontend to the OSV database
+that connects a projects list of dependencies with the vulnerabilities
+that affect them. Since the OSV.dev database is open source and distributed,
+it has several benefits in comparison with closed source advisory databases
+and scanners:
+
+* Each advisory comes from an open and authoritative source.
+* Anyone can suggest improvements to advisories, resulting in a very high
+ quality database.
+* The OSV format unambiguously stores information about affected versions
+ in a machine-readable format that precisely maps onto a developers list
+ of packages.
+
+The above all results in fewer, more actionable vulnerability notifications,
+which reduces the time needed to resolve them.