aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Nagy <rnagy@FreeBSD.org>2023-08-24 10:44:04 +0000
committerRobert Nagy <rnagy@FreeBSD.org>2023-08-24 10:45:29 +0000
commitb37a3f572890f7796caf33332709b906b61152dc (patch)
treec6037fe9b7f16477ec5560a8638d56035468d281
parent543b67d5f361ddf4aa825a25445443785d313235 (diff)
downloadports-b37a3f572890f7796caf33332709b906b61152dc.tar.gz
ports-b37a3f572890f7796caf33332709b906b61152dc.zip
www/chromium: update to 116.0.5845.110
Security: https://vuxml.freebsd.org/freebsd/5fa332b9-4269-11ee-8290-a8a1599412c6.html (cherry picked from commit facfa9bd603d77241c4b76b6e7afc9edb900e0ab)
-rw-r--r--www/chromium/Makefile2
-rw-r--r--www/chromium/distinfo14
-rw-r--r--www/chromium/files/patch-media_gpu_chromeos_video__decoder__pipeline.cc6
-rw-r--r--www/chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json58
4 files changed, 15 insertions, 15 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index c2c4d7e934e3..8834d64e6d34 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -1,5 +1,5 @@
PORTNAME= chromium
-PORTVERSION= 116.0.5845.96
+PORTVERSION= 116.0.5845.110
CATEGORIES= www wayland
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
https://nerd.hu/distfiles/:external
diff --git a/www/chromium/distinfo b/www/chromium/distinfo
index 2b6e14288aaf..c47c74c7e606 100644
--- a/www/chromium/distinfo
+++ b/www/chromium/distinfo
@@ -1,9 +1,9 @@
-TIMESTAMP = 1692255968
-SHA256 (chromium-116.0.5845.96.tar.xz) = 1ec1052a959abced9642b36482549bc2ebefa428ed136289d8e0c54b4ccd1c81
-SIZE (chromium-116.0.5845.96.tar.xz) = 1599788748
-SHA256 (chrome-linux-116.0.5845.96-llvm13.profdata.tar.xz) = b770982155d6500331265ab0b6670692ab73c69a650d3398813b378bad1e6069
-SIZE (chrome-linux-116.0.5845.96-llvm13.profdata.tar.xz) = 27750072
-SHA256 (chromium-116.0.5845.96-testdata.tar.xz) = f626b0fb34dbf528df11830b9d1d7f5e56832d6770ccd3fad07cee31e9825606
-SIZE (chromium-116.0.5845.96-testdata.tar.xz) = 269310352
+TIMESTAMP = 1692873434
+SHA256 (chromium-116.0.5845.110.tar.xz) = e85ef479a1a4972ffd4d2e389cbaf341df4c7cca63e4ebbb38d175fda106d9a9
+SIZE (chromium-116.0.5845.110.tar.xz) = 1599776928
+SHA256 (chrome-linux-116.0.5845.110-llvm13.profdata.tar.xz) = 6733879d92df843e2fdf3a8aaf221a785c5e5f73d8625a6b9b8c3376357f12d1
+SIZE (chrome-linux-116.0.5845.110-llvm13.profdata.tar.xz) = 27740936
+SHA256 (chromium-116.0.5845.110-testdata.tar.xz) = 784577faa337801c8111bb5459f72a65043053f68bec037ab1920828c6534dc3
+SIZE (chromium-116.0.5845.110-testdata.tar.xz) = 267917840
SHA256 (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = a2ca2962daf482a8f943163541e1c73ba4b2694fabcd2510981f2db4eda493c8
SIZE (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = 32624734
diff --git a/www/chromium/files/patch-media_gpu_chromeos_video__decoder__pipeline.cc b/www/chromium/files/patch-media_gpu_chromeos_video__decoder__pipeline.cc
index 18cd434b5b11..1927fc3f668d 100644
--- a/www/chromium/files/patch-media_gpu_chromeos_video__decoder__pipeline.cc
+++ b/www/chromium/files/patch-media_gpu_chromeos_video__decoder__pipeline.cc
@@ -1,6 +1,6 @@
---- media/gpu/chromeos/video_decoder_pipeline.cc.orig 2023-07-16 15:47:57 UTC
+--- media/gpu/chromeos/video_decoder_pipeline.cc.orig 2023-08-24 10:40:35 UTC
+++ media/gpu/chromeos/video_decoder_pipeline.cc
-@@ -979,14 +979,14 @@ VideoDecoderPipeline::PickDecoderOutputFormat(
+@@ -986,14 +986,14 @@ VideoDecoderPipeline::PickDecoderOutputFormat(
}
}
@@ -17,7 +17,7 @@
// Linux w/ V4L2 should not use a custom allocator
// Only tested with video_decode_accelerator_tests
// TODO(wenst@) Test with full Chromium Browser
-@@ -1117,7 +1117,7 @@ VideoDecoderPipeline::PickDecoderOutputFormat(
+@@ -1124,7 +1124,7 @@ VideoDecoderPipeline::PickDecoderOutputFormat(
<< " VideoFrames";
auxiliary_frame_pool_->set_parent_task_runner(decoder_task_runner_);
diff --git a/www/chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json5 b/www/chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json5
index e8afca6d3b32..9e42ea09e6d4 100644
--- a/www/chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json5
+++ b/www/chromium/files/patch-third__party_blink_renderer_platform_runtime__enabled__features.json5
@@ -1,6 +1,6 @@
---- third_party/blink/renderer/platform/runtime_enabled_features.json5.orig 2023-08-17 07:33:31 UTC
+--- third_party/blink/renderer/platform/runtime_enabled_features.json5.orig 2023-08-24 10:40:35 UTC
+++ third_party/blink/renderer/platform/runtime_enabled_features.json5
-@@ -2673,7 +2673,7 @@
+@@ -2675,7 +2675,7 @@
name: "PaymentHandlerMinimalHeaderUX",
origin_trial_feature_name: "PaymentHandlerMinimalHeaderUX",
origin_trial_allows_third_party: true,
@@ -9,7 +9,7 @@
},
{
name: "PaymentInstruments",
-@@ -3634,7 +3634,7 @@
+@@ -3636,7 +3636,7 @@
name: "UnrestrictedSharedArrayBuffer",
base_feature: "none",
origin_trial_feature_name: "UnrestrictedSharedArrayBuffer",
@@ -18,7 +18,7 @@
},
{
name: "URLPatternCompareComponent",
-@@ -3812,12 +3812,12 @@
+@@ -3814,12 +3814,12 @@
status: "experimental",
base_feature: "none",
origin_trial_feature_name: "WebAppUrlHandling",