aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 06:21:46 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2007-10-04 06:21:46 +0000
commitb448c924112a2914f0569c0bcec9690b9fa159cd (patch)
tree69d410f5d69f08b523a59ea57e83f8424e28807e
parentcc82ac7af1a4b4743ab599432b8c7f24a774e0c8 (diff)
downloadports-b448c924112a2914f0569c0bcec9690b9fa159cd.tar.gz
ports-b448c924112a2914f0569c0bcec9690b9fa159cd.zip
Remove always-false/true conditions based on OSVERSION 500000
Notes
Notes: svn path=/head/; revision=200793
-rw-r--r--textproc/estraier/Makefile2
-rw-r--r--textproc/heirloom-doctools/Makefile4
-rw-r--r--textproc/highlight/Makefile8
-rw-r--r--textproc/htdig/Makefile4
-rw-r--r--textproc/libebml/Makefile8
-rw-r--r--textproc/libxml++/Makefile13
-rw-r--r--textproc/nltk/Makefile8
-rw-r--r--textproc/uim/Makefile4
-rw-r--r--www/campsite/Makefile8
-rw-r--r--www/dfileserver/Makefile8
-rw-r--r--www/dtse/Makefile4
-rw-r--r--www/firefox-esr/Makefile4
-rw-r--r--www/firefox/Makefile4
-rw-r--r--www/firefox36/Makefile4
-rw-r--r--www/galeon/Makefile3
-rw-r--r--www/junkbuster/Makefile8
-rw-r--r--www/kazehakase/Makefile4
-rw-r--r--www/opera/Makefile6
-rw-r--r--www/pecl-pecl_http/Makefile2
-rw-r--r--www/polipo/Makefile4
-rw-r--r--www/seamonkey/Makefile5
-rw-r--r--www/seamonkey2/Makefile5
-rw-r--r--www/tinyproxy/Makefile7
-rw-r--r--www/wwwoffle/Makefile8
-rw-r--r--www/xulrunner/Makefile5
25 files changed, 14 insertions, 126 deletions
diff --git a/textproc/estraier/Makefile b/textproc/estraier/Makefile
index ba1f28f7a8a3..2eb4625a32f7 100644
--- a/textproc/estraier/Makefile
+++ b/textproc/estraier/Makefile
@@ -41,13 +41,11 @@ LIB_DEPENDS+= chasen.0:${PORTSDIR}/japanese/chasen-base
CONFIGURE_ARGS+= --enable-chasen
.endif
-.if ${OSVERSION} > 500000
.if ${ARCH} == i386 && defined(WITH_MECAB)
LIB_DEPENDS+= mecab.1:${PORTSDIR}/japanese/mecab
CONFIGURE_ARGS+= --enable-mecab
.endif
-.endif
.if !defined(WITHOUT_KAKASI)
LIB_DEPENDS+= kakasi.3:${PORTSDIR}/japanese/kakasi
diff --git a/textproc/heirloom-doctools/Makefile b/textproc/heirloom-doctools/Makefile
index 94e90961f973..d2fa2d68944d 100644
--- a/textproc/heirloom-doctools/Makefile
+++ b/textproc/heirloom-doctools/Makefile
@@ -58,9 +58,7 @@ DOCS= CHANGES FONTS NEWS PDFS README \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-IGNORE= Does not compile on FreeBSD 4.x
-.elif ${OSVERSION} < 600000
+.if ${OSVERSION} < 600000
BROKEN= fails to install on FreeBSD 5.x
.endif
diff --git a/textproc/highlight/Makefile b/textproc/highlight/Makefile
index 2dbec4117714..c0dc29336ea3 100644
--- a/textproc/highlight/Makefile
+++ b/textproc/highlight/Makefile
@@ -34,12 +34,6 @@ MANCOMPRESSED= yes
PORTDOCS= *
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile
-.endif
-
post-patch:
@${REINPLACE_CMD} -e \
's|/etc/highlight|${DATADIR}|g' ${WRKSRC}/datadir.cpp
@@ -77,4 +71,4 @@ post-install:
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/htdig/Makefile b/textproc/htdig/Makefile
index 8836f9a28b62..af7feb508ff8 100644
--- a/textproc/htdig/Makefile
+++ b/textproc/htdig/Makefile
@@ -46,10 +46,6 @@ CONFIGURE_ARGS+= --with-apache=${LOCALBASE}/sbin
RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/${APACHE_PORT}
.endif
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${PATCHDIR}/RELENG_4-patch-htnet_SSLConnection.cc
-.endif
-
post-patch:
@${FIND} ${WRKSRC} -name configure | ${XARGS} ${REINPLACE_CMD} -e 's|echo aout|echo elf|'
diff --git a/textproc/libebml/Makefile b/textproc/libebml/Makefile
index 298881388f5c..f9b671f3860e 100644
--- a/textproc/libebml/Makefile
+++ b/textproc/libebml/Makefile
@@ -37,10 +37,4 @@ do-configure:
s,^(INSTALL_OPTS_LIB|INSTALL_OPTS)[[:space:]]*=.*$$,\1=${INSTALL_DATA},' \
${WRKSRC}/make/linux/Makefile
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-CFLAGS+= -DNO_WSTRING
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/libxml++/Makefile b/textproc/libxml++/Makefile
index dff8bc43b43b..96246017a733 100644
--- a/textproc/libxml++/Makefile
+++ b/textproc/libxml++/Makefile
@@ -21,15 +21,4 @@ USE_GNOME= gnomehack gnometarget libxml2 pkgconfig
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-post-patch:
- @${FIND} ${WRKSRC}/libxml++ -name *.h \
- | ${XARGS} ${REINPLACE_CMD} \
- -e 's|<istream>|<iostream>|' \
- -e 's|<ostream>|<iostream>|'
-
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/nltk/Makefile b/textproc/nltk/Makefile
index 0fe692b8beab..4c30ee245ceb 100644
--- a/textproc/nltk/Makefile
+++ b/textproc/nltk/Makefile
@@ -19,16 +19,10 @@ USE_PYTHON= 2.3+
USE_PYDISTUTILS= yes
USE_PYTHON_PREFIX= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "alpha" && ${OSVERSION} < 500000
-BROKEN= Coredump during build on alpha 4.x
-.endif
-
post-install:
@${FIND} ${PYTHON_SITELIBDIR}/nltk ! -type d | \
${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${PYTHON_SITELIBDIR}/nltk -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index 3b2566373776..5aeb268b249b 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -59,10 +59,6 @@ PLIST_SUB+= X11=""
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-EXTRA_PATCHES+= ${PATCHDIR}/extra-patch-uim_editline.c
-.endif
-
.for _x in x xft gtk2 qt gnome2 anthy canna m17nlib prime scim dict
.if ${CONFIGURE_ARGS:M--with-${_x}} == ""
CONFIGURE_ARGS+=--without-${_x}
diff --git a/www/campsite/Makefile b/www/campsite/Makefile
index 5ec840fe5936..bb7125f1e3d8 100644
--- a/www/campsite/Makefile
+++ b/www/campsite/Makefile
@@ -43,12 +43,6 @@ USE_GMAKE= yes
SUB_FILES= pkg-message pkg-install pkg-deinstall crontab.in
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= does not compile
-.endif
-
post-patch:
@${FIND} ${WRKSRC} -type f -perm 755 \
-or -name campsite_create_instance \
@@ -69,4 +63,4 @@ post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/dfileserver/Makefile b/www/dfileserver/Makefile
index fe408dcdc229..581a4c114f30 100644
--- a/www/dfileserver/Makefile
+++ b/www/dfileserver/Makefile
@@ -19,12 +19,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
MAKE_ENV= CXX=${CXX}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4+
-.endif
-
post-patch:
${REINPLACE_CMD} 's,g++,${CXX},;s,$$GCCFLAGS,${CXXFLAGS},; \
s,strip,${STRIP_CMD},' ${WRKSRC}/build.sh
@@ -36,4 +30,4 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/DFileServer.x86 ${PREFIX}/bin/dfileserver
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/dtse/Makefile b/www/dtse/Makefile
index 547f6a38f3a1..d7c8c971f1d6 100644
--- a/www/dtse/Makefile
+++ b/www/dtse/Makefile
@@ -32,10 +32,6 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4
-.endif
-
.if ${PERL_LEVEL} < 500800
BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.endif
diff --git a/www/firefox-esr/Makefile b/www/firefox-esr/Makefile
index 84823e17d917..3e48e4eeb15a 100644
--- a/www/firefox-esr/Makefile
+++ b/www/firefox-esr/Makefile
@@ -52,10 +52,6 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 pthread | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
-.if ${OSVERSION} < 500000
-BROKEN= does not build
-.endif
-
.if ${ARCH} == "sparc64" && ${OSVERSION} < 601101
IGNORE= does not run, update to 6.2-RELEASE or newer
.endif
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 84823e17d917..3e48e4eeb15a 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -52,10 +52,6 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 pthread | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
-.if ${OSVERSION} < 500000
-BROKEN= does not build
-.endif
-
.if ${ARCH} == "sparc64" && ${OSVERSION} < 601101
IGNORE= does not run, update to 6.2-RELEASE or newer
.endif
diff --git a/www/firefox36/Makefile b/www/firefox36/Makefile
index 84823e17d917..3e48e4eeb15a 100644
--- a/www/firefox36/Makefile
+++ b/www/firefox36/Makefile
@@ -52,10 +52,6 @@ OPTIONS= NEWTAB "Open external links in a new tab" on \
GECKO_PTHREAD_LIBS!=${CC} -dumpspecs | ${GREP} -m 1 pthread | ${SED} -e 's|^.*%{\!pg: %{pthread:|| ; s|}.*$$||' || ${TRUE}
-.if ${OSVERSION} < 500000
-BROKEN= does not build
-.endif
-
.if ${ARCH} == "sparc64" && ${OSVERSION} < 601101
IGNORE= does not run, update to 6.2-RELEASE or newer
.endif
diff --git a/www/galeon/Makefile b/www/galeon/Makefile
index 2b8e9f3f13eb..31b77a68cec4 100644
--- a/www/galeon/Makefile
+++ b/www/galeon/Makefile
@@ -38,11 +38,10 @@ GCONF_SCHEMAS= galeon.schemas
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
-.if ${OSVERSION} > 500000
# Galeon does not build correctly in -CURRENT if -Werror is passed
# to the compiler.
NO_WERROR= yes
-.endif
+
# allow build with more warnings enabled
.if defined(NO_WERROR)
CONFIGURE_ARGS+= --disable-werror
diff --git a/www/junkbuster/Makefile b/www/junkbuster/Makefile
index e15d2aeca6f5..41b454899e9f 100644
--- a/www/junkbuster/Makefile
+++ b/www/junkbuster/Makefile
@@ -23,13 +23,7 @@ SUB_FILES= junkbuster.sh pkg-message
USE_RC_SUBR= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-
-.if ( ${OSVERSION} >= 500000 )
GNUREGEXP= 's:gnu_regex.h:gnu/regex.h:'
-.else
-GNUREGEXP= 's:gnu_regex.h:gnuregex.h:'
-.endif
post-patch:
.for f in junkbstr.ini saclfile.ini sblock.ini scookie.ini sforward.ini strust.ini win32.h
@@ -56,4 +50,4 @@ do-install:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/kazehakase/Makefile b/www/kazehakase/Makefile
index 827e344d503c..b5040d2737b0 100644
--- a/www/kazehakase/Makefile
+++ b/www/kazehakase/Makefile
@@ -39,10 +39,6 @@ RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/uconv.so:${PORTSDIR}/japanese/ruby-uconv
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../www/mozilla/bsd.gecko.mk"
-.if ${OSVERSION} < 500000
-IGNORE=Does not build
-.endif
-
# !!! gtk-webcore higly experimental right now and not very stable !!!
# See https://mail.gna.org/public/kazehakase-devel/2004-10/msg00001.html
# on how to use gtk-webcore with kazehakase. and yes you still have to
diff --git a/www/opera/Makefile b/www/opera/Makefile
index 18013c2309da..066969110a5f 100644
--- a/www/opera/Makefile
+++ b/www/opera/Makefile
@@ -61,10 +61,8 @@ QT_PRESENT= off
OPERA_TYPE= 1
.elif ${OSVERSION} >= 600000
OPERA_TYPE= 4
-.elif ${OSVERSION} >= 500000
-OPERA_TYPE= 3
.else
-OPERA_TYPE= 1
+OPERA_TYPE= 3
.endif
.if ${OSVERSION} > 700000
@@ -86,7 +84,7 @@ OPERA_LIB= static
OPERA_TYPE= 1
.endif
-.if ${OPERA_TYPE} == 1 && ${OSVERSION} >= 500000
+.if ${OPERA_TYPE} == 1
LIB_DEPENDS+= c_r.4:${PORTSDIR}/misc/compat4x
.if ${OSVERSION} >= 600000
LIB_DEPENDS+= z.2:${PORTSDIR}/misc/compat5x
diff --git a/www/pecl-pecl_http/Makefile b/www/pecl-pecl_http/Makefile
index 7851372564cf..ea96e1c99001 100644
--- a/www/pecl-pecl_http/Makefile
+++ b/www/pecl-pecl_http/Makefile
@@ -50,7 +50,7 @@ CONFIGURE_ARGS+=--with-http-magic-mime=${MAGICBASE}
CONFIGURE_ARGS+=--without-http-magic-mime
.endif
-.if defined(WITH_ZLIB_COMPRESSION) && ${OSVERSION} > 500000
+.if defined(WITH_ZLIB_COMPRESSION)
CONFIGURE_ARGS+=--with-http-zlib-compression=/usr
.else
CONFIGURE_ARGS+=--without-http-zlib-compression
diff --git a/www/polipo/Makefile b/www/polipo/Makefile
index 524fea0b0faa..89b05c028c51 100644
--- a/www/polipo/Makefile
+++ b/www/polipo/Makefile
@@ -20,10 +20,6 @@ USE_RC_SUBR= polipo.sh
.include <bsd.port.pre.mk>
-# in some 4.x makeinfo does not work. So we do not try to build and install.
-.if ${OSVERSION} < 500000
-NO_PTEXINFO= yes
-.endif
.if defined(NO_PTEXINFO)
ALL_TARGET= polipo
NOPORTDOCS= yes
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index b3541f1ff248..dcfc7bb86f25 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -62,11 +62,6 @@ IGNORE= core dumps on ${ARCH} during post-build
IGNORE= core dumps on ${ARCH}, need kern.osreldate>=601101
.endif
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-security_manager_Makefile.in
-.endif
-
.if defined(WITHOUT_MAILNEWS)
MOZ_OPTIONS+= --disable-ldap --disable-mailnews
.else
diff --git a/www/seamonkey2/Makefile b/www/seamonkey2/Makefile
index b3541f1ff248..dcfc7bb86f25 100644
--- a/www/seamonkey2/Makefile
+++ b/www/seamonkey2/Makefile
@@ -62,11 +62,6 @@ IGNORE= core dumps on ${ARCH} during post-build
IGNORE= core dumps on ${ARCH}, need kern.osreldate>=601101
.endif
-.if ${OSVERSION} < 500000
-USE_GCC= 3.4
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-security_manager_Makefile.in
-.endif
-
.if defined(WITHOUT_MAILNEWS)
MOZ_OPTIONS+= --disable-ldap --disable-mailnews
.else
diff --git a/www/tinyproxy/Makefile b/www/tinyproxy/Makefile
index ce4312d85fbb..592593907ee4 100644
--- a/www/tinyproxy/Makefile
+++ b/www/tinyproxy/Makefile
@@ -24,15 +24,10 @@ CONFIGURE_ARGS= --bindir=${PREFIX}/sbin \
MAN8= tinyproxy.8
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|-O2||' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|/etc/tinyproxy/tinyproxy.conf|${PREFIX}/etc/tinyproxy.conf|' \
${WRKSRC}/doc/tinyproxy.8
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's|stdint.h|stdlib.h|' ${WRKSRC}/src/scanner.c
-.endif
post-install:
@if [ ! -f ${PREFIX}/etc/tinyproxy.conf ]; then \
@@ -40,4 +35,4 @@ post-install:
${PREFIX}/etc/tinyproxy.conf ; \
fi
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/wwwoffle/Makefile b/www/wwwoffle/Makefile
index 2f49b3923f9f..3ab54cc7ad6c 100644
--- a/www/wwwoffle/Makefile
+++ b/www/wwwoffle/Makefile
@@ -39,12 +39,6 @@ MAN1= wwwoffle.1
MAN5= wwwoffle.conf.5
MAN8= wwwoffled.8
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on 4.x
-.endif
-
.if ${WWWOFFLE_SPOOL} != "/var/spool/wwwoffle"
# If using a non-standard spool, change all the documentation (and anything
# else) to reflect that.
@@ -60,4 +54,4 @@ post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/conf/upgrade-config.pl ${WWWOFFLE_SPOOL}
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/xulrunner/Makefile b/www/xulrunner/Makefile
index 1ec16436be1b..bd2d708ebaac 100644
--- a/www/xulrunner/Makefile
+++ b/www/xulrunner/Makefile
@@ -33,9 +33,4 @@ USE_GECKO_OPTIONS= java debug logging optimized_cflags
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/www/mozilla/Makefile.common"
-
-.if ${OSVERSION} < 500000
-BROKEN= does not build
-.endif
-
.include <bsd.port.post.mk>