aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2023-11-02 17:59:19 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2023-11-02 17:59:19 +0000
commitb4d7b4b8d8dcf97208f9b5afb1f963116c9e3d7b (patch)
tree55f04f7dda99eb09e8010147505ef13a8b276b21
parent6bdd9a3cb9a3954958a2da50140ced8828fefb9b (diff)
downloadports-b4d7b4b8d8dcf97208f9b5afb1f963116c9e3d7b.tar.gz
ports-b4d7b4b8d8dcf97208f9b5afb1f963116c9e3d7b.zip
www/varnish-ip2location: Update to upstream commit 32ff41a, bump
-rw-r--r--www/varnish-ip2location/Makefile4
-rw-r--r--www/varnish-ip2location/distinfo6
-rw-r--r--www/varnish-ip2location/files/patch-src_vmod__ip2location.c44
3 files changed, 5 insertions, 49 deletions
diff --git a/www/varnish-ip2location/Makefile b/www/varnish-ip2location/Makefile
index d4d4375f882c..049d0992087a 100644
--- a/www/varnish-ip2location/Makefile
+++ b/www/varnish-ip2location/Makefile
@@ -1,6 +1,6 @@
PORTNAME= ip2location
PORTVERSION= 1.0.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www
PKGNAMEPREFIX= varnish-
@@ -30,7 +30,7 @@ CFLAGS+= -I${WRKSRC}/src
USE_GITHUB= yes
GH_ACCOUNT= ip2location
GH_PROJECT= ${PORTNAME}-varnish
-GH_TAGNAME= b24b36e
+GH_TAGNAME= 32ff41a
OPTIONS_DEFINE= DOCS
diff --git a/www/varnish-ip2location/distinfo b/www/varnish-ip2location/distinfo
index f9aa9c41c473..baa10f951a60 100644
--- a/www/varnish-ip2location/distinfo
+++ b/www/varnish-ip2location/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1649431734
-SHA256 (ip2location-ip2location-varnish-1.0.3-b24b36e_GH0.tar.gz) = 3c8e5220c6a1807cde5dc53a76201ef3674e73afee94b61e1180edbe707e930f
-SIZE (ip2location-ip2location-varnish-1.0.3-b24b36e_GH0.tar.gz) = 6667
+TIMESTAMP = 1698945834
+SHA256 (ip2location-ip2location-varnish-1.0.3-32ff41a_GH0.tar.gz) = 5b741cb1d101105b5363218d69d62dff597f132e515c5492c4d317d5dbcd59f1
+SIZE (ip2location-ip2location-varnish-1.0.3-32ff41a_GH0.tar.gz) = 6735
diff --git a/www/varnish-ip2location/files/patch-src_vmod__ip2location.c b/www/varnish-ip2location/files/patch-src_vmod__ip2location.c
deleted file mode 100644
index 3f2ff55e821a..000000000000
--- a/www/varnish-ip2location/files/patch-src_vmod__ip2location.c
+++ /dev/null
@@ -1,44 +0,0 @@
---- src/vmod_ip2location.c.orig 2020-11-29 23:51:52 UTC
-+++ src/vmod_ip2location.c
-@@ -6,6 +6,11 @@
-
- #include <IP2Location.h>
-
-+#ifdef __FreeBSD__
-+#include <stdio.h>
-+#define gcvt(v, d, c) sprintf(c, "%*g", d, v);
-+#endif
-+
- #include "cache/cache.h"
-
- #ifndef VRT_H_INCLUDED
-@@ -13,12 +18,19 @@
- #endif
-
- void
--i2pl_free(void *obj)
-+ip2l_free(VRT_CTX, void *obj)
- {
- AN(obj);
-+ CHECK_OBJ_NOTNULL(ctx, VRT_CTX_MAGIC);
- IP2Location_close((IP2Location *)obj);
- }
-
-+static const struct vmod_priv_methods ip2l_methods[1] = {{
-+ .magic = VMOD_PRIV_METHODS_MAGIC,
-+ .type = "vmod_std_ip2location",
-+ .fini = ip2l_free
-+}};
-+
- VCL_VOID
- vmod_init_db(VRT_CTX, struct vmod_priv *priv, char *filename, char *memtype)
- {
-@@ -51,7 +63,7 @@ vmod_init_db(VRT_CTX, struct vmod_priv *priv, char *fi
- IP2Location_set_lookup_mode(IP2LocationObj, mtype);
-
- priv->priv = IP2LocationObj;
-- priv->free = i2pl_free;
-+ priv->methods = ip2l_methods;
- }
-
- static VCL_STRING