aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-06-15 13:39:39 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-06-15 13:39:39 +0000
commitb50b5fdd0e3c710296f81b62255b66a71095fd01 (patch)
treed88460a3414d81443d679044775707dfcdf054f6
parent9227a0e954006f833de64c37fa4d04f7f61fd72a (diff)
downloadports-b50b5fdd0e3c710296f81b62255b66a71095fd01.tar.gz
ports-b50b5fdd0e3c710296f81b62255b66a71095fd01.zip
sysutils/fusefs-curlftpfs: unbreak build
- Unbreak build for FreeBSD >= 9 [1] - Add LICENSE (GPLv2) PR: ports/174606 [1] Submitted by: ARAI Toshihiko <arai.toshihiko@gmail.com> Approved by: culot / jpaetzel (mentors, implicit), maintainer (timeout)
Notes
Notes: svn path=/head/; revision=320997
-rw-r--r--sysutils/fusefs-curlftpfs/Makefile13
-rw-r--r--sysutils/fusefs-curlftpfs/files/extra-32-ftpfs.h11
-rw-r--r--sysutils/fusefs-curlftpfs/files/extra-64-ftpfs.h11
-rw-r--r--sysutils/fusefs-curlftpfs/files/extra-patch-ftpfs.c (renamed from sysutils/fusefs-curlftpfs/files/patch-ftpfs.c)0
4 files changed, 32 insertions, 3 deletions
diff --git a/sysutils/fusefs-curlftpfs/Makefile b/sysutils/fusefs-curlftpfs/Makefile
index 24a714406037..36dc03318fd0 100644
--- a/sysutils/fusefs-curlftpfs/Makefile
+++ b/sysutils/fusefs-curlftpfs/Makefile
@@ -11,6 +11,8 @@ PKGNAMEPREFIX= fusefs-
MAINTAINER= dhn@FreeBSD.org
COMMENT= Mount remote ftp directories
+LICENSE= GPLv2
+
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl
GNU_CONFIGURE= yes
@@ -21,8 +23,13 @@ PLIST_FILES= bin/curlftpfs
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 900000
-BROKEN= does not build
+.if ${OSVERSION} >= 1000000
+EXTRA_PATCHES+= ${FILESDIR}/extra-64-ftpfs.h
+.else
+EXTRA_PATCHES+= ${FILESDIR}/extra-32-ftpfs.h
+.endif
+.if ${OSVERSION} < 900000
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-ftpfs.c
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.post.mk>
diff --git a/sysutils/fusefs-curlftpfs/files/extra-32-ftpfs.h b/sysutils/fusefs-curlftpfs/files/extra-32-ftpfs.h
new file mode 100644
index 000000000000..6fc7b5f4f862
--- /dev/null
+++ b/sysutils/fusefs-curlftpfs/files/extra-32-ftpfs.h
@@ -0,0 +1,11 @@
+--- ftpfs.h.orig 2008-04-25 19:32:30.000000000 +0900
++++ ftpfs.h 2012-12-21 18:18:20.000000000 +0900
+@@ -75,7 +75,7 @@
+ do { if (level <= ftpfs.debug) {\
+ int i = 0; \
+ while (++i < level) fprintf(stderr, " "); \
+- fprintf(stderr, "%ld ", time(NULL));\
++ fprintf(stderr, "%d ", time(NULL));\
+ fprintf(stderr, __FILE__ ":%d ", __LINE__);\
+ fprintf(stderr, args);\
+ }\
diff --git a/sysutils/fusefs-curlftpfs/files/extra-64-ftpfs.h b/sysutils/fusefs-curlftpfs/files/extra-64-ftpfs.h
new file mode 100644
index 000000000000..bb9dd7609ed1
--- /dev/null
+++ b/sysutils/fusefs-curlftpfs/files/extra-64-ftpfs.h
@@ -0,0 +1,11 @@
+--- ftpfs.h.orig 2008-04-25 19:32:30.000000000 +0900
++++ ftpfs.h 2012-12-21 18:18:20.000000000 +0900
+@@ -75,7 +75,7 @@
+ do { if (level <= ftpfs.debug) {\
+ int i = 0; \
+ while (++i < level) fprintf(stderr, " "); \
+- fprintf(stderr, "%ld ", time(NULL));\
++ fprintf(stderr, "%lld ", time(NULL));\
+ fprintf(stderr, __FILE__ ":%d ", __LINE__);\
+ fprintf(stderr, args);\
+ }\
diff --git a/sysutils/fusefs-curlftpfs/files/patch-ftpfs.c b/sysutils/fusefs-curlftpfs/files/extra-patch-ftpfs.c
index 42f6e1c4ee12..42f6e1c4ee12 100644
--- a/sysutils/fusefs-curlftpfs/files/patch-ftpfs.c
+++ b/sysutils/fusefs-curlftpfs/files/extra-patch-ftpfs.c