aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-12-16 14:51:13 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-12-16 14:51:13 +0000
commitb51723216c0b8d56c0463a22c43453504b219ffc (patch)
treea00d57432dd71d73fb2b43626f0d4fc9fd4bb1bd
parent2348c94e53a5f5bcdd7528d9edebf39423751959 (diff)
downloadports-b51723216c0b8d56c0463a22c43453504b219ffc.tar.gz
ports-b51723216c0b8d56c0463a22c43453504b219ffc.zip
- Add databases/p5-SQL-NamedPlaceholder
SQL::NamedPlaceholder is extension of placeholder. This enable more readable and robust code. WWW: https://metacpan.org/release/SQL-NamedPlaceholder PR: 242020 Submitted by: bokutin@bokut.in
Notes
Notes: svn path=/head/; revision=520264
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-SQL-NamedPlaceholder/Makefile28
-rw-r--r--databases/p5-SQL-NamedPlaceholder/distinfo3
-rw-r--r--databases/p5-SQL-NamedPlaceholder/pkg-descr4
4 files changed, 36 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index ed2114d8650b..57c9fbb6f4f3 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -493,6 +493,7 @@
SUBDIR += p5-SQL-Abstract-Plugin-InsertMulti
SUBDIR += p5-SQL-Interp
SUBDIR += p5-SQL-Maker
+ SUBDIR += p5-SQL-NamedPlaceholder
SUBDIR += p5-SQL-ReservedWords
SUBDIR += p5-SQL-Statement
SUBDIR += p5-SQL-Translator
diff --git a/databases/p5-SQL-NamedPlaceholder/Makefile b/databases/p5-SQL-NamedPlaceholder/Makefile
new file mode 100644
index 000000000000..009a262a9ab7
--- /dev/null
+++ b/databases/p5-SQL-NamedPlaceholder/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= SQL-NamedPlaceholder
+PORTVERSION= 0.10
+CATEGORIES= databases perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR=CPAN:SATOH
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= bokutin@bokut.in
+COMMENT= Extension of placeholder
+
+LICENSE= ART10 GPLv1+
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Module-Build>=0:devel/p5-Module-Build \
+ p5-Module-Build-Tiny>=0.035:devel/p5-Module-Build-Tiny
+RUN_DEPENDS= p5-Exporter-Lite>=0:devel/p5-Exporter-Lite
+TEST_DEPENDS= p5-Test-Fatal>=0:devel/p5-Test-Fatal
+
+USES= perl5
+USE_PERL5= modbuild
+PLIST_FILES= ${SITE_PERL_REL}/SQL/NamedPlaceholder.pm \
+ ${SITE_MAN3_REL}/SQL::NamedPlaceholder.3.gz
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/databases/p5-SQL-NamedPlaceholder/distinfo b/databases/p5-SQL-NamedPlaceholder/distinfo
new file mode 100644
index 000000000000..58f64702409e
--- /dev/null
+++ b/databases/p5-SQL-NamedPlaceholder/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1560854140
+SHA256 (SQL-NamedPlaceholder-0.10.tar.gz) = a87468204cb3d5a3ba329c1991bc68dcaa6b454724078db67779c03086d841ab
+SIZE (SQL-NamedPlaceholder-0.10.tar.gz) = 10338
diff --git a/databases/p5-SQL-NamedPlaceholder/pkg-descr b/databases/p5-SQL-NamedPlaceholder/pkg-descr
new file mode 100644
index 000000000000..5e5c7e0e41e7
--- /dev/null
+++ b/databases/p5-SQL-NamedPlaceholder/pkg-descr
@@ -0,0 +1,4 @@
+SQL::NamedPlaceholder is extension of placeholder.
+This enable more readable and robust code.
+
+WWW: https://metacpan.org/release/SQL-NamedPlaceholder