aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-07-13 16:17:29 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-07-13 16:17:29 +0000
commitb51f27f333b5cfd8f7b7a5bbf63dd3013ed814a9 (patch)
tree9b7eab39cc0a18ae4580ccf4a84e572cd1ab3f5b
parentb09689878c765dc13b2a3089f51113cdd49957e2 (diff)
downloadports-b51f27f333b5cfd8f7b7a5bbf63dd3013ed814a9.tar.gz
ports-b51f27f333b5cfd8f7b7a5bbf63dd3013ed814a9.zip
Initial import of ldapmodule.
ldapmodule is an LDAP module for python PR: 19781 Submitted by: Dirk Meyer <dirk.meyer@dinoex.sub.org>
Notes
Notes: svn path=/head/; revision=30582
-rw-r--r--net/Makefile1
-rw-r--r--net/ldapmodule/Makefile23
-rw-r--r--net/ldapmodule/distinfo1
-rw-r--r--net/ldapmodule/pkg-comment1
-rw-r--r--net/ldapmodule/pkg-descr10
-rw-r--r--net/ldapmodule/pkg-plist2
-rw-r--r--net/py-ldap1/Makefile23
-rw-r--r--net/py-ldap1/distinfo1
-rw-r--r--net/py-ldap1/pkg-comment1
-rw-r--r--net/py-ldap1/pkg-descr10
-rw-r--r--net/py-ldap1/pkg-plist2
-rw-r--r--net/py-ldap2/Makefile23
-rw-r--r--net/py-ldap2/distinfo1
-rw-r--r--net/py-ldap2/pkg-comment1
-rw-r--r--net/py-ldap2/pkg-descr10
-rw-r--r--net/py-ldap2/pkg-plist2
16 files changed, 112 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 7ca2ae7114f4..8fe4ea1f9f5c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -106,6 +106,7 @@
SUBDIR += kxicq
SUBDIR += lambdamoo
SUBDIR += ldap
+ SUBDIR += ldapmodule
SUBDIR += ldapsdk
SUBDIR += libetherx
SUBDIR += libicq
diff --git a/net/ldapmodule/Makefile b/net/ldapmodule/Makefile
new file mode 100644
index 000000000000..574310c09788
--- /dev/null
+++ b/net/ldapmodule/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: ldapmodule
+# Date created: 05.Jul 2000
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+
+PORTNAME= ldapmodule
+PORTVERSION= 1.9
+CATEGORIES= net
+MASTER_SITES= http://archive.csee.uq.edu.au/~leonard/dc-prj/ldapmodule/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-alpha
+
+MAINTAINER= dirk.meyer@dinoex.sub.org
+
+LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/ldapmodule/distinfo b/net/ldapmodule/distinfo
new file mode 100644
index 000000000000..92ff002e485f
--- /dev/null
+++ b/net/ldapmodule/distinfo
@@ -0,0 +1 @@
+MD5 (ldapmodule-1.9-alpha.tar.gz) = 6918466d2c8ce2ed5e91785d433cd1a1
diff --git a/net/ldapmodule/pkg-comment b/net/ldapmodule/pkg-comment
new file mode 100644
index 000000000000..1ffd4b8f590d
--- /dev/null
+++ b/net/ldapmodule/pkg-comment
@@ -0,0 +1 @@
+An LDAP module for phyton
diff --git a/net/ldapmodule/pkg-descr b/net/ldapmodule/pkg-descr
new file mode 100644
index 000000000000..8dd6dae6fb16
--- /dev/null
+++ b/net/ldapmodule/pkg-descr
@@ -0,0 +1,10 @@
+
+ LDAP Wrapper for Python
+
+ This module provides an LDAP API to Python in the spirit of RFC1823.
+
+Some cool things people have done with ldapmodule
+
+ * LANL phone book (source)
+ * Michael Stroeder's web2ldap (previously ldap-client-cgi.py).
+ * LDAP support for Zope (see also Zope)
diff --git a/net/ldapmodule/pkg-plist b/net/ldapmodule/pkg-plist
new file mode 100644
index 000000000000..7baaa1362546
--- /dev/null
+++ b/net/ldapmodule/pkg-plist
@@ -0,0 +1,2 @@
+lib/python1.5/site-packages/ldapmodule.so
+@dirrm lib/python1.5/site-packages
diff --git a/net/py-ldap1/Makefile b/net/py-ldap1/Makefile
new file mode 100644
index 000000000000..574310c09788
--- /dev/null
+++ b/net/py-ldap1/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: ldapmodule
+# Date created: 05.Jul 2000
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+
+PORTNAME= ldapmodule
+PORTVERSION= 1.9
+CATEGORIES= net
+MASTER_SITES= http://archive.csee.uq.edu.au/~leonard/dc-prj/ldapmodule/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-alpha
+
+MAINTAINER= dirk.meyer@dinoex.sub.org
+
+LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/py-ldap1/distinfo b/net/py-ldap1/distinfo
new file mode 100644
index 000000000000..92ff002e485f
--- /dev/null
+++ b/net/py-ldap1/distinfo
@@ -0,0 +1 @@
+MD5 (ldapmodule-1.9-alpha.tar.gz) = 6918466d2c8ce2ed5e91785d433cd1a1
diff --git a/net/py-ldap1/pkg-comment b/net/py-ldap1/pkg-comment
new file mode 100644
index 000000000000..1ffd4b8f590d
--- /dev/null
+++ b/net/py-ldap1/pkg-comment
@@ -0,0 +1 @@
+An LDAP module for phyton
diff --git a/net/py-ldap1/pkg-descr b/net/py-ldap1/pkg-descr
new file mode 100644
index 000000000000..8dd6dae6fb16
--- /dev/null
+++ b/net/py-ldap1/pkg-descr
@@ -0,0 +1,10 @@
+
+ LDAP Wrapper for Python
+
+ This module provides an LDAP API to Python in the spirit of RFC1823.
+
+Some cool things people have done with ldapmodule
+
+ * LANL phone book (source)
+ * Michael Stroeder's web2ldap (previously ldap-client-cgi.py).
+ * LDAP support for Zope (see also Zope)
diff --git a/net/py-ldap1/pkg-plist b/net/py-ldap1/pkg-plist
new file mode 100644
index 000000000000..7baaa1362546
--- /dev/null
+++ b/net/py-ldap1/pkg-plist
@@ -0,0 +1,2 @@
+lib/python1.5/site-packages/ldapmodule.so
+@dirrm lib/python1.5/site-packages
diff --git a/net/py-ldap2/Makefile b/net/py-ldap2/Makefile
new file mode 100644
index 000000000000..574310c09788
--- /dev/null
+++ b/net/py-ldap2/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: ldapmodule
+# Date created: 05.Jul 2000
+# Whom: dirk.meyer@dinoex.sub.org
+#
+# $FreeBSD$
+
+PORTNAME= ldapmodule
+PORTVERSION= 1.9
+CATEGORIES= net
+MASTER_SITES= http://archive.csee.uq.edu.au/~leonard/dc-prj/ldapmodule/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-alpha
+
+MAINTAINER= dirk.meyer@dinoex.sub.org
+
+LIB_DEPENDS= ldap.1:${PORTSDIR}/net/openldap
+BUILD_DEPENDS= python:${PORTSDIR}/lang/python
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/py-ldap2/distinfo b/net/py-ldap2/distinfo
new file mode 100644
index 000000000000..92ff002e485f
--- /dev/null
+++ b/net/py-ldap2/distinfo
@@ -0,0 +1 @@
+MD5 (ldapmodule-1.9-alpha.tar.gz) = 6918466d2c8ce2ed5e91785d433cd1a1
diff --git a/net/py-ldap2/pkg-comment b/net/py-ldap2/pkg-comment
new file mode 100644
index 000000000000..1ffd4b8f590d
--- /dev/null
+++ b/net/py-ldap2/pkg-comment
@@ -0,0 +1 @@
+An LDAP module for phyton
diff --git a/net/py-ldap2/pkg-descr b/net/py-ldap2/pkg-descr
new file mode 100644
index 000000000000..8dd6dae6fb16
--- /dev/null
+++ b/net/py-ldap2/pkg-descr
@@ -0,0 +1,10 @@
+
+ LDAP Wrapper for Python
+
+ This module provides an LDAP API to Python in the spirit of RFC1823.
+
+Some cool things people have done with ldapmodule
+
+ * LANL phone book (source)
+ * Michael Stroeder's web2ldap (previously ldap-client-cgi.py).
+ * LDAP support for Zope (see also Zope)
diff --git a/net/py-ldap2/pkg-plist b/net/py-ldap2/pkg-plist
new file mode 100644
index 000000000000..7baaa1362546
--- /dev/null
+++ b/net/py-ldap2/pkg-plist
@@ -0,0 +1,2 @@
+lib/python1.5/site-packages/ldapmodule.so
+@dirrm lib/python1.5/site-packages