aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2024-07-11 00:46:37 +0000
committerJason E. Hale <jhale@FreeBSD.org>2024-07-11 01:45:32 +0000
commitb5256acd117dbb9692efabed6bdd5b588b1741e9 (patch)
treeba6e001ea022e2358284afbfb5eaeb8beb9cf518
parent2c3fb6ea503a1e12920220860521b0a8b8582c0f (diff)
downloadports-b5256acd117dbb9692efabed6bdd5b588b1741e9.tar.gz
ports-b5256acd117dbb9692efabed6bdd5b588b1741e9.zip
comms/usbmuxd: Update to latest git commit
This is needed to build with the rest of the libimobiledevice stack. See next commit for more details. PR: 280014 Reported by: <fabio.comolli@gmail.com>
-rw-r--r--comms/usbmuxd/Makefile24
-rw-r--r--comms/usbmuxd/distinfo6
-rw-r--r--comms/usbmuxd/files/patch-src_client.c13
3 files changed, 18 insertions, 25 deletions
diff --git a/comms/usbmuxd/Makefile b/comms/usbmuxd/Makefile
index ce219c0512b2..92e22795e166 100644
--- a/comms/usbmuxd/Makefile
+++ b/comms/usbmuxd/Makefile
@@ -1,27 +1,30 @@
PORTNAME= usbmuxd
-DISTVERSION= 1.1.1
-PORTREVISION= 3
+DISTVERSION= 1.1.1-58
+DISTVERSIONSUFFIX= -gbc0b91c
CATEGORIES= comms
-MASTER_SITES= https://github.com/libimobiledevice/${PORTNAME}/releases/download/${PORTVERSION}/
+#MASTER_SITES= https://github.com/libimobiledevice/${PORTNAME}/releases/download/${DISTVERSION}/
MAINTAINER= jhale@FreeBSD.org
COMMENT= Daemon for multiplexing connections over USB to iPhone/iPod Touch
WWW= https://www.libimobiledevice.org
-LICENSE= GPLv2 GPLv3
-LICENSE_COMB= dual
+LICENSE= GPLv2 GPLv3
+LICENSE_COMB= dual
LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING.GPLv2
LICENSE_FILE_GPLv3= ${WRKSRC}/COPYING.GPLv3
LIB_DEPENDS= libplist-2.0.so:devel/libplist \
- libimobiledevice-1.0.so:comms/libimobiledevice
+ libimobiledevice-1.0.so:comms/libimobiledevice \
+ libimobiledevice-glue-1.0.so:comms/libimobiledevice-glue
-USES= autoreconf cpe libtool localbase pathfix pkgconfig tar:bzip2
+USES= autoreconf cpe libtool localbase pathfix pkgconfig
CPE_VENDOR= nikias_bassen
+USE_GITHUB= yes
+GH_ACCOUNT= libimobiledevice
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-systemd
-GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
SUB_LIST= USERS=${USERS} \
GROUPS=${GROUPS}
@@ -39,9 +42,12 @@ OPTIONS_DEFAULT= DEVD
DEVD_SUB_FILES= ${PORTNAME}.conf
DEVD_PLIST_FILES= etc/devd/${PORTNAME}.conf
+post-patch:
+ @echo "${DISTVERSIONFULL}" > ${WRKSRC}/.tarball-version
+
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
post-install-DEVD-on:
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/devd
diff --git a/comms/usbmuxd/distinfo b/comms/usbmuxd/distinfo
index 9a6d75721b02..532706a3035e 100644
--- a/comms/usbmuxd/distinfo
+++ b/comms/usbmuxd/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1611089774
-SHA256 (usbmuxd-1.1.1.tar.bz2) = c0ec9700172bf635ccb5bed98daae607d2925c2bc3597f25706ecd9dfbfd2d9e
-SIZE (usbmuxd-1.1.1.tar.bz2) = 345290
+TIMESTAMP = 1720421685
+SHA256 (libimobiledevice-usbmuxd-1.1.1-58-gbc0b91c_GH0.tar.gz) = 2a88c8a27ba43cf00e9aed5b09791a5ce651758a87dc802954c73b0690ddacab
+SIZE (libimobiledevice-usbmuxd-1.1.1-58-gbc0b91c_GH0.tar.gz) = 65593
diff --git a/comms/usbmuxd/files/patch-src_client.c b/comms/usbmuxd/files/patch-src_client.c
deleted file mode 100644
index 4065dd4c615c..000000000000
--- a/comms/usbmuxd/files/patch-src_client.c
+++ /dev/null
@@ -1,13 +0,0 @@
-client.c:210:18: error: use of undeclared identifier 'IPPROTO_TCP'
- setsockopt(cfd, IPPROTO_TCP, TCP_NODELAY, (void*)&yes, sizeof(int));
-
---- src/client.c.orig 2020-06-09 16:20:07 UTC
-+++ src/client.c
-@@ -31,6 +31,7 @@
- #include <unistd.h>
- #include <sys/types.h>
- #include <sys/socket.h>
-+#include <netinet/in.h>
- #include <netinet/tcp.h>
- #include <sys/un.h>
- #include <arpa/inet.h>