aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-08-18 00:50:46 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-08-18 00:50:46 +0000
commitb59436c4b7b6f3cb4996aca943303e32726bd36c (patch)
treed177dd01843ab0796706a49a00e32e84cd28f5c3
parent584c05109adac8e99340806edceb57d36925d7d3 (diff)
downloadports-b59436c4b7b6f3cb4996aca943303e32726bd36c.tar.gz
ports-b59436c4b7b6f3cb4996aca943303e32726bd36c.zip
devel/ptmalloc port enhancements
- USE_GMAKE is not necessary - make thread aware by using the 'posix' target - add regression-test target - Clean up some unnecessary verbosity. The posix target introduced a lot of warnings but it seems to work. This malloc should behave pretty much like the one in glibc now, but FreeBSD's native malloc is probably better. PR: ports/126547 Submitted by: "Pedro F. Giffuni" <giffunip@tutopia.com>
Notes
Notes: svn path=/head/; revision=218740
-rw-r--r--devel/ptmalloc/Makefile12
-rw-r--r--devel/ptmalloc/pkg-descr10
-rw-r--r--devel/ptmalloc2/Makefile12
-rw-r--r--devel/ptmalloc2/pkg-descr10
4 files changed, 14 insertions, 30 deletions
diff --git a/devel/ptmalloc/Makefile b/devel/ptmalloc/Makefile
index 41e223145fb4..8b41d985305a 100644
--- a/devel/ptmalloc/Makefile
+++ b/devel/ptmalloc/Makefile
@@ -14,11 +14,11 @@ DISTNAME= ${PORTNAME}2-current
MAINTAINER= giffunip@tutopia.com
COMMENT= Alternative threads-aware malloc
-USE_GMAKE= yes
USE_LD_CONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}2
-INCDIR= include/${PORTNAME}
+ALL_TARGET= posix
+INCDIR= include/${PORTNAME}
PLIST_SUB= INCDIR=${INCDIR}
post-patch:
@@ -32,11 +32,7 @@ do-install: all
${LN} -s ${PREFIX}/lib/ptmalloc.so.2 ${PREFIX}/lib/libptmalloc.so
${INSTALL_PROGRAM} ${WRKSRC}/libmalloc.a ${PREFIX}/lib/libptmalloc.a
-post-install:
- @${ECHO_CMD}
- @${ECHO_CMD} Not much documentation is available.
- @${ECHO_CMD} Read ${WRKSRC:S|^${WRKDIRPREFIX}${.CURDIR}/||}/README for what there is.
- @${ECHO_CMD} See also pkg_descr
- @${ECHO_CMD}
+regression-test: build
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
.include <bsd.port.mk>
diff --git a/devel/ptmalloc/pkg-descr b/devel/ptmalloc/pkg-descr
index 4d685884c521..8ed482701dcb 100644
--- a/devel/ptmalloc/pkg-descr
+++ b/devel/ptmalloc/pkg-descr
@@ -1,7 +1,7 @@
ptmalloc is the original version of the malloc that was later included
-in GNU libc. This version is *not* GPL or LGPL:
+in GNU libc. This version is also but *not* exclusively LGPL:
- Copyright (c) 1999 Wolfram Gloger
+ Copyright (c) 2001-2006 Wolfram Gloger
Permission to use, copy, modify, distribute, and sell this software
and its documentation for any purpose is hereby granted without fee,
@@ -21,12 +21,8 @@ in GNU libc. This version is *not* GPL or LGPL:
THEORY OF LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
PERFORMANCE OF THIS SOFTWARE.
-This is not the latest version: it's older than the one in GNU libc.
-
This package comes with no documentation beyond a README, which isn't
worth installing. It appears that the GNU libc man page malloc(3)
-applies, but it's not included here for copyright reasons. There's
-nothing unusual about it. In particular, the section TUNING in
-FreeBSD malloc(3) does not apply.
+applies, but it's not included here for copyright reasons.
WWW: http://www.malloc.de/en/
diff --git a/devel/ptmalloc2/Makefile b/devel/ptmalloc2/Makefile
index 41e223145fb4..8b41d985305a 100644
--- a/devel/ptmalloc2/Makefile
+++ b/devel/ptmalloc2/Makefile
@@ -14,11 +14,11 @@ DISTNAME= ${PORTNAME}2-current
MAINTAINER= giffunip@tutopia.com
COMMENT= Alternative threads-aware malloc
-USE_GMAKE= yes
USE_LD_CONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}2
-INCDIR= include/${PORTNAME}
+ALL_TARGET= posix
+INCDIR= include/${PORTNAME}
PLIST_SUB= INCDIR=${INCDIR}
post-patch:
@@ -32,11 +32,7 @@ do-install: all
${LN} -s ${PREFIX}/lib/ptmalloc.so.2 ${PREFIX}/lib/libptmalloc.so
${INSTALL_PROGRAM} ${WRKSRC}/libmalloc.a ${PREFIX}/lib/libptmalloc.a
-post-install:
- @${ECHO_CMD}
- @${ECHO_CMD} Not much documentation is available.
- @${ECHO_CMD} Read ${WRKSRC:S|^${WRKDIRPREFIX}${.CURDIR}/||}/README for what there is.
- @${ECHO_CMD} See also pkg_descr
- @${ECHO_CMD}
+regression-test: build
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check
.include <bsd.port.mk>
diff --git a/devel/ptmalloc2/pkg-descr b/devel/ptmalloc2/pkg-descr
index 4d685884c521..8ed482701dcb 100644
--- a/devel/ptmalloc2/pkg-descr
+++ b/devel/ptmalloc2/pkg-descr
@@ -1,7 +1,7 @@
ptmalloc is the original version of the malloc that was later included
-in GNU libc. This version is *not* GPL or LGPL:
+in GNU libc. This version is also but *not* exclusively LGPL:
- Copyright (c) 1999 Wolfram Gloger
+ Copyright (c) 2001-2006 Wolfram Gloger
Permission to use, copy, modify, distribute, and sell this software
and its documentation for any purpose is hereby granted without fee,
@@ -21,12 +21,8 @@ in GNU libc. This version is *not* GPL or LGPL:
THEORY OF LIABILITY, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
PERFORMANCE OF THIS SOFTWARE.
-This is not the latest version: it's older than the one in GNU libc.
-
This package comes with no documentation beyond a README, which isn't
worth installing. It appears that the GNU libc man page malloc(3)
-applies, but it's not included here for copyright reasons. There's
-nothing unusual about it. In particular, the section TUNING in
-FreeBSD malloc(3) does not apply.
+applies, but it's not included here for copyright reasons.
WWW: http://www.malloc.de/en/