aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-05-08 07:25:26 +0000
committerWen Heping <wen@FreeBSD.org>2010-05-08 07:25:26 +0000
commitb5ba0fb4ca461bcce2202baf540db394d4cd842e (patch)
treebb57531fb2ec8e57796c0b11463e10f768f63987
parent83b021152a950048aa6d34d6d228ffe12c2c03c5 (diff)
downloadports-b5ba0fb4ca461bcce2202baf540db394d4cd842e.tar.gz
ports-b5ba0fb4ca461bcce2202baf540db394d4cd842e.zip
smtp-cli is a powerful SMTP command line client with a support for
advanced features, such as STARTTLS, SMTP-AUTH, or IPv6 and with a scriptable message composition capabilities supporting anything from simple plain-text messages right up to building complex HTML emails with alternative plain-text part, attachments and inline images. The MIME-Type of the attachments can either be guessed automatically or alternatively set on the command line, separately for each attachment if required. WWW: http://www.logix.cz/michal/devel/smtp-cli/ PR: ports/145937 Submitted by: Frank Wall <fw@moov.de>
Notes
Notes: svn path=/head/; revision=253934
-rw-r--r--mail/Makefile1
-rw-r--r--mail/smtp-cli/Makefile37
-rw-r--r--mail/smtp-cli/distinfo3
-rw-r--r--mail/smtp-cli/pkg-descr10
4 files changed, 51 insertions, 0 deletions
diff --git a/mail/Makefile b/mail/Makefile
index 6888a3c9be4c..2da1970783f4 100644
--- a/mail/Makefile
+++ b/mail/Makefile
@@ -619,6 +619,7 @@
SUBDIR += sma
SUBDIR += smail
SUBDIR += smfsav
+ SUBDIR += smtp-cli
SUBDIR += smtp-gated
SUBDIR += smtpclient
SUBDIR += smtpd
diff --git a/mail/smtp-cli/Makefile b/mail/smtp-cli/Makefile
new file mode 100644
index 000000000000..caa7fa511390
--- /dev/null
+++ b/mail/smtp-cli/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: smtp-cli
+# Date created: Thu Apr 22 10:03:56 CEST 2010
+# Whom: Frank Wall <fw@moov.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smtp
+PORTVERSION= 2.6
+CATEGORIES= mail
+MASTER_SITES= http://www.logix.cz/michal/devel/smtp-cli/
+PKGNAMESUFFIX= -cli
+DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}
+EXTRACT_SUFX=
+
+MAINTAINER= fw@moov.de
+COMMENT= A powerful SMTP command line client
+
+RUN_DEPENDS= p5-IO-Socket-SSL>0:${PORTSDIR}/security/p5-IO-Socket-SSL \
+ p5-Digest-HMAC>0:${PORTSDIR}/security/p5-Digest-HMAC \
+ p5-Term-ReadKey>0:${PORTSDIR}/devel/p5-Term-ReadKey \
+ p5-MIME-Lite>0:${PORTSDIR}/mail/p5-MIME-Lite \
+ p5-File-Type>0:${PORTSDIR}/devel/p5-File-Type \
+ p5-IO-Socket-INET6>0:${PORTSDIR}/net/p5-IO-INET6
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}
+PLIST_FILES= bin/smtp-cli
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/mail/smtp-cli/distinfo b/mail/smtp-cli/distinfo
new file mode 100644
index 000000000000..b0bd9822f6ac
--- /dev/null
+++ b/mail/smtp-cli/distinfo
@@ -0,0 +1,3 @@
+MD5 (smtp-cli) = df21b66ba2d91df8072c70f8970be563
+SHA256 (smtp-cli) = 95e71ba7e86bfb92076a264d179ee7365d9e8f81fd46cd3d1e3725ce37603a5c
+SIZE (smtp-cli) = 24295
diff --git a/mail/smtp-cli/pkg-descr b/mail/smtp-cli/pkg-descr
new file mode 100644
index 000000000000..9614d447cf35
--- /dev/null
+++ b/mail/smtp-cli/pkg-descr
@@ -0,0 +1,10 @@
+smtp-cli is a powerful SMTP command line client with a support for
+advanced features, such as STARTTLS, SMTP-AUTH, or IPv6 and with a
+scriptable message composition capabilities supporting anything
+from simple plain-text messages right up to building complex HTML
+emails with alternative plain-text part, attachments and inline
+images. The MIME-Type of the attachments can either be guessed
+automatically or alternatively set on the command line, separately
+for each attachment if required.
+
+WWW: http://www.logix.cz/michal/devel/smtp-cli/