aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2021-07-06 22:41:36 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2021-07-06 22:49:34 +0000
commitb5ecb8bcbeb3d0574c83be98be1f586cb7e44ab6 (patch)
tree6d6d7a6ed622772b288547f90d25e18ef6ad440b
parent9ffa41537310b846c210cdbaa9217c9fd361c6ae (diff)
downloadports-b5ecb8bcbeb3d0574c83be98be1f586cb7e44ab6.tar.gz
ports-b5ecb8bcbeb3d0574c83be98be1f586cb7e44ab6.zip
textproc/py-rstfmt: Add new port
rstfmt is a tool for automatically formatting reStructuredText files in a consistent way. Like Black and gofmt, the motivation is to provide a format that is reasonable and minimally configurable to prevent teams from wasting time on style discussions (or individuals on manually doing formatting, for that matter). Currently, rstfmt is in a very early stage of development. Not all reST constructs are covered and the interface or formatting may change at any time without warning. WWW: https://github.com/dzhu/rstfmt
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-rstfmt/Makefile27
-rw-r--r--textproc/py-rstfmt/distinfo3
-rw-r--r--textproc/py-rstfmt/pkg-descr12
4 files changed, 43 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index c7c6b3dc573a..7cbdf8c9d171 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1411,6 +1411,7 @@
SUBDIR += py-rss2gen
SUBDIR += py-rst2ansi
SUBDIR += py-rst2html5
+ SUBDIR += py-rstfmt
SUBDIR += py-scour
SUBDIR += py-simplebayes
SUBDIR += py-smartypants
diff --git a/textproc/py-rstfmt/Makefile b/textproc/py-rstfmt/Makefile
new file mode 100644
index 000000000000..f16ca76ebb56
--- /dev/null
+++ b/textproc/py-rstfmt/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= rstfmt
+DISTVERSION= 0.0.9
+CATEGORIES= textproc devel python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= 0mp@FreeBSD.org
+COMMENT= Formatter for reStructuredText
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+# Sphinix should be < 4.0 for now: https://github.com/dzhu/rstfmt/issues/12
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=3.3.2:www/py-aiohttp@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}black>=19.10b0:devel/py-black@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx>=2.4.0,1<4.0,1:textproc/py-sphinx@${PY_FLAVOR}
+
+USES= python:3.6+
+USE_GITHUB= yes
+GH_ACCOUNT= dzhu
+GH_TAGNAME= 5173b3cf68c9eaaf4b5d7fcb2e6c169c4f56f388
+USE_PYTHON= autoplist concurrent distutils
+
+TEST_TARGET= test
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/textproc/py-rstfmt/distinfo b/textproc/py-rstfmt/distinfo
new file mode 100644
index 000000000000..13cb67533f1c
--- /dev/null
+++ b/textproc/py-rstfmt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1625609486
+SHA256 (dzhu-rstfmt-0.0.9-5173b3cf68c9eaaf4b5d7fcb2e6c169c4f56f388_GH0.tar.gz) = aa0f50317de5a509100e61c8771bb58ab9194705bbad929c1741c7eaa8690bc4
+SIZE (dzhu-rstfmt-0.0.9-5173b3cf68c9eaaf4b5d7fcb2e6c169c4f56f388_GH0.tar.gz) = 21160
diff --git a/textproc/py-rstfmt/pkg-descr b/textproc/py-rstfmt/pkg-descr
new file mode 100644
index 000000000000..7fba39a5b817
--- /dev/null
+++ b/textproc/py-rstfmt/pkg-descr
@@ -0,0 +1,12 @@
+rstfmt is a tool for automatically formatting reStructuredText files in a
+consistent way.
+
+Like Black and gofmt, the motivation is to provide a format that is reasonable
+and minimally configurable to prevent teams from wasting time on style
+discussions (or individuals on manually doing formatting, for that matter).
+
+Currently, rstfmt is in a very early stage of development. Not all reST
+constructs are covered and the interface or formatting may change at any time
+without warning.
+
+WWW: https://github.com/dzhu/rstfmt