aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-10-17 06:11:39 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-10-17 06:11:39 +0000
commitb6128b71dc539d0942a5dff9bf000e390194aa2c (patch)
tree6917948f0ae3841e3dc122dbb99d1f907a3a2ce8
parent8f4e4480e0dcae8063072e87aa60bb6175053451 (diff)
downloadports-b6128b71dc539d0942a5dff9bf000e390194aa2c.tar.gz
ports-b6128b71dc539d0942a5dff9bf000e390194aa2c.zip
- Add STAGEDIR support.
- Remove MAKE_JOBS_UNSAFE. - Take maintainership.
Notes
Notes: svn path=/head/; revision=330603
-rw-r--r--net/mcast-tools/Makefile18
-rw-r--r--net/mcast-tools/files/patch-mfc-Makefile.am29
-rw-r--r--net/mcast-tools/files/patch-pim6sd-Makefile.am29
-rw-r--r--net/mcast-tools/pkg-plist11
4 files changed, 74 insertions, 13 deletions
diff --git a/net/mcast-tools/Makefile b/net/mcast-tools/Makefile
index 108ac4a7b8f1..746fe239c196 100644
--- a/net/mcast-tools/Makefile
+++ b/net/mcast-tools/Makefile
@@ -7,25 +7,17 @@ PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= hrs@FreeBSD.org
COMMENT= IPv6 multicast routing daemons and tools
-MAKE_JOBS_UNSAFE= yes
-
GNU_CONFIGURE= yes
USE_AUTOTOOLS= automake aclocal autoconf
AUTOMAKE_ARGS= --add-missing
-CONFIGURE_ARGS=
-CONFIGURE_ENV=
-
-MAN1= mcastread.1 mcastsend.1 pim6stat.1 pmsft.1
-MAN5= pim6dd.conf.5 pim6sd.conf.5
-MAN8= mfc.8 mtrace6.8 pim6dd.8 pim6sd.8
+CONFIGURE_ARGS= YACC=${YACC}
-NO_STAGE= yes
post-install:
- ${INSTALL_DATA} ${WRKSRC}/pim6sd/pim6sd.conf.sample ${PREFIX}/etc
- ${INSTALL_DATA} ${FILESDIR}/pim6dd.conf.sample ${PREFIX}/etc
- ${INSTALL_DATA} ${WRKSRC}/mfc/mfc.conf.sample ${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/pim6sd/pim6sd.conf.sample ${STAGEDIR}${PREFIX}/etc
+ ${INSTALL_DATA} ${FILESDIR}/pim6dd.conf.sample ${STAGEDIR}${PREFIX}/etc
+ ${INSTALL_DATA} ${WRKSRC}/mfc/mfc.conf.sample ${STAGEDIR}${PREFIX}/etc
.include <bsd.port.mk>
diff --git a/net/mcast-tools/files/patch-mfc-Makefile.am b/net/mcast-tools/files/patch-mfc-Makefile.am
new file mode 100644
index 000000000000..7ef27b13a36f
--- /dev/null
+++ b/net/mcast-tools/files/patch-mfc-Makefile.am
@@ -0,0 +1,29 @@
+--- mfc/Makefile.am.orig 2005-12-11 14:15:10.000000000 +0900
++++ mfc/Makefile.am 2013-10-17 13:52:36.000000000 +0900
+@@ -9,15 +9,19 @@
+
+ # Config file parser (this is necessary because not all yacc generate y.tab.h)
+ cftoken.o: cftoken.c cfparse.h
+- $(COMPILE) -c -o $@ $<
++ $(COMPILE) -c -o $@ cftoken.c
+
+ cfparse.o: cfparse.c
+- $(COMPILE) -c -o $@ $<
++ $(COMPILE) -c -o $@ $?
+
+ cftoken.c: cftoken.l
+- $(LEX) -ocftoken.c $<
++ $(LEX) -o$@ $?
+
+-cfparse.h cfparse.c: cfparse.y
+- $(YACC) -d $< && \
+- mv y.tab.c cfparse.c && \
+- mv y.tab.h cfparse.h
++y.tab.h y.tab.c: cfparse.y
++ $(YACC) -d $?
++
++cfparse.h: y.tab.h
++ mv y.tab.h $@
++
++cfparse.c: y.tab.c
++ mv y.tab.c $@
diff --git a/net/mcast-tools/files/patch-pim6sd-Makefile.am b/net/mcast-tools/files/patch-pim6sd-Makefile.am
new file mode 100644
index 000000000000..df9e53b05809
--- /dev/null
+++ b/net/mcast-tools/files/patch-pim6sd-Makefile.am
@@ -0,0 +1,29 @@
+--- pim6sd/Makefile.am.orig 2005-12-11 14:15:12.000000000 +0900
++++ pim6sd/Makefile.am 2013-10-17 13:54:42.000000000 +0900
+@@ -12,15 +12,19 @@
+
+ # Config file parser (this is necessary because not all yacc generate y.tab.h)
+ cftoken.o: cftoken.c cfparse.h
+- $(COMPILE) -c -o $@ $<
++ $(COMPILE) -c -o $@ cftoken.c
+
+ cfparse.o: cfparse.c
+- $(COMPILE) -c -o $@ $<
++ $(COMPILE) -c -o $@ $?
+
+ cftoken.c: cftoken.l
+- $(LEX) -ocftoken.c $<
++ $(LEX) -o$@ $?
+
+-cfparse.h cfparse.c: cfparse.y
+- $(YACC) -d $< && \
+- mv y.tab.c cfparse.c && \
+- mv y.tab.h cfparse.h
++y.tab.c y.tab.h: cfparse.y
++ $(YACC) -d $?
++
++cfparse.h: y.tab.h
++ mv y.tab.h $@
++
++cfparse.c: y.tab.c
++ mv y.tab.c $@
diff --git a/net/mcast-tools/pkg-plist b/net/mcast-tools/pkg-plist
index e61638ad649a..079fa59e057a 100644
--- a/net/mcast-tools/pkg-plist
+++ b/net/mcast-tools/pkg-plist
@@ -1,3 +1,4 @@
+@comment $FreeBSD$
etc/pim6sd.conf.sample
etc/pim6dd.conf.sample
etc/mfc.conf.sample
@@ -9,3 +10,13 @@ sbin/mfc
sbin/pim6dd
sbin/pim6sd
sbin/pim6stat
+man/man1/mcastread.1.gz
+man/man1/mcastsend.1.gz
+man/man1/pim6stat.1.gz
+man/man1/pmsft.1.gz
+man/man5/pim6dd.conf.5.gz
+man/man5/pim6sd.conf.5.gz
+man/man8/mfc.8.gz
+man/man8/mtrace6.8.gz
+man/man8/pim6dd.8.gz
+man/man8/pim6sd.8.gz