aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-10-10 14:36:22 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-10-10 14:36:22 +0000
commitb65986de015fa2712d3cd69bf90542f53b8b72ae (patch)
tree795b241761a05a6560125c79ddd067942a15fb41
parentab681b31166802d957aace9bf76ee5d50270f452 (diff)
downloadports-b65986de015fa2712d3cd69bf90542f53b8b72ae.tar.gz
ports-b65986de015fa2712d3cd69bf90542f53b8b72ae.zip
add fc++
Functional Programming in C++
Notes
Notes: svn path=/head/; revision=48650
-rw-r--r--devel/Makefile1
-rw-r--r--devel/fc++/Makefile23
-rw-r--r--devel/fc++/distinfo1
-rw-r--r--devel/fc++/pkg-comment1
-rw-r--r--devel/fc++/pkg-descr21
-rw-r--r--devel/fc++/pkg-plist10
6 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cb598cd9dd6e..c659b25880ad 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -118,6 +118,7 @@
SUBDIR += fam
SUBDIR += fampp
SUBDIR += fastcrc
+ SUBDIR += fc++
SUBDIR += ffcall
SUBDIR += fhist
SUBDIR += flick
diff --git a/devel/fc++/Makefile b/devel/fc++/Makefile
new file mode 100644
index 000000000000..8b53384c24d8
--- /dev/null
+++ b/devel/fc++/Makefile
@@ -0,0 +1,23 @@
+# ex:ts=8
+# New ports collection makefile for: fc++
+# Date created: Oct 10, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= fc++
+PORTVERSION= 1.3
+CATEGORIES= devel
+MASTER_SITES= http://www.cc.gatech.edu/~yannis/fc++/
+DISTNAME= FC++.${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+NO_BUILD= yes
+
+do-install:
+ @${MKDIR} ${PREFIX}/include/fc++
+ ${CP} ${WRKSRC}/*.h ${PREFIX}/include/fc++
+
+.include <bsd.port.mk>
diff --git a/devel/fc++/distinfo b/devel/fc++/distinfo
new file mode 100644
index 000000000000..3e9c21758669
--- /dev/null
+++ b/devel/fc++/distinfo
@@ -0,0 +1 @@
+MD5 (FC++.1.3.tar.gz) = d021ec02527eef3e8e4f23014b81793e
diff --git a/devel/fc++/pkg-comment b/devel/fc++/pkg-comment
new file mode 100644
index 000000000000..02f12759f4a0
--- /dev/null
+++ b/devel/fc++/pkg-comment
@@ -0,0 +1 @@
+Functional Programming in C++
diff --git a/devel/fc++/pkg-descr b/devel/fc++/pkg-descr
new file mode 100644
index 000000000000..b9224652d547
--- /dev/null
+++ b/devel/fc++/pkg-descr
@@ -0,0 +1,21 @@
+FC++ is a library for functional programming in C++. Functional programming
+is a programming paradigm in which functions are treated as regular values.
+Thus, we can have functions that take other functions as parameters. The
+former functions are called "higher-order" functions. A common feature of
+functions is that they can be polymorphic. "Polymorphic" means that the same
+function can be used with arguments of many types. FC++ is distinguished from
+other libraries (including the C++ Standard Library) by its complete support
+for polymorphism: FC++ polymorphic higher-order functions can take other
+polymorphic functions as arguments and return polymorphic functions as results.
+This is particularly useful (i.e., simplifies code) in C++ where type inference
+is limited and we often need to pass polymorphic functions around and determine
+their type later.
+
+With FC++ you can define your own higher-order polymorphic functions, but the
+library also contains a large amount of functionality that can be re-used as-is
+in C++ programs. This includes infinite ("lazy") lists, useful higher-order
+functions (like map, compose, etc.), a reference-counting facility that can be
+used to replace C++ pointers, many common logical and arithmetic operators in
+a form that can be used with higher-order functions, and more.
+
+WWW: http://www.cc.gatech.edu/~yannis/fc++/
diff --git a/devel/fc++/pkg-plist b/devel/fc++/pkg-plist
new file mode 100644
index 000000000000..2ee1f2ae93a3
--- /dev/null
+++ b/devel/fc++/pkg-plist
@@ -0,0 +1,10 @@
+include/fc++/config.h
+include/fc++/curry.h
+include/fc++/function.h
+include/fc++/list.h
+include/fc++/operator.h
+include/fc++/prelude.h
+include/fc++/ref_count.h
+include/fc++/reuse.h
+include/fc++/signature.h
+@dirrm include/fc++