aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2022-02-23 17:43:55 +0000
committerJason E. Hale <jhale@FreeBSD.org>2022-02-24 14:24:15 +0000
commitb65af6ede18ed22bffc4cef9501bcef6117df14d (patch)
tree2faa4c2cba7ac2d14980d9306f8e33c5f30afeb7
parentf30d6253c6552e920b79d0699fae16657ff07b2b (diff)
downloadports-b65af6ede18ed22bffc4cef9501bcef6117df14d.tar.gz
ports-b65af6ede18ed22bffc4cef9501bcef6117df14d.zip
editors/mp: Update to 5.57
The source code for mpdm and mpsl was merged back into the main project tree.
-rw-r--r--editors/mp/Makefile6
-rw-r--r--editors/mp/distinfo10
-rw-r--r--editors/mp/files/patch-config.sh18
-rw-r--r--editors/mp/files/patch-makefile.in12
-rw-r--r--editors/mp/files/patch-mpv__qt4.cpp13
-rw-r--r--editors/mp/pkg-plist4
6 files changed, 22 insertions, 41 deletions
diff --git a/editors/mp/Makefile b/editors/mp/Makefile
index 0eec81128e35..bc1d66266b5d 100644
--- a/editors/mp/Makefile
+++ b/editors/mp/Makefile
@@ -1,7 +1,7 @@
# Created by: Mark Pulford <mark@kyne.com.au>
PORTNAME= mp
-DISTVERSION= 5.50
+DISTVERSION= 5.57
CATEGORIES= editors
MAINTAINER= jhale@FreeBSD.org
@@ -14,9 +14,7 @@ USES= gmake iconv
USE_GITHUB= yes
GH_ACCOUNT= ttcdt
-GH_PROJECT= mp-5.x mpdm:mpdm mpsl:mpsl
-GH_TAGNAME= 2.72:mpdm 2.62:mpsl
-GH_SUBDIR= mpdm:mpdm mpsl:mpsl
+GH_PROJECT= mp-5.x
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= config.sh
diff --git a/editors/mp/distinfo b/editors/mp/distinfo
index 0866ed030890..5fe6e459e6ca 100644
--- a/editors/mp/distinfo
+++ b/editors/mp/distinfo
@@ -1,7 +1,3 @@
-TIMESTAMP = 1619877757
-SHA256 (ttcdt-mp-5.x-5.50_GH0.tar.gz) = 581f3aa718ec7615d0029a01717cc6f3471244afb3017f1ed04fb99c67b3be66
-SIZE (ttcdt-mp-5.x-5.50_GH0.tar.gz) = 230814
-SHA256 (ttcdt-mpdm-2.72_GH0.tar.gz) = eca91ca7549cab93931a806c7434fff9efa122f29ba787c670ab25fec24ecfbf
-SIZE (ttcdt-mpdm-2.72_GH0.tar.gz) = 144909
-SHA256 (ttcdt-mpsl-2.62_GH0.tar.gz) = 3e12bbbb8504bc9ebba31a5753c60e5280a1d7d9f3f0d5199ff0f1f3f241879a
-SIZE (ttcdt-mpsl-2.62_GH0.tar.gz) = 69393
+TIMESTAMP = 1645632855
+SHA256 (ttcdt-mp-5.x-5.57_GH0.tar.gz) = 7d1cb0914c665c826a458ae2aac479204fca867abe98b9be1452d15e5ae2b69d
+SIZE (ttcdt-mp-5.x-5.57_GH0.tar.gz) = 463070
diff --git a/editors/mp/files/patch-config.sh b/editors/mp/files/patch-config.sh
index e98023f526c5..e4a222672b49 100644
--- a/editors/mp/files/patch-config.sh
+++ b/editors/mp/files/patch-config.sh
@@ -1,4 +1,4 @@
---- config.sh.orig 2021-01-14 18:21:08 UTC
+--- config.sh.orig 2022-02-03 09:30:31 UTC
+++ config.sh
@@ -40,6 +40,7 @@ while [ $# -gt 0 ] ; do
case $1 in
@@ -36,7 +36,7 @@
cat $MPDM/config.ldflags >> config.ldflags
cat $MPSL/config.ldflags >> config.ldflags
-@@ -285,8 +287,8 @@ else
+@@ -286,8 +288,8 @@ else
TMP_CFLAGS="$(ncurses5-config --cflags)"
TMP_LDFLAGS="$(ncurses5-config --libs)"
else
@@ -47,7 +47,7 @@
fi
if chk_compiles "$(cat <<EOF
-@@ -450,8 +452,8 @@ if [ "$WITHOUT_QT5" = "1" ] ; then
+@@ -451,8 +453,8 @@ if [ "$WITHOUT_QT5" = "1" ] ; then
else
if chk_pkgconfig Qt5Widgets
then
@@ -58,7 +58,7 @@
if USE_CXX=true chk_compiles "$(cat <<EOF
#include <QtWidgets>
-@@ -540,8 +542,8 @@ if [ "$WITHOUT_GTK" = "1" ] ; then
+@@ -541,8 +543,8 @@ if [ "$WITHOUT_GTK" = "1" ] ; then
else
# Try first GTK 3.0
if chk_pkgconfig gtk+-3.0 ; then
@@ -69,7 +69,7 @@
if chk_compiles "$(cat <<EOF
#include <gtk/gtk.h>
-@@ -549,10 +551,10 @@ else
+@@ -550,10 +552,10 @@ else
int main(void) { gtk_main(); return 0; }
EOF
)" ; then
@@ -82,12 +82,12 @@
DRIVERS="gtk $DRIVERS"
DRV_OBJS="mpv_gtk.o $DRV_OBJS"
CFLAGS="$CFLAGS $TMP_CFLAGS"
-@@ -701,7 +703,7 @@ if [ "$WITH_EXTERNAL_ARCH" = "1" ] ; then
+@@ -704,7 +706,7 @@ if [ "$WITH_EXTERNAL_ARCH" = "1" ] ; then
echo "#define CONFOPT_EXTERNAL_ARCH 1" >> config.h
echo "#define ARCH_START NULL" >> config.h
echo "#define ARCH_END NULL" >> config.h
-- MORE_TARGETS="mp.tar"
-+ MORE_TARGETS="mp.tar $MORE_TARGETS"
- MORE_INSTALL_TARGETS="install-tar $MORE_INSTALL_TARGETS"
+- MORE_TARGETS="$ARCH_FILE"
++ MORE_TARGETS="$ARCH_FILE $MORE_TARGETS"
+ MORE_INSTALL_TARGETS="install-arch $MORE_INSTALL_TARGETS"
fi
diff --git a/editors/mp/files/patch-makefile.in b/editors/mp/files/patch-makefile.in
index be2c6b91518e..b31224da7c16 100644
--- a/editors/mp/files/patch-makefile.in
+++ b/editors/mp/files/patch-makefile.in
@@ -1,11 +1,11 @@
---- makefile.in.orig 2020-10-11 16:57:43 UTC
+--- makefile.in.orig 2022-02-03 09:30:31 UTC
+++ makefile.in
-@@ -52,13 +52,13 @@ mp.zip.o: mp.zip
- $(LD) -r -b binary mp.zip -o $@
+@@ -56,13 +56,13 @@ $(MPSL)/libmpsl.a: $(MPSL)/VERSION $(MPSL)/config.h
+ $(MAKE) -C $(MPSL) libmpsl.a
- $(APPNAME): $(OBJS) $(MPDM)/libmpdm.a $(MPSL)/libmpsl.a
-- $(CCLINK) $(CFLAGS) $(OBJS) `cat config.ldflags` -o $@
-+ $(CCLINK) $(LDFLAGS) $(OBJS) `cat config.ldflags` -o $@
+ $(APPNAME): $(OBJS) $(DRV_OBJS) $(MPDM)/libmpdm.a $(MPSL)/libmpsl.a
+- $(CCLINK) $(CFLAGS) $(OBJS) $(DRV_OBJS) `cat config.ldflags` -o $@
++ $(CCLINK) $(LDFLAGS) $(OBJS) $(DRV_OBJS) `cat config.ldflags` -o $@
mpv_kde4.o: mpv_kde4.cpp mpv_qk_common.moc
- $(CPP) $(CFLAGS) -I. `cat config.cflags` -c $<
diff --git a/editors/mp/files/patch-mpv__qt4.cpp b/editors/mp/files/patch-mpv__qt4.cpp
deleted file mode 100644
index e8ef3659ce85..000000000000
--- a/editors/mp/files/patch-mpv__qt4.cpp
+++ /dev/null
@@ -1,13 +0,0 @@
-Fix forgotten renamed variable.
-
---- mpv_qt4.cpp.orig 2021-04-06 20:21:29 UTC
-+++ mpv_qt4.cpp
-@@ -518,7 +518,7 @@ static mpdm_t qt4_drv_idle(mpdm_t a, mpdm_t ctxt)
-
- window->area->timer->stop();
-
-- if (msecs)
-+ if (idle_msecs)
- window->area->timer->start(idle_msecs);
-
- return NULL;
diff --git a/editors/mp/pkg-plist b/editors/mp/pkg-plist
index 13d99d3e4727..aceb3b5fbc47 100644
--- a/editors/mp/pkg-plist
+++ b/editors/mp/pkg-plist
@@ -3,11 +3,11 @@ bin/mp-5
%%GUI%%share/applications/minimum-profit.desktop
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/RELEASE_NOTES
-%%PORTDOCS%%%%DOCSDIR%%/mp_actions.html
+%%PORTDOCS%%%%DOCSDIR%%/mp_actions.gmi
%%PORTDOCS%%%%DOCSDIR%%/mp_actions.txt
%%PORTDOCS%%%%DOCSDIR%%/mp_api.html
%%PORTDOCS%%%%DOCSDIR%%/mp_api.txt
-%%PORTDOCS%%%%DOCSDIR%%/mp_configuration.html
+%%PORTDOCS%%%%DOCSDIR%%/mp_configuration.gmi
%%PORTDOCS%%%%DOCSDIR%%/mp_configuration.txt
%%PORTDOCS%%%%DOCSDIR%%/mp_cookbook.html
%%PORTDOCS%%%%DOCSDIR%%/mp_cookbook.txt