aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-06-06 21:02:42 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-06-06 21:02:42 +0000
commitb684da0d06d3d3b90d28639c92338465313b8e68 (patch)
treef35a0e66a4198584c06250890b3750b7d665c5d9
parent44847256b93398e07cc35f31ed83d7968d649405 (diff)
downloadports-b684da0d06d3d3b90d28639c92338465313b8e68.tar.gz
ports-b684da0d06d3d3b90d28639c92338465313b8e68.zip
Adding port textproc/p5-Text-Decorator, Apply a chain of filters to text.
Approved by: tobez (implicit)
Notes
Notes: svn path=/head/; revision=164651
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-Decorator/Makefile40
-rw-r--r--textproc/p5-Text-Decorator/distinfo3
-rw-r--r--textproc/p5-Text-Decorator/pkg-descr8
-rw-r--r--textproc/p5-Text-Decorator/pkg-plist11
5 files changed, 63 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 6d5e7b1ab5e8..9fc0ed4f45e0 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -454,6 +454,7 @@
SUBDIR += p5-Text-Capitalize
SUBDIR += p5-Text-Chomp
SUBDIR += p5-Text-Context-EitherSide
+ SUBDIR += p5-Text-Decorator
SUBDIR += p5-Text-Diff
SUBDIR += p5-Text-Diff-HTML
SUBDIR += p5-Text-Diff3
diff --git a/textproc/p5-Text-Decorator/Makefile b/textproc/p5-Text-Decorator/Makefile
new file mode 100644
index 000000000000..e665c41319c4
--- /dev/null
+++ b/textproc/p5-Text-Decorator/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-Text-Decorator
+# Date created: 05 Jun 06
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Decorator
+PORTVERSION= 1.65
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= Apply a chain of filters to text
+
+BUILD_DEPENDS= ${SITE_PERL}/URI/Find.pm:${PORTSDIR}/textproc/p5-URI-Find \
+ ${SITE_PERL}/${PERL_ARCH}/Template.pm:${PORTSDIR}/www/p5-Template-Toolkit \
+ ${SITE_PERL}/UNIVERSAL/require.pm:${PORTSDIR}/devel/p5-UNIVERSAL-require
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+MAN3= Text::Decorator.3 \
+ Text::Decorator::Filter.3 \
+ Text::Decorator::Filter::Quoted.3 \
+ Text::Decorator::Filter::TTBridge.3 \
+ Text::Decorator::Filter::Test.3 \
+ Text::Decorator::Filter::URIFind.3 \
+ Text::Decorator::Group.3 \
+ Text::Decorator::Node.3
+
+PERL_MODBUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600 # inhertied from textproc/p5-URI-Find
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-Decorator/distinfo b/textproc/p5-Text-Decorator/distinfo
new file mode 100644
index 000000000000..00f15e4d4f2c
--- /dev/null
+++ b/textproc/p5-Text-Decorator/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-Decorator-1.65.tar.gz) = 1c1780e2dd8b6148e55d9f4c62b33497
+SHA256 (Text-Decorator-1.65.tar.gz) = ef974b7418548dd37b28699b30a3da8ed626338649588a9d4116c3a56906edf2
+SIZE (Text-Decorator-1.65.tar.gz) = 7146
diff --git a/textproc/p5-Text-Decorator/pkg-descr b/textproc/p5-Text-Decorator/pkg-descr
new file mode 100644
index 000000000000..8ebc99af6331
--- /dev/null
+++ b/textproc/p5-Text-Decorator/pkg-descr
@@ -0,0 +1,8 @@
+Text::Decorator is a framework for marking up plain text into various
+formats by applying a chain of filters. For instance, you might apply a
+filter which will cause URIs in text to be presented as links if the text
+is exported as HTML.
+
+WWW: http://search.cpan.org/dist/Text-Decorator
+Authors: Simon Cozens
+ Tony Bowden <bug-Text-Decorator@rt.cpan.org>
diff --git a/textproc/p5-Text-Decorator/pkg-plist b/textproc/p5-Text-Decorator/pkg-plist
new file mode 100644
index 000000000000..82a52a52b110
--- /dev/null
+++ b/textproc/p5-Text-Decorator/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Text/Decorator.pm
+%%SITE_PERL%%/Text/Decorator/Filter.pm
+%%SITE_PERL%%/Text/Decorator/Filter/Quoted.pm
+%%SITE_PERL%%/Text/Decorator/Filter/TTBridge.pm
+%%SITE_PERL%%/Text/Decorator/Filter/Test.pm
+%%SITE_PERL%%/Text/Decorator/Filter/URIFind.pm
+%%SITE_PERL%%/Text/Decorator/Group.pm
+%%SITE_PERL%%/Text/Decorator/Node.pm
+@dirrm %%SITE_PERL%%/Text/Decorator/Filter
+@dirrm %%SITE_PERL%%/Text/Decorator
+@dirrmtry %%SITE_PERL%%/Text