aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 13:44:59 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-02 14:16:42 +0000
commitb71fa5b6b7f610fc3a5bcb16962b7da61cd5444a (patch)
treebf6b906eb3e0380aaea2b5151744f1680d5c32b7
parent62516c88401939a0549085c30444796940811196 (diff)
downloadports-b71fa5b6b7f610fc3a5bcb16962b7da61cd5444a.tar.gz
ports-b71fa5b6b7f610fc3a5bcb16962b7da61cd5444a.zip
editors/zile: Fix build with llvm16
- Pet port{clippy|fmt} - Utilize USES=localbase Sponsored by: The FreeBSD Foundation
-rw-r--r--editors/zile/Makefile29
1 files changed, 18 insertions, 11 deletions
diff --git a/editors/zile/Makefile b/editors/zile/Makefile
index 14ac9cd182a8..2e29b2af73e4 100644
--- a/editors/zile/Makefile
+++ b/editors/zile/Makefile
@@ -9,26 +9,33 @@ WWW= https://www.gnu.org/software/zile/
LICENSE= GPLv3
-LIB_DEPENDS= libgc.so:devel/boehm-gc \
- libgnuregex.so.6:devel/libgnuregex \
- libgee-0.8.so:devel/libgee
BUILD_DEPENDS= ${LOCALBASE}/bin/help2man:misc/help2man
+LIB_DEPENDS= libgc.so:devel/boehm-gc \
+ libgee-0.8.so:devel/libgee \
+ libgnuregex.so.6:devel/libgnuregex
-USES= gmake gnome ncurses perl5 pkgconfig compiler:c++11-lang
-USE_PERL5= build
+USES= compiler:c++11-lang gmake gnome localbase:ldflags \
+ ncurses perl5 pkgconfig
USE_GNOME= glib20
+USE_PERL5= build
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-regex
-PLIST_FILES= bin/${PORTNAME} \
+LDFLAGS+= -lgnuregex
+
+PLIST_FILES= bin/${PORTNAME} \
man/man1/${PORTNAME}.1.gz \
%%DOCSDIR%%/AUTHORS \
+ %%DOCSDIR%%/dotzile.sample \
%%DOCSDIR%%/FAQ \
- %%DOCSDIR%%/NEWS \
- %%DOCSDIR%%/dotzile.sample
+ %%DOCSDIR%%/NEWS
+
+.include <bsd.port.pre.mk>
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -lgnuregex
+.if ${COMPILER_TYPE} == clang && ${COMPILER_VERSION} >= 160
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
post-patch:
@${REINPLACE_CMD} -e \
@@ -36,4 +43,4 @@ post-patch:
@${REINPLACE_CMD} -e \
's|@pkgdatadir@|${DOCSDIR}|' ${WRKSRC}/doc/man-extras
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>