aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2023-09-15 08:51:03 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2023-10-03 11:19:52 +0000
commitb724e3db06bbae07f916fa77c3bc43abc0726255 (patch)
tree719caff3eef4c0ddd7fe397d2e5aee9e9cacb534
parent62068131522cf018f55a37baca7d76a24029507c (diff)
downloadports-b724e3db06bbae07f916fa77c3bc43abc0726255.tar.gz
ports-b724e3db06bbae07f916fa77c3bc43abc0726255.zip
net/multicat: install missing tools
Build and install multicat additional tools ingests, aggregartp and reordertp which are required if tou want to manipulate rtp streams. PR: 273816 Reported by: rodrigo Reviewed by: m.muenz@gmail.com (maintainer)
-rw-r--r--net/multicat/Makefile22
-rw-r--r--net/multicat/files/patch-ingests.c11
2 files changed, 27 insertions, 6 deletions
diff --git a/net/multicat/Makefile b/net/multicat/Makefile
index 6ca90b0241b0..d90c1cd84e67 100644
--- a/net/multicat/Makefile
+++ b/net/multicat/Makefile
@@ -1,5 +1,6 @@
PORTNAME= multicat
PORTVERSION= 2.3
+PORTREVISION= 1
CATEGORIES= net multimedia
MASTER_SITES= https://get.videolan.org/multicat/${PORTVERSION}/
@@ -13,17 +14,26 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/bitstream/mpeg/ts.h:multimedia/bitstream
USES= localbase tar:bzip2
-ALL_TARGET= ${PORTNAME}
-
-PLIST_FILES= bin/${PORTNAME} \
- man/man1/${PORTNAME}.1.gz
+ALL_TARGET= multicat ingests aggregartp reordertp
+
+PLIST_FILES= bin/aggregartp \
+ bin/ingests \
+ bin/multicat \
+ bin/reordertp \
+ man/man1/aggregartp.1.gz \
+ man/man1/ingests.1.gz \
+ man/man1/multicat.1.gz \
+ man/man1/reordertp.1.gz
PORTDOCS= AUTHORS Changelog NEWS README
+BINARIES= ${ALL_TARGET}
OPTIONS_DEFINE= DOCS
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+.for file in ${BINARIES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${file}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+.endfor
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/net/multicat/files/patch-ingests.c b/net/multicat/files/patch-ingests.c
new file mode 100644
index 000000000000..9e8558fc312c
--- /dev/null
+++ b/net/multicat/files/patch-ingests.c
@@ -0,0 +1,11 @@
+--- ingests.c.orig 2018-06-12 15:18:47 UTC
++++ ingests.c
+@@ -31,6 +31,8 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <syslog.h>
++#include <netinet/in.h>
++#include <sys/socket.h>
+
+ #include <bitstream/mpeg/ts.h>
+