aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-29 11:41:34 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-08-30 16:51:53 +0000
commitb74afcfe1a5504349990ea05cdbfcab8213cb1d2 (patch)
treee63cbf67333ef8c6e627b4581cbdb012006e6e82
parent87bb5531bc4c055d6dbbdc0d3a75b86a9b073eb4 (diff)
downloadports-b74afcfe1a5504349990ea05cdbfcab8213cb1d2.tar.gz
ports-b74afcfe1a5504349990ea05cdbfcab8213cb1d2.zip
editors/texmacs: Fix build on 13, 14 and 15
Sponsored by: The FreeBSD Foundation
-rw-r--r--editors/texmacs/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/editors/texmacs/Makefile b/editors/texmacs/Makefile
index ee08c42cdfda..f4b3dc8509ea 100644
--- a/editors/texmacs/Makefile
+++ b/editors/texmacs/Makefile
@@ -12,23 +12,17 @@ WWW= https://www.texmacs.org/
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_FreeBSD_13= assigning to 'bool' from incompatible type 'nullptr_t'
-BROKEN_FreeBSD_14= assigning to 'bool' from incompatible type 'nullptr_t'
-
-RUN_DEPENDS= fig2dev:print/transfig
-
BROKEN_armv6= fails to compile: call to min is ambiguous
BROKEN_armv7= fails to compile: call to min is ambiguous
+RUN_DEPENDS= fig2dev:print/transfig
+
USES= cpe desktop-file-utils gmake guile:1.8,alias iconv \
localbase pkgconfig python shared-mime-info shebangfix \
tex xorg
+USE_CXXSTD= c++14
USE_TEX= tex:run dvipsk:run
-USE_XORG= xext
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-optimize="${CXXFLAGS}" --disable-qt
-MAKE_ARGS= CP="${CP} -R -f"
-ALL_TARGET= ${PORTNAME:tu}
+USE_XORG= x11 xext
SHEBANG_FILES= plugins/asymptote/bin/* plugins/dratex/bin/* \
plugins/eukleides/bin/* plugins/feynmf/bin/* \
@@ -37,6 +31,12 @@ SHEBANG_FILES= plugins/asymptote/bin/* plugins/dratex/bin/* \
plugins/python/bin/tm_python plugins/sage/bin/tm_sage \
plugins/mathematica/bin/realpath.py
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-optimize="${CXXFLAGS}" --disable-qt
+
+MAKE_ARGS= CP="${CP} -R -f"
+ALL_TARGET= ${PORTNAME:tu}
+
DATADIR= ${PREFIX}/share/TeXmacs
OPTIONS_DEFINE= ASPELL FREETYPE GHOSTSCRIPT IMLIB2 PDF SQLITE
@@ -53,9 +53,9 @@ GHOSTSCRIPT_CONFIGURE_ON= --with-gs=yes
GHOSTSCRIPT_CONFIGURE_OFF= --with-gs=no
IMLIB2_LIB_DEPENDS= libImlib2.so:graphics/imlib2
IMLIB2_CONFIGURE_WITH= imlib2
+PDF_IMPLIES= FREETYPE GHOSTSCRIPT
PDF_CONFIGURE_ENABLE= pdf-renderer
PDF_LDFLAGS= -lz
-PDF_IMPLIES= FREETYPE GHOSTSCRIPT
SQLITE_USES= sqlite
SQLITE_CONFIGURE_ON= --with-sqlite3