aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2022-09-27 20:09:56 +0000
committerRene Ladan <rene@FreeBSD.org>2022-09-28 07:48:20 +0000
commitb74ed0f79d32e7564969faac41a2e1083bbc49f4 (patch)
tree796b61809ac113669a78cd85bd3742d72eddf22a
parent1b12700108642534ba3ed31b49c1340c7fd2f0e5 (diff)
downloadports-b74ed0f79d32e7564969faac41a2e1083bbc49f4.tar.gz
ports-b74ed0f79d32e7564969faac41a2e1083bbc49f4.zip
Mk: remove ancient 'make update-patches' target.
People should use 'make makepatch' instead which creates patches with the expected filename and header. Differential Revision: https://reviews.freebsd.org/D36767
-rw-r--r--Mk/bsd.port.mk13
-rw-r--r--Tools/scripts/README17
-rwxr-xr-xTools/scripts/update-patches102
3 files changed, 0 insertions, 132 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index c582ca50bb32..3071c4e08597 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3861,19 +3861,6 @@ delete-distfiles-list:
. endif
. endif
-# Generates patches.
-
-update-patches:
- @toedit=`PATCH_WRKSRC=${PATCH_WRKSRC} \
- PATCHDIR=${PATCHDIR} \
- PATCH_LIST=${PATCHDIR}/patch-* \
- DIFF_ARGS=${DIFF_ARGS} \
- DISTORIG=${DISTORIG} \
- ${SH} ${PORTSDIR}/Tools/scripts/update-patches`; \
- case $$toedit in "");; \
- *) ${ECHO_CMD} -n 'edit patches: '; read i; \
- cd ${PATCHDIR} && $${VISUAL:-$${EDIT:-/usr/bin/vi}} $$toedit;; esac
-
# Checksumming utilities
# List all algorithms here, all the variables name must begin with dp_
diff --git a/Tools/scripts/README b/Tools/scripts/README
index f69646991a45..8dfb2b17028a 100644
--- a/Tools/scripts/README
+++ b/Tools/scripts/README
@@ -42,8 +42,6 @@ splitpatch.pl - A small script to convert multi-file patches to several
tindex - script used to build INDEXes for supported FreeBSD branches, which
are the source of the 'make fetchindex' INDEXes, and the build
failure reports on ports@FreeBSD.org
-update-patches - generates updated patches.
-
update_crates - script used to generate an updated Makefile using make cargo-crates
output
@@ -118,18 +116,3 @@ portsearch - A utility for searching the ports tree.
All searches are case-insensitive
See the file README.portsearch for further information.
-
-----------------------------------------------------------------------
-
-The update-patches script looks for files in $WRKSRC (if unset, this defaults
-to the work/ subdirectory of the current directory) which have a matching .orig
-file. It also looks in $PATCHDIR (if unset, this defaults to the files/
-subdirectory of the current directory) for patches that correspond to the first
-set. If the changes in an existing patch do not reflect the changes in the
-files in $WRKSRC, the script renames the existing patch by adding the suffix
-.orig and generates a new patch in its place. If no patch existed, the new one
-is created with a name that contains the path and filename of the file being
-patched, except that "/" separators and "." characters are replaced by
-underscores: for example, a new patch to $WRKSRC/foo/bar.c would be created as
-$PATCHDIR/patch-foo_bar_c. If you save a .orig backup of a file, but don't
-change the file, update-patches will generate an empty patch.
diff --git a/Tools/scripts/update-patches b/Tools/scripts/update-patches
deleted file mode 100755
index 0d92905f6428..000000000000
--- a/Tools/scripts/update-patches
+++ /dev/null
@@ -1,102 +0,0 @@
-#!/bin/sh
-
-# $OpenBSD: update-patches,v 1.3 2000/06/09 17:08:37 espie Exp $
-# Copyright (c) 2000
-# Marc Espie. All rights reserved.
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions
-# are met:
-# 1. Redistributions of code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# 2. Neither the name of OpenBSD nor the names of its contributors
-# may be used to endorse or promote products derived from this software
-# without specific prior written permission.
-#
-# THIS SOFTWARE IS PROVIDED BY ITS AUTHOR AND THE OpenBSD project ``AS IS'' AND
-# ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
-# ARE DISCLAIMED. IN NO EVENT SHALL THE REGENTS OR CONTRIBUTORS BE LIABLE
-# FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
-# OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-# HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
-# LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
-# OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
-# SUCH DAMAGE.
-
-# Find out all .orig files and strip the name to what diff will use
-cd $PATCH_WRKSRC && find . -type f -name '*.orig' | fgrep -v $DISTORIG | \
-sed -e "s,^./\(.*\)\.orig\$,\1," | {
-while read file
-do
- echo 1>&2 "Processing $file"
- # look in patchdir for an existing patchfile matching this
- mkdir -p $PATCHDIR
- cd $PATCHDIR
- for i in ${PATCH_LIST}
- do
- # Ignore non-files, or old backup
- [ -f $i ] || continue
- case $i in \
- *.orig|*.rej|*~) ;;
- *) # Patch found. Is this the one ?
- if grep "^--- $file.orig" $i >/dev/null
- then
- accounted="$accounted $i"
- # found it, splice before diff part with diff
- esc=`echo $file | sed -e 's,/,\\\\/,g'`
- { sed -e "/^--- $esc.orig/,\$ d" <$i
- (cd $PATCH_WRKSRC && diff -p ${DIFF_ARGS} -u $file.orig $file) } >$i.new
- # did it change ? mark it as changed
- if diff ${DIFF_ARGS} -u --ignore-matching-lines="^--- $file.orig .*" \
- --ignore-matching-lines="^+++ $file .*" $i $i.new 1>&2
- then
- rm $i.new
- else
- echo 1>&2 "Patch $i for $file updated"
- mv $i $i.orig
- mv $i.new $i
- edit="$edit $i"
- fi
- continue 2
- fi;;
- esac
- done
- # Build a sensible name for the patch file
- patchname=patch-`echo $file|sed -e s,/,_,g`
- echo 1>&2 "No patch-* found for $file, creating $patchname"
- (cd $PATCH_WRKSRC && diff -p ${DIFF_ARGS} -u $file.orig $file) >$patchname
- edit="$edit $patchname"
- accounted="$accounted $patchname"
-done
-
-# Verify all patches accounted for
-for i in ${PATCHDIR}/*
-do
- [ -f $i ] || continue
- case $i in \
- *.orig|*.rej|*~) ;;
- *)
- for j in $accounted
- do
- if [ $j = $i ]
- then
- continue 2
- fi
- done
- echo 1>&2 "*** Patch $i not accounted for.";;
- esac
-done
-
-# Check for $Id and similar bugs in all those patch files.
-for i in $accounted
-do
- if sed -e '/1,^---/ d' $i|egrep '$(Id|FreeBSD)'
- then
- echo 1>&2 "Problem with $i: CVS tag found in patch"
- fi
-done
-
-echo $edit
-}
-exit 0