aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Cochard <olivier@FreeBSD.org>2024-05-30 21:10:49 +0000
committerOlivier Cochard <olivier@FreeBSD.org>2024-05-30 21:10:49 +0000
commitb79e471822e61b17ca23c6bbbd961a11a82f2ef9 (patch)
tree4ac36aeb778f5e0382e8970d5a0f1f9abec36813
parenteb04906c320dd4fe43d600999073877c964de76d (diff)
downloadports-b79e471822e61b17ca23c6bbbd961a11a82f2ef9.tar.gz
ports-b79e471822e61b17ca23c6bbbd961a11a82f2ef9.zip
net/bird2: Add BGP Monitoring Protocol configuration option
Reported by: Luiz Amaral <email@luiz.eng.br> Differential Revision: https://reviews.freebsd.org/D45413
-rw-r--r--net/bird2/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/net/bird2/Makefile b/net/bird2/Makefile
index 0a3d77873632..867aaffb6ac8 100644
--- a/net/bird2/Makefile
+++ b/net/bird2/Makefile
@@ -32,12 +32,13 @@ MAKE_JOBS_UNSAFE= yes
OPTIONS_MULTI= RP
RP_DESC= Routing Protocols
-OPTIONS_MULTI_RP= BFD BABEL BGP MRT OSPF PIPE RADV RIP RPKI STATIC
-OPTIONS_DEFAULT= ${OPTIONS_MULTI_RP}
+OPTIONS_MULTI_RP= BFD BABEL BMP BGP MRT OSPF PIPE RADV RIP RPKI STATIC
+OPTIONS_DEFAULT= BFD BABEL BGP MRT OSPF PIPE RADV RIP RPKI STATIC
BFD_DESC= Bidirectional Forwarding Detection
BABEL_DESC= Babel routing protocol
BGP_DESC= Border Gateway Protocol
+BMP_DESC= BGP Monitoring Protocol
MRT_DESC= Dumping Routing Information in MRT Format
OSPF_DESC= Open Short Path First
PIPE_DESC= PIPE routing
@@ -49,6 +50,7 @@ STATIC_DESC= Static routing
BFD_VARS= rt_prot+=bfd
BABEL_VARS= rt_prot+=babel
BGP_VARS= rt_prot+=bgp
+BMP_VARS= rt_prot+=bmp
MRT_VARS= rt_prot+=mrt
OSPF_VARS= rt_prot+=ospf
PIPE_VARS= rt_prot+=pipe