aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2016-08-03 12:45:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2016-08-03 12:45:30 +0000
commitb79eed7e6652ea9529bf37f35bb2f17c2d77063b (patch)
treec3b70398d1ab95d4982241d1bea61cc37358a44c
parent30af180f1d367c505f0d8ab27752e4b9be732503 (diff)
downloadports-b79eed7e6652ea9529bf37f35bb2f17c2d77063b.tar.gz
ports-b79eed7e6652ea9529bf37f35bb2f17c2d77063b.zip
Add a PKGMESSAGES variable that allows the framework to have more than
one PKGMESSAGE file. This allows the framework to add messages to ports, without touching their PKGMESSAGE file. Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=419513
-rw-r--r--Mk/Scripts/create-manifest.sh6
-rw-r--r--Mk/bsd.port.mk3
2 files changed, 6 insertions, 3 deletions
diff --git a/Mk/Scripts/create-manifest.sh b/Mk/Scripts/create-manifest.sh
index a960505cbb48..acc4ba75a239 100644
--- a/Mk/Scripts/create-manifest.sh
+++ b/Mk/Scripts/create-manifest.sh
@@ -10,7 +10,7 @@ set -e
validate_env dp_ACTUAL_PACKAGE_DEPENDS dp_CATEGORIES dp_COMMENT \
dp_COMPLETE_OPTIONS_LIST dp_DEPRECATED dp_DESCR dp_EXPIRATION_DATE \
dp_GROUPS dp_LICENSE dp_LICENSE_COMB dp_MAINTAINER dp_METADIR \
- dp_NO_ARCH dp_PKGBASE dp_PKGDEINSTALL dp_PKGINSTALL dp_PKGMESSAGE \
+ dp_NO_ARCH dp_PKGBASE dp_PKGDEINSTALL dp_PKGINSTALL dp_PKGMESSAGES \
dp_PKGORIGIN dp_PKGPOSTDEINSTALL dp_PKGPOSTINSTALL dp_PKGPOSTUPGRADE \
dp_PKGPREDEINSTALL dp_PKGPREINSTALL dp_PKGPREUPGRADE dp_PKGUPGRADE \
dp_PKGVERSION dp_PKG_BIN dp_PKG_IGNORE_DEPENDS dp_PKG_NOTES \
@@ -104,7 +104,9 @@ done
exec >${dp_METADIR}/+DISPLAY
-[ -f ${dp_PKGMESSAGE} ] && cat ${dp_PKGMESSAGE}
+for message in ${dp_PKGMESSAGES}; do
+ [ -f "${message}" ] && cat "${message}"
+done
# Try and keep these messages in sync with check-deprecated
if [ ${dp_MAINTAINER} = "ports@FreeBSD.org" ]; then
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 2429aa761093..f16c19fa732c 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2167,6 +2167,7 @@ PKGINSTALL?= ${PKGDIR}/pkg-install
PKGDEINSTALL?= ${PKGDIR}/pkg-deinstall
PKGREQ?= ${PKGDIR}/pkg-req
PKGMESSAGE?= ${PKGDIR}/pkg-message
+PKGMESSAGES+= ${PKGMESSAGE}
TMPPLIST?= ${WRKDIR}/.PLIST.mktmp
TMPPLIST_SORT?= ${WRKDIR}/.PLIST.mktmp.sorted
@@ -4251,7 +4252,7 @@ create-manifest:
dp_PKGBASE='${PKGBASE}' \
dp_PKGDEINSTALL='${PKGDEINSTALL}' \
dp_PKGINSTALL='${PKGINSTALL}' \
- dp_PKGMESSAGE='${PKGMESSAGE}' \
+ dp_PKGMESSAGES='${PKGMESSAGES}' \
dp_PKGORIGIN='${PKGORIGIN}' \
dp_PKGPOSTDEINSTALL='${PKGPOSTDEINSTALL}' \
dp_PKGPOSTINSTALL='${PKGPOSTINSTALL}' \