aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2007-07-03 11:41:35 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2007-07-03 11:41:35 +0000
commitb7b4a190c6096fd3eacd55e3ee310261e90b6f62 (patch)
treeb24a0d196aa7ab0a62f9f601380f50ddaec80160
parent006df8ea42c8b1d1ca952806af43802384ee0827 (diff)
downloadports-b7b4a190c6096fd3eacd55e3ee310261e90b6f62.tar.gz
ports-b7b4a190c6096fd3eacd55e3ee310261e90b6f62.zip
- Fix the build with GCC 4.2 [1]
- Replace USE_X_PREFIX with USE_XLIB Reported by: pointyhat via pav [1]
Notes
Notes: svn path=/head/; revision=194781
-rw-r--r--games/yadex/Makefile2
-rw-r--r--games/yadex/files/patch-wadlist.cc12
2 files changed, 13 insertions, 1 deletions
diff --git a/games/yadex/Makefile b/games/yadex/Makefile
index ea4fb5437010..7273fb7f008c 100644
--- a/games/yadex/Makefile
+++ b/games/yadex/Makefile
@@ -16,7 +16,7 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= danfe@FreeBSD.org
COMMENT= A WAD-file editor, for games like Doom and Hexen
-USE_X_PREFIX= yes
+USE_XLIB= yes
USE_GMAKE= yes
USE_PERL5_BUILD= yes
MAKEFILE= GNUmakefile
diff --git a/games/yadex/files/patch-wadlist.cc b/games/yadex/files/patch-wadlist.cc
new file mode 100644
index 000000000000..be81ddacb3ba
--- /dev/null
+++ b/games/yadex/files/patch-wadlist.cc
@@ -0,0 +1,12 @@
+--- src/wadlist.cc.orig Fri Mar 28 18:37:32 2003
++++ src/wadlist.cc Tue Jul 3 18:35:21 2007
+@@ -175,7 +175,8 @@
+ priv->iter = priv->list.erase (i);
+ if (priv->iter == priv->list.begin ())
+ {
+- priv->iter = 0; // Catch bugs
++ list_t::iterator empty;
++ priv->iter = empty; // Catch bugs
+ priv->rewound = true;
+ }
+ }