aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2023-01-13 11:26:51 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2023-01-13 11:26:51 +0000
commitb7f9ad79997a0dfee696887f19c3a2707817aafb (patch)
tree3e3312c03b269fbdd355413e11ef8c92d6a83788
parent0f6d608630e59fb5e1a414f62fe39ec10d6d7714 (diff)
downloadports-b7f9ad79997a0dfee696887f19c3a2707817aafb.tar.gz
ports-b7f9ad79997a0dfee696887f19c3a2707817aafb.zip
www/firefox: update to 109.0 (rc2)
-rw-r--r--www/firefox/Makefile3
-rw-r--r--www/firefox/distinfo6
-rw-r--r--www/firefox/files/patch-toolkit_xre_glxtest.cpp17
3 files changed, 22 insertions, 4 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 4b61bbe2dbdc..c86f4924640a 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -1,9 +1,10 @@
PORTNAME= firefox
DISTVERSION= 109.0
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= www wayland
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}${DISTVERSIONSUFFIX}/source \
- MOZILLA/${PORTNAME}/candidates/${DISTVERSION}${DISTVERSIONSUFFIX}-candidates/build1/source
+ MOZILLA/${PORTNAME}/candidates/${DISTVERSION}${DISTVERSIONSUFFIX}-candidates/build2/source
DISTFILES= ${DISTNAME}.source${EXTRACT_SUFX}
MAINTAINER= gecko@FreeBSD.org
diff --git a/www/firefox/distinfo b/www/firefox/distinfo
index 0e4cc3517d27..d04e8a8e134b 100644
--- a/www/firefox/distinfo
+++ b/www/firefox/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1673297409
-SHA256 (firefox-109.0.source.tar.xz) = 892237fdead5da1ee15e98d383f5cd0cf0cfa5590ee5156f63c486abacc42291
-SIZE (firefox-109.0.source.tar.xz) = 499318384
+TIMESTAMP = 1673601389
+SHA256 (firefox-109.0.source.tar.xz) = 0678a03b572b5992fb85f0923a25b236acf81e5ea2c08e549b63a56076a69351
+SIZE (firefox-109.0.source.tar.xz) = 493231972
diff --git a/www/firefox/files/patch-toolkit_xre_glxtest.cpp b/www/firefox/files/patch-toolkit_xre_glxtest.cpp
new file mode 100644
index 000000000000..b89d8b492e4a
--- /dev/null
+++ b/www/firefox/files/patch-toolkit_xre_glxtest.cpp
@@ -0,0 +1,17 @@
+--- toolkit/xre/glxtest.cpp.orig
++++ toolkit/xre/glxtest.cpp
+@@ -270,9 +270,14 @@
+ #define PCI_BASE_CLASS_DISPLAY 0x03
+
+ static void get_pci_status() {
++#if defined(__FreeBSD__)
++ if (access("/dev/pci", F_OK) != 0) {
++ record_warning("cannot access /dev/pci");
++#else
+ if (access("/sys/bus/pci/", F_OK) != 0 &&
+ access("/sys/bus/pci_express/", F_OK) != 0) {
+ record_warning("cannot access /sys/bus/pci");
++#endif
+ return;
+ }
+