aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2021-06-21 12:48:14 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2021-06-21 12:50:52 +0000
commitb87f37734a9de7a3aa76e5520613e01519332461 (patch)
treedee293825d3a830ac852d5f1b16cd282e1f3f59a
parent66cfc9f4c6bee130e703090b40dd068c936eb61c (diff)
downloadports-b87f37734a9de7a3aa76e5520613e01519332461.tar.gz
ports-b87f37734a9de7a3aa76e5520613e01519332461.zip
dns/knot3: update to 3.0.7.
PR: 256671 Reported by: maintainer
-rw-r--r--dns/knot3/Makefile41
-rw-r--r--dns/knot3/distinfo6
2 files changed, 24 insertions, 23 deletions
diff --git a/dns/knot3/Makefile b/dns/knot3/Makefile
index beadb824e5d9..77725ec40458 100644
--- a/dns/knot3/Makefile
+++ b/dns/knot3/Makefile
@@ -1,7 +1,7 @@
# Created by: Leo Vandewoestijne <freebsd@dns.company>
PORTNAME= knot
-DISTVERSION= 3.0.6
+DISTVERSION= 3.0.7
CATEGORIES= dns
MASTER_SITES= https://secure.nic.cz/files/knot-dns/ \
https://dns.company/downloads/knot-dns/
@@ -27,17 +27,17 @@ CONFLICTS= knot-1.* knot1-[0-6].* knot2-[0-9].*
HAS_CONFIGURE= yes
BINARY_ALIAS= sed=${LOCALBASE}/bin/gsed
CONFIGURE_ARGS= --enable-recvmmsg=no \
- --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
- --mandir=${MANPREFIX}/man
+ --mandir=${MANPREFIX}/man \
+ --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig
.if !defined(UTILS_ONLY) && !defined(LIB_ONLY)
CONFIGURE_ARGS+= --with-rundir=/var/run/knot \
--with-storage=/var/db/knot
-LIB_DEPENDS+= liburcu.so:sysutils/liburcu
-USE_RC_SUBR= ${PORTNAME}
-#PLIST_FILES= etc/rc.d/${PORTNAME}
-SUB_FILES= pkg-message
-USES+= libedit
+LIB_DEPENDS+= liburcu.so:sysutils/liburcu
+USE_RC_SUBR= ${PORTNAME}
+#PLIST_FILES= etc/rc.d/${PORTNAME}
+SUB_FILES= pkg-message
+USES+= libedit
.endif
.if defined(UTILS_ONLY) || defined(LIB_ONLY)
@@ -54,41 +54,42 @@ INSTALL_TARGET= install-strip
USERS= knot
GROUPS= knot
-SUB_LIST+= USERS="${USERS}" GROUPS="${GROUPS}"
+SUB_LIST+= GROUPS="${GROUPS}" \
+ USERS="${USERS}"
PORTDOCS= COPYING NEWS
-OPTIONS_DEFINE= DNSTAP DOCS
+OPTIONS_DEFINE= DNSTAP DOCS
.if !defined(LIB_ONLY)
-OPTIONS_DEFINE+= IDN
+OPTIONS_DEFINE+= IDN
.endif
.if !defined(UTILS_ONLY) && !defined(LIB_ONLY)
-OPTIONS_DEFINE+= FASTPARSER MAXMINDDB
+OPTIONS_DEFINE+= FASTPARSER MAXMINDDB
.endif
DNSTAP_DESC= dnstap support (see dnstap.info)
DNSTAP_CONFIGURE_ENABLE= dnstap
DNSTAP_CONFIGURE_WITH= module-dnstap=yes
-DNSTAP_LIB_DEPENDS= libprotobuf-c.so:devel/protobuf-c \
- libfstrm.so:devel/fstrm
+DNSTAP_LIB_DEPENDS= libfstrm.so:devel/fstrm \
+ libprotobuf-c.so:devel/protobuf-c
# XXX: because `kdig_CPPFLAGS += $(DNSTAP_CFLAGS)' line is missing from
# `src/Makefile.am' file (and thus pre-generated `src/Makefile.in') which
# should contain "$libfstrm_CFLAGS $libprotobuf_c_CFLAGS" set by configure
# script, provide it here explicitly as patching those files would result
# in higher line count. Ideally this bug should be fixed upstream.
-DNSTAP_CPPFLAGS= -I${LOCALBASE}/include
+DNSTAP_CPPFLAGS= -I${LOCALBASE}/include
-DOCS_CONFIGURE_OFF= --disable-documentation
+DOCS_CONFIGURE_OFF= --disable-documentation
FASTPARSER_DESC= Fast zone parser (demanding compilation)
FASTPARSER_CONFIGURE_ENABLE= fastparser
-IDN_CONFIGURE_WITH= libidn
-IDN_CONFIGURE_OFF= --without-libidn
-#IDN_LIB_DEPENDS= libidn2.so:dns/libidn2
+IDN_CONFIGURE_WITH= libidn
+IDN_CONFIGURE_OFF= --without-libidn
+#IDN_LIB_DEPENDS= libidn2.so:dns/libidn2
MAXMINDDB_DESC= Enable MaxMind for geodb module
MAXMINDDB_LIB_DEPENDS= libmaxminddb.so:net/libmaxminddb
@@ -97,7 +98,7 @@ MAXMINDDB_CONFIGURE_ENABLE= maxminddb
.include <bsd.port.options.mk>
.if ${ARCH} == i386
-USES+= autoreconf
+USES+= autoreconf
.endif
post-patch:
diff --git a/dns/knot3/distinfo b/dns/knot3/distinfo
index 90c49749dc3f..2ea42526412e 100644
--- a/dns/knot3/distinfo
+++ b/dns/knot3/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1621645570
-SHA256 (knot-3.0.6.tar.xz) = 63756ac5a00c3e4a066ed231a287faef5963a9183d77326e30bf0644cdf74f86
-SIZE (knot-3.0.6.tar.xz) = 1333296
+TIMESTAMP = 1623930813
+SHA256 (knot-3.0.7.tar.xz) = 2bad8be0be95c8f54a26d1e16299e65f31ae1b34bd6ad3819aa50e7b40521484
+SIZE (knot-3.0.7.tar.xz) = 1334788