aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Lachman <000.fbsd@quip.cz>2023-07-04 20:53:00 +0000
committerFelix Palmen <zirias@FreeBSD.org>2023-07-19 11:05:15 +0000
commitb8e72f7c31046aee0be12553dd1fffde7706ffde (patch)
treec08d7a8c9bedb761ab24b8d89c521bf23c094c45
parentd70bd0e00fa17baaf395aae4f1a5bfc48391eb32 (diff)
downloadports-b8e72f7c31046aee0be12553dd1fffde7706ffde.tar.gz
ports-b8e72f7c31046aee0be12553dd1fffde7706ffde.zip
graphics/pecl-imagick: Convert to USES=magick
This will build it with whatever ImageMagick version is set in DEFAULT_VERSIONS, so it obsoletes the -im7 slave port. Remove it and document in MOVED. PR: 268833
-rw-r--r--MOVED1
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pecl-imagick-im7/Makefile17
-rw-r--r--graphics/pecl-imagick/Makefile13
4 files changed, 4 insertions, 28 deletions
diff --git a/MOVED b/MOVED
index c10f42c670bb..5190c15456d9 100644
--- a/MOVED
+++ b/MOVED
@@ -7775,3 +7775,4 @@ japanese/kterm||2023-07-12|Has expired: Last upstream release was in 2011
graphics/gmic-qt@krita|graphics/krita-gmic-plugin|2023-07-14|Forked to a seperate project
devel/capstone5|devel/capstone|2023-07-15|Keep the latest version without any pkgnamesufix
games/naev-data||2023-07-15|Remove obsoleted port. Now games/naev installs data files
+graphics/pecl-imagick-im7|graphics/pecl-imagick|2023-07-19|Merged into master port
diff --git a/graphics/Makefile b/graphics/Makefile
index 7a5011259ce2..8b052478eabf 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -763,7 +763,6 @@
SUBDIR += pear-Image_GraphViz
SUBDIR += pear-Image_Transform
SUBDIR += pecl-imagick
- SUBDIR += pecl-imagick-im7
SUBDIR += pecl-qrencode
SUBDIR += pecl-vips
SUBDIR += pencil2d
diff --git a/graphics/pecl-imagick-im7/Makefile b/graphics/pecl-imagick-im7/Makefile
deleted file mode 100644
index 1fa2f32f9fe5..000000000000
--- a/graphics/pecl-imagick-im7/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-PORTREVISION= 2
-
-PKGNAMESUFFIX= -im7
-
-MAINTAINER= 000.fbsd@quip.cz
-COMMENT= PHP wrapper to the ImageMagick/GraphicsMagick library version 7
-
-LICENSE= PHP301
-
-MASTERDIR= ${.CURDIR}/../pecl-imagick
-
-CONFLICTS_INSTALL= ${PKGNAMEPREFIX}${PORTNAME}
-
-X11_USES?= magick:7
-X11_USES_OFF?= magick:7,nox11
-
-.include "${MASTERDIR}/Makefile"
diff --git a/graphics/pecl-imagick/Makefile b/graphics/pecl-imagick/Makefile
index 886a0b02fc73..c0021457cba7 100644
--- a/graphics/pecl-imagick/Makefile
+++ b/graphics/pecl-imagick/Makefile
@@ -1,25 +1,18 @@
PORTNAME= imagick
PORTVERSION= 3.7.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MAINTAINER= 000.fbsd@quip.cz
-COMMENT?= PHP wrapper to the ImageMagick/GraphicsMagick library version 6
+COMMENT?= PHP wrapper to the ImageMagick/GraphicsMagick library
WWW= https://pecl.php.net/package/imagick
LICENSE= PHP301
-USES= cpe php:pecl localbase
+USES= cpe php:pecl localbase magick
CPE_VENDOR= php
-CONFLICTS_INSTALL?= ${PKGNAMEPREFIX}${PORTNAME}-im7
-
-OPTIONS_DEFINE= X11
-
-X11_USES?= magick:6
-X11_USES_OFF?= magick:6,nox11
-
CONFIGURE_ARGS= --with-imagick=${LOCALBASE}
.include <bsd.port.mk>