aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-11-01 13:26:27 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-11-01 13:41:48 +0000
commitb931cf4dbd5924bbd71b7bbfa405bea3a97bc888 (patch)
tree8b17774996823ff17c8ccfe7ba677204a15e8b37
parent9eb2e1b42d8e755e1b506459ca5dce0b5afffc5f (diff)
downloadports-b931cf4dbd5924bbd71b7bbfa405bea3a97bc888.tar.gz
ports-b931cf4dbd5924bbd71b7bbfa405bea3a97bc888.zip
math/py-statsmodels: Update to 0.13.0
-rw-r--r--math/py-statsmodels/Makefile16
-rw-r--r--math/py-statsmodels/distinfo6
-rw-r--r--math/py-statsmodels/pkg-plist30
3 files changed, 41 insertions, 11 deletions
diff --git a/math/py-statsmodels/Makefile b/math/py-statsmodels/Makefile
index 87556fac2333..04d4b628082b 100644
--- a/math/py-statsmodels/Makefile
+++ b/math/py-statsmodels/Makefile
@@ -1,7 +1,7 @@
# Created by: Johannes Meixner <johannes@perceivon.net>
PORTNAME= statsmodels
-PORTVERSION= 0.12.2
+PORTVERSION= 0.13.0
CATEGORIES= math python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,13 +12,13 @@ COMMENT= Complement to SciPy for statistical computations
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0.29:lang/cython@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}numpy>=1.15,1:math/py-numpy@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}scipy>=1.1:science/py-scipy@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.15,1:math/py-numpy@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pandas>=0.21,1:math/py-pandas@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}patsy>=0.5:math/py-patsy@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}scipy>=1.1:science/py-scipy@${PY_FLAVOR}
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cython>=0.29.22:lang/cython@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}numpy>=1.17,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=1.3:science/py-scipy@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.17,1:math/py-numpy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pandas>=0.25,1:math/py-pandas@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}patsy>=0.5.2:math/py-patsy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}scipy>=1.3:science/py-scipy@${PY_FLAVOR}
USES= python:3.7+ shebangfix
USE_PYTHON= autoplist concurrent cython distutils
diff --git a/math/py-statsmodels/distinfo b/math/py-statsmodels/distinfo
index c4b6ca4f590a..9037dd4fe6e1 100644
--- a/math/py-statsmodels/distinfo
+++ b/math/py-statsmodels/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1612519149
-SHA256 (statsmodels-0.12.2.tar.gz) = 8ad7a7ae7cdd929095684118e3b05836c0ccb08b6a01fe984159475d174a1b10
-SIZE (statsmodels-0.12.2.tar.gz) = 17470078
+TIMESTAMP = 1635730995
+SHA256 (statsmodels-0.13.0.tar.gz) = f2efc02011b7240a9e851acd76ab81150a07d35c97021cb0517887539a328f8a
+SIZE (statsmodels-0.13.0.tar.gz) = 17766215
diff --git a/math/py-statsmodels/pkg-plist b/math/py-statsmodels/pkg-plist
index 7941e114374b..c2bc5581e0d4 100644
--- a/math/py-statsmodels/pkg-plist
+++ b/math/py-statsmodels/pkg-plist
@@ -8,9 +8,11 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/incomplete/ols_tftest.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/incomplete/wls_extended.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/autoregressions.ipynb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/autoregressive_distributed_lag.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/categorical_interaction_plot.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/chi2_fitting.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/contrasts.ipynb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/copula.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/deterministics.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/discrete_choice_example.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/discrete_choice_overview.ipynb
@@ -28,12 +30,14 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/influence_glm_logit.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/interactions_anova.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/kernel_density.ipynb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/lowess.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/markov_autoregression.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/markov_regression.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/mediation_survival.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/metaanalysis1.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/mixed_lm_example.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/ols.ipynb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/ordinal_regression.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/pca_fertility_factors.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/plots_boxplots.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/predict.ipynb
@@ -56,6 +60,7 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/statespace_forecasting.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/statespace_local_linear_trend.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/statespace_news.ipynb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/statespace_sarimax_faq.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/statespace_sarimax_internet.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/statespace_sarimax_pymc3.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/statespace_sarimax_stata.ipynb
@@ -72,14 +77,21 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/tsa_filters.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/variance_components.ipynb
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/notebooks/wls.ipynb
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/autoregressions.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/autoregressive_distributed_lag.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/categorical_interaction_plot.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/chi2_fitting.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/contrasts.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/copula.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/deterministics.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/discrete_choice_example.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/discrete_choice_overview.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/distributed_estimation.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/ets.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/exponential_smoothing.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/formulas.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/gee_nested_simulation.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/gee_score_test_simulation.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/generic_mle.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/glm.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/glm_formula.py
@@ -88,32 +100,50 @@
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/influence_glm_logit.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/interactions_anova.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/kernel_density.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/lowess.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/markov_autoregression.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/markov_regression.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/mediation_survival.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/metaanalysis1.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/mixed_lm_example.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/ols.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/ordinal_regression.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/pca_fertility_factors.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/plots_boxplots.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/predict.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/quantile_regression.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/quasibinomial.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/recursive_ls.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/regression_diagnostics.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/regression_plots.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/robust_models_0.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/robust_models_1.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/rolling_ls.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_arma_0.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_chandrasekhar.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_concentrated_scale.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_custom_models.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_cycles.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_dfm_coincident.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_fixed_params.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_forecasting.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_local_linear_trend.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_news.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_sarimax_faq.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_sarimax_internet.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_sarimax_pymc3.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_sarimax_stata.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_seasonal.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_structural_harvey_jaeger.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_tvpvar_mcmc_cfa.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/statespace_varmax.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/stationarity_detrending_adf_kpss.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/stl_decomposition.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/theta-model.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/tsa_arma_0.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/tsa_arma_1.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/tsa_dates.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/tsa_filters.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/variance_components.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/python/wls.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/run_all.py