aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2023-03-24 10:57:23 +0000
committerChris Rees <crees@FreeBSD.org>2023-03-24 12:13:08 +0000
commitb9be9ee1c2a5866f15113f538786910b7cf69782 (patch)
tree2729258a4774cc148d9483a8874b84d9869d1b1d
parent4b6e26bfcb8f96732b5c52df8096f9064efd1eb5 (diff)
downloadports-b9be9ee1c2a5866f15113f538786910b7cf69782.tar.gz
ports-b9be9ee1c2a5866f15113f538786910b7cf69782.zip
misc/py-icoextract: New port
icoextract is an icon extractor for Windows PE files (.exe/.dll), written in Python. It also includes a thumbnailer script (exe-thumbnailer) for Linux desktops. This project is inspired by extract-icon-py, icoutils, and others. icoextract aims to be: Lightweight Portable (cross-platform) Fast on large files
-rw-r--r--misc/Makefile1
-rw-r--r--misc/py-icoextract/Makefile20
-rw-r--r--misc/py-icoextract/distinfo3
-rw-r--r--misc/py-icoextract/pkg-descr12
4 files changed, 36 insertions, 0 deletions
diff --git a/misc/Makefile b/misc/Makefile
index 723256f0c2c9..fa5ebf0a6bbd 100644
--- a/misc/Makefile
+++ b/misc/Makefile
@@ -412,6 +412,7 @@
SUBDIR += py-halo
SUBDIR += py-histoprint
SUBDIR += py-huepy
+ SUBDIR += py-icoextract
SUBDIR += py-ipyfastscape
SUBDIR += py-kartograph
SUBDIR += py-lightgbm
diff --git a/misc/py-icoextract/Makefile b/misc/py-icoextract/Makefile
new file mode 100644
index 000000000000..05adfd147c2c
--- /dev/null
+++ b/misc/py-icoextract/Makefile
@@ -0,0 +1,20 @@
+PORTNAME= icoextract
+PORTVERSION= 0.1.4
+CATEGORIES= misc
+MASTER_SITES= GH
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= crees@FreeBSD.org
+COMMENT= Extract icons from Windows EXE and DLL files
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pefile>0:devel/py-pefile@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:graphics/py-pillow@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils autoplist
+USE_GITHUB= yes
+GH_ACCOUNT= jlu5
+
+.include <bsd.port.mk>
diff --git a/misc/py-icoextract/distinfo b/misc/py-icoextract/distinfo
new file mode 100644
index 000000000000..4ef5486acfcb
--- /dev/null
+++ b/misc/py-icoextract/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1678578100
+SHA256 (jlu5-icoextract-0.1.4_GH0.tar.gz) = 9d84a6191c02326bdf6f7689184540aba5b683b9c626ed832ff20c426f2d6746
+SIZE (jlu5-icoextract-0.1.4_GH0.tar.gz) = 46660
diff --git a/misc/py-icoextract/pkg-descr b/misc/py-icoextract/pkg-descr
new file mode 100644
index 000000000000..ed1bdbc4c729
--- /dev/null
+++ b/misc/py-icoextract/pkg-descr
@@ -0,0 +1,12 @@
+icoextract is an icon extractor for Windows PE files (.exe/.dll),
+written in Python. It also includes a thumbnailer script
+(exe-thumbnailer) for Linux desktops.
+
+This project is inspired by extract-icon-py, icoutils,
+and others.
+
+icoextract aims to be:
+
+ Lightweight
+ Portable (cross-platform)
+ Fast on large files