aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimur I. Bakeyev <timur@FreeBSD.org>2009-02-20 14:47:24 +0000
committerTimur I. Bakeyev <timur@FreeBSD.org>2009-02-20 14:47:24 +0000
commitb9f49abb5cfd9108bc608bfd6f862e42aacf6784 (patch)
tree2f7823230da3cc7edb931017b295ddb11c8fe144
parentf63ffb288750dc1841cf79d178a652295b6cd91e (diff)
downloadports-b9f49abb5cfd9108bc608bfd6f862e42aacf6784.tar.gz
ports-b9f49abb5cfd9108bc608bfd6f862e42aacf6784.zip
Fixed the order of CONFIGURE_ARGS so, that disabling NLS actually work.
As it's not default setting no revision bump is required.
Notes
Notes: svn path=/head/; revision=228707
-rw-r--r--www/neon28/Makefile20
-rw-r--r--www/neon29/Makefile20
2 files changed, 24 insertions, 16 deletions
diff --git a/www/neon28/Makefile b/www/neon28/Makefile
index bd5132d87038..1bb0fb7c1067 100644
--- a/www/neon28/Makefile
+++ b/www/neon28/Makefile
@@ -22,14 +22,6 @@ CONFLICTS= neon26-[0-9]*
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.endif
-
.ifndef WITHOUT_OPENSSL
USE_OPENSSL= yes
.endif
@@ -42,6 +34,18 @@ CONFIGURE_ARGS= --with-ssl \
--with-expat \
--with-libs=${LOCALBASE}:${PREFIX}
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+.if defined(WITHOUT_GSSAPI)
+CONFIGURE_ARGS+=--without-gssapi
+.endif
+
MAN1= neon-config.1
MAN3= ne_add_request_header.3 ne_addr_resolve.3 ne_buffer.3 \
ne_buffer_append.3 ne_buffer_clear.3 ne_buffer_create.3 \
diff --git a/www/neon29/Makefile b/www/neon29/Makefile
index bd5132d87038..1bb0fb7c1067 100644
--- a/www/neon29/Makefile
+++ b/www/neon29/Makefile
@@ -22,14 +22,6 @@ CONFLICTS= neon26-[0-9]*
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
-USE_GETTEXT= yes
-PLIST_SUB+= NLS=""
-.endif
-
.ifndef WITHOUT_OPENSSL
USE_OPENSSL= yes
.endif
@@ -42,6 +34,18 @@ CONFIGURE_ARGS= --with-ssl \
--with-expat \
--with-libs=${LOCALBASE}:${PREFIX}
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.endif
+
+.if defined(WITHOUT_GSSAPI)
+CONFIGURE_ARGS+=--without-gssapi
+.endif
+
MAN1= neon-config.1
MAN3= ne_add_request_header.3 ne_addr_resolve.3 ne_buffer.3 \
ne_buffer_append.3 ne_buffer_clear.3 ne_buffer_create.3 \