aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikolaj Golub <trociny@FreeBSD.org>2023-06-28 06:17:59 +0000
committerMikolaj Golub <trociny@FreeBSD.org>2023-06-28 06:27:40 +0000
commitba4c77cf20f8eb6991c17843d7fd95628c0aeb2e (patch)
tree69709041433d6f5773b08fcf8bc8712d4d63d02c
parentdaa254451e8cd5cd1a3911eb2de037669cbab7dc (diff)
downloadports-ba4c77cf20f8eb6991c17843d7fd95628c0aeb2e.tar.gz
ports-ba4c77cf20f8eb6991c17843d7fd95628c0aeb2e.zip
databases/leofs: fix build with clang 16
Since clang 16 (and gcc 11) the default C++ standard is now gnu++17. Because Makefile does not explicitly set its C++ standard, this leads to the error when building eleveldb: util/bloom.cc:100:10: error: no template named 'auto_ptr' in namespace 'std' std::auto_ptr<const FilterPolicy> m_Item; ~~~~~^ Add USE_CXXSTD=gnu++11 to avoid this error.
-rw-r--r--databases/leofs/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/databases/leofs/Makefile b/databases/leofs/Makefile
index 2d86eb92f082..87969c2295fb 100644
--- a/databases/leofs/Makefile
+++ b/databases/leofs/Makefile
@@ -1,6 +1,6 @@
PORTNAME= leofs
DISTVERSION= 1.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= databases
DIST_SUBDIR= ${PORTNAME}
@@ -55,6 +55,7 @@ SUB_LIST+= LEOFS_USER=${LEOFS_USER} \
SUB_FILES+= ${LEOFS_SBIN_FILES:S/^/sbin-/}
USES= dos2unix gmake pkgconfig ssl
+USE_CXXSTD= gnu++11
USE_RC_SUBR= ${PORTNAME}
DOS2UNIX_FILES= apps/leo_*/snmp/snmpa_*/leo_*_snmp.config