aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-11-20 22:07:56 +0000
committerAdriaan de Groot <adridg@FreeBSD.org>2021-11-20 22:30:28 +0000
commitba53edfff7f33f38bb7ecf19f813d39ba5729edd (patch)
tree5107ffd8802d0ab9fb48ae95e3e9c94a059b764f
parente4813a53c7dbcfb5a6f8c7a6ced31f393fc05622 (diff)
downloadports-ba53edfff7f33f38bb7ecf19f813d39ba5729edd.tar.gz
ports-ba53edfff7f33f38bb7ecf19f813d39ba5729edd.zip
ftp/coeurl: New port, C++ wrapper around libcurl
Functionally, This seems to be an awful lot like ftp/curlpp, but consumers want something else. This is part of the mtxclient and nheko Matrix stack.
-rw-r--r--ftp/Makefile1
-rw-r--r--ftp/coeurl/Makefile25
-rw-r--r--ftp/coeurl/distinfo3
-rw-r--r--ftp/coeurl/pkg-descr5
-rw-r--r--ftp/coeurl/pkg-plist7
5 files changed, 41 insertions, 0 deletions
diff --git a/ftp/Makefile b/ftp/Makefile
index 927c8e8f9344..5f9c9638ce9c 100644
--- a/ftp/Makefile
+++ b/ftp/Makefile
@@ -8,6 +8,7 @@
SUBDIR += bftpd
SUBDIR += bsdftpd-ssl
SUBDIR += cmdftp
+ SUBDIR += coeurl
SUBDIR += curl
SUBDIR += curlie
SUBDIR += curlpp
diff --git a/ftp/coeurl/Makefile b/ftp/coeurl/Makefile
new file mode 100644
index 000000000000..8e7ab363cc58
--- /dev/null
+++ b/ftp/coeurl/Makefile
@@ -0,0 +1,25 @@
+PORTNAME= coeurl
+DISTVERSIONPREFIX=v
+DISTVERSION= 0.1.0
+CATEGORIES= ftp www
+
+MAINTAINER= adridg@FreeBSD.org
+COMMENT= Simple async wrapper around CURL for C++
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= \
+ libcurl.so:ftp/curl \
+ libevent.so:devel/libevent \
+ libspdlog.so:devel/spdlog
+
+USES= compiler:c++17-lang pkgconfig \
+ meson tar:xz
+
+USE_GITLAB= yes
+GL_SITE= https://nheko.im/
+GL_ACCOUNT= nheko-reborn
+GL_COMMIT= a08f619adaa1ccd34eb6315d6578eddae0d1cc9b
+
+.include <bsd.port.mk>
diff --git a/ftp/coeurl/distinfo b/ftp/coeurl/distinfo
new file mode 100644
index 000000000000..3b3f2ff15ab3
--- /dev/null
+++ b/ftp/coeurl/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1637438851
+SHA256 (nheko-reborn-coeurl-a08f619adaa1ccd34eb6315d6578eddae0d1cc9b_GL0.tar.gz) = fee0dc804699d99b01b994943d2a64178b9ca1827d4b1cb4f27d7d34d8235ce8
+SIZE (nheko-reborn-coeurl-a08f619adaa1ccd34eb6315d6578eddae0d1cc9b_GL0.tar.gz) = 51155
diff --git a/ftp/coeurl/pkg-descr b/ftp/coeurl/pkg-descr
new file mode 100644
index 000000000000..7e2f95c9b858
--- /dev/null
+++ b/ftp/coeurl/pkg-descr
@@ -0,0 +1,5 @@
+Simple library to do http requests asynchronously via CURL in C++.
+(Eventually as coroutines, once all the compilers I need to support
+support them.) This is based on the CURL-libevent example.
+
+WWW: https://nheko.im/nheko-reborn/coeurl
diff --git a/ftp/coeurl/pkg-plist b/ftp/coeurl/pkg-plist
new file mode 100644
index 000000000000..2e9882675a3f
--- /dev/null
+++ b/ftp/coeurl/pkg-plist
@@ -0,0 +1,7 @@
+include/coeurl/client.hpp
+include/coeurl/headers.hpp
+include/coeurl/request.hpp
+lib/libcoeurl.so
+lib/libcoeurl.so.0
+lib/libcoeurl.so.0.1.0
+libdata/pkgconfig/coeurl.pc