aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2024-06-10 21:06:09 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2024-06-10 21:26:01 +0000
commitba54accf2651fcc45ff208e347e7d3190ecdb08b (patch)
tree6988d74092b10ec7bfabfbd7757cd89748f952d8
parent33af18c5b93efbf067054619f3104975016a41bc (diff)
downloadports-ba54accf2651fcc45ff208e347e7d3190ecdb08b.tar.gz
ports-ba54accf2651fcc45ff208e347e7d3190ecdb08b.zip
devel/kdesvn: Try to prevent overlinking
Add -Wl,--as-needed to LDFLAGS to prevent overlinking and remove incorrect dependency of BDB5 PR: 279128 Approved by: kde (tcberner)
-rw-r--r--devel/kdesvn/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/devel/kdesvn/Makefile b/devel/kdesvn/Makefile
index c4e2a9d7b9c8..47bd885a652c 100644
--- a/devel/kdesvn/Makefile
+++ b/devel/kdesvn/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS+= libsvn_client-1.so:devel/subversion
CONFLICTS_INSTALL= qsvn
-USES= bdb cmake compiler:c++11-lang kde:5 qt:5 tar:xz xorg
+USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz xorg
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons dbusaddons i18n iconthemes itemviews jobwidgets kio \
notifications parts service solid sonnet texteditor \
@@ -34,6 +34,8 @@ USE_XORG= x11
PORTSCOUT= ignore:1
+LDFLAGS+= -Wl,--as-needed
+
post-patch:
${REINPLACE_CMD} -e 's#%%EXECINFO%%#${EXECINFO_LDFLAGS} -lexecinfo#' \
${PATCH_WRKSRC}/src/svnqt/cmake/FindSubversion.cmake