aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-03 16:41:55 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-03-03 16:41:55 +0000
commitba6b3ee34e4da6cb8f0ec08eaa299cdf019aab48 (patch)
tree4bb24872326d943cb0c5f512837b5953a7203d53
parent6bd9a5f31b1b9f5428e08a16e21a66e444be9a8a (diff)
downloadports-ba6b3ee34e4da6cb8f0ec08eaa299cdf019aab48.tar.gz
ports-ba6b3ee34e4da6cb8f0ec08eaa299cdf019aab48.zip
- Switch to USES=tar
- Properly fix shebang - Add NO_ARCH - Switch to options helpers
Notes
Notes: svn path=/head/; revision=410059
-rw-r--r--security/mussh/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/security/mussh/Makefile b/security/mussh/Makefile
index 69f7ff36ad27..7403a09980e9 100644
--- a/security/mussh/Makefile
+++ b/security/mussh/Makefile
@@ -5,28 +5,33 @@ PORTNAME= mussh
PORTVERSION= 1.0
CATEGORIES= security
MASTER_SITES= SF
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool for easily running the same commands on multiple hosts
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USES= shebangfix tar:tgz
+SHEBANG_FILES= ${WRKSRC}/${PORTNAME}
NO_BUILD= yes
+NO_ARCH= yes
+
PORTDOCS= BUGS CHANGES EXAMPLES README
PLIST_FILES= bin/mussh
-WRKSRC= ${WRKDIR}/${PORTNAME}
OPTIONS_DEFINE= DOCS
post-patch:
- ${REINPLACE_CMD} -e "s,^#!/bin/bash,#!/usr/bin/env bash,g" \
- -e "s,seq 1 ,jot 1 ,g" \
+ @${REINPLACE_CMD} -e "s,seq 1 ,jot 1 ,g" \
${WRKSRC}/${PORTNAME}
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}