aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2023-04-06 13:54:54 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2023-04-06 13:54:54 +0000
commitba8f7956c72febadc10438262d0826e3934bdd5e (patch)
tree4c26a50b8c891c642fdaef97c38ffbf63ab13572
parent18fb6fb22235ae0fb9b0303d211cdaf1368ae4db (diff)
downloadports-ba8f7956c72febadc10438262d0826e3934bdd5e.tar.gz
ports-ba8f7956c72febadc10438262d0826e3934bdd5e.zip
net/downzemall: new port had been added (+)
DownZemAll! is a multi-platform mass download manager. It helps one to select, organize, prioritize, and run many downloads in parallel. Disable translations for now because required `tools' Qt 6 component pulls LLVM 15 which is too high price to pay to get `LinguistTools'.
-rw-r--r--net/Makefile1
-rw-r--r--net/downzemall/Makefile40
-rw-r--r--net/downzemall/distinfo3
-rw-r--r--net/downzemall/files/patch-src_CMakeLists.txt35
-rw-r--r--net/downzemall/pkg-descr5
5 files changed, 84 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 910fbdf44934..bac3ba307d14 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -127,6 +127,7 @@
SUBDIR += dhcprelya
SUBDIR += dictd
SUBDIR += dimes
+ SUBDIR += downzemall
SUBDIR += dpdk
SUBDIR += dpdk-20.11
SUBDIR += dpinger
diff --git a/net/downzemall/Makefile b/net/downzemall/Makefile
new file mode 100644
index 000000000000..acc3cd068216
--- /dev/null
+++ b/net/downzemall/Makefile
@@ -0,0 +1,40 @@
+PORTNAME= ${GH_PROJECT:tl}
+PORTVERSION= 3.0.3
+DISTVERSIONPREFIX= v
+CATEGORIES= net
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Multi-protocol standalone download manager
+WWW= https://setvisible.github.io/DownZemAll/
+
+LICENSE= LGPL21+
+
+LIB_DEPENDS= libtorrent-rasterbar.so:net-p2p/libtorrent-rasterbar2
+
+USES= cmake qt:6 ssl
+USE_QT= base
+USE_GITHUB= yes
+GH_ACCOUNT= setvisible
+GH_PROJECT= DownZemAll
+
+CMAKE_OFF= BUILD_LAUNCHER BUILD_TESTS
+
+PLIST_FILES= bin/DownZemAll \
+ share/applications/DownZemAll.desktop \
+ share/pixmaps/DownZemAll.png
+
+post-extract:
+ @${RM} -r ${WRKSRC}/3rd/libtorrent-rasterbar
+ @${RM} ${WRKSRC}/cmake/Modules/FindLibtorrentRasterbar.cmake
+
+do-install:
+ ${INSTALL_PROGRAM} ${INSTALL_WRKSRC}/src/DownZemAll \
+ ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} \
+ ${WRKSRC}/installer/unix/appimage/DownZemAll.desktop \
+ ${STAGEDIR}${PREFIX}/share/applications
+ ${INSTALL_DATA} \
+ ${WRKSRC}/installer/unix/portable/DownZemAll_64x64.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/DownZemAll.png
+
+.include <bsd.port.mk>
diff --git a/net/downzemall/distinfo b/net/downzemall/distinfo
new file mode 100644
index 000000000000..f4c1732923a7
--- /dev/null
+++ b/net/downzemall/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1680382911
+SHA256 (setvisible-DownZemAll-v3.0.3_GH0.tar.gz) = f9b1ad2d2a43c0e39606085b35d8eeb2fc147afd32cef2d34eb1fc119bcb6a98
+SIZE (setvisible-DownZemAll-v3.0.3_GH0.tar.gz) = 42449624
diff --git a/net/downzemall/files/patch-src_CMakeLists.txt b/net/downzemall/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..d03ca3d36ce4
--- /dev/null
+++ b/net/downzemall/files/patch-src_CMakeLists.txt
@@ -0,0 +1,35 @@
+--- src/CMakeLists.txt.orig 2023-04-01 21:01:51 UTC
++++ src/CMakeLists.txt
+@@ -10,7 +10,6 @@ find_package(GoogleGumboParser REQUIRED)
+ find_package(Qt6 REQUIRED COMPONENTS
+ Core
+ Gui
+- LinguistTools
+ Network
+ Widgets
+ )
+@@ -72,6 +71,7 @@ target_compile_definitions(${TARGET_NAME}
+ UNICODE
+ )
+
++if(false)
+ qt_add_translations(${TARGET_NAME}
+ TS_FILES
+ ${CMAKE_SOURCE_DIR}/src/locale/dza_ar_EG.ts # Arabic
+@@ -93,6 +93,7 @@ qt_add_translations(${TARGET_NAME}
+ QM_FILES_OUTPUT_VARIABLE
+ qm_files
+ )
++endif()
+
+ if(MSVC OR MSYS OR MINGW) # for detecting Windows compilers
+
+@@ -123,7 +124,7 @@ else() # MacOS or Unix Compilers
+ target_link_libraries(${TARGET_NAME}
+ PRIVATE
+ ${GoogleGumboParser_LIBRARIES}
+- ${LibtorrentRasterbar_LIBRARIES}
++ LibtorrentRasterbar::torrent-rasterbar
+
+ Threads::Threads
+
diff --git a/net/downzemall/pkg-descr b/net/downzemall/pkg-descr
new file mode 100644
index 000000000000..797919a670ca
--- /dev/null
+++ b/net/downzemall/pkg-descr
@@ -0,0 +1,5 @@
+DownZemAll! is a multi-platform mass download manager. It helps one to
+select, organize, prioritize, and run many downloads in parallel.
+
+Based on the Qt framework, DownZemAll! is written in C/C++ and supports
+various download types (regular files, video streams, torrents).