aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDimitry Andric <dim@FreeBSD.org>2023-05-08 20:12:30 +0000
committerDimitry Andric <dim@FreeBSD.org>2023-05-18 11:34:09 +0000
commitbaf5218c3bf238c5feea231a3c587b416b689016 (patch)
treecf3f3cb30f5612f3214afb874f858d282721590d
parent67237e5afd193f57fb2153072d01d6645eb79b5c (diff)
downloadports-baf5218c3bf238c5feea231a3c587b416b689016.tar.gz
ports-baf5218c3bf238c5feea231a3c587b416b689016.zip
security/libsecret: fix build with clang 16
Clang 16 has a new error about incompatible function types, which shows up when building security/libsecret: libsecret/test-vala-lang.p/test-vala-lang.c:1166:51: error: incompatible function pointer types passing 'void (gpointer)' (aka 'void (void *)') to parameter of type 'GTestDataFunc' (aka 'void (*)(const void *)') [-Wincompatible-function-pointer-types] g_test_add_data_func ("/vala/lookup/sync", NULL, _test_lookup_sync_gtest_data_func); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ /usr/local/include/glib-2.0/glib/gtestutils.h:337:58: note: passing argument to parameter 'test_func' here GTestDataFunc test_func); ^ Since the errors all occur in vala-generated code, it does not make sense to patch the .c files. Suppress the warning instead. PR: 271320 Approved by: portmgr (build fix blanket) MFH: 2023Q2
-rw-r--r--security/libsecret/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/security/libsecret/Makefile b/security/libsecret/Makefile
index 08b778bb54a3..b6807abddf2f 100644
--- a/security/libsecret/Makefile
+++ b/security/libsecret/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libsecret
PORTVERSION= 0.20.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security gnome
MASTER_SITES= GNOME
@@ -15,7 +15,13 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gi-docgen>0:textproc/py-gi-docgen@${PY_FLA
LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libgpg-error.so:security/libgpg-error
-USES= gnome meson pkgconfig python:3.8+ tar:xz vala:build
+USES= compiler gnome meson pkgconfig python:3.8+ tar:xz vala:build
USE_GNOME= glib20 intltool introspection:build libxslt:build
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang
+CFLAGS+= -Wno-incompatible-function-pointer-types
+.endif
+
+.include <bsd.port.post.mk>