aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Moench-Tegeder <cmt@FreeBSD.org>2023-02-10 18:38:45 +0000
committerChristoph Moench-Tegeder <cmt@FreeBSD.org>2023-02-10 18:38:45 +0000
commitbb3b17fce7374dde7053048a8f71802780244090 (patch)
tree985a4a0dd3b5d8ff3f552a04ef5ed7db15e15474
parent71dda54b318583d02e571f99b6efa036405e4749 (diff)
downloadports-bb3b17fce7374dde7053048a8f71802780244090.tar.gz
ports-bb3b17fce7374dde7053048a8f71802780244090.zip
mail/thunderbird: update to 102.8.0 (rc1)
-rw-r--r--mail/thunderbird/Makefile2
-rw-r--r--mail/thunderbird/distinfo6
-rw-r--r--mail/thunderbird/files/patch-bug179998260
3 files changed, 4 insertions, 64 deletions
diff --git a/mail/thunderbird/Makefile b/mail/thunderbird/Makefile
index 7be54b91841c..d29e043f677f 100644
--- a/mail/thunderbird/Makefile
+++ b/mail/thunderbird/Makefile
@@ -1,5 +1,5 @@
PORTNAME= thunderbird
-DISTVERSION= 102.7.2
+DISTVERSION= 102.8.0
CATEGORIES= mail news net-im wayland
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source \
MOZILLA/${PORTNAME}/candidates/${DISTVERSION}-candidates/build1/source
diff --git a/mail/thunderbird/distinfo b/mail/thunderbird/distinfo
index ce1a42c5c55d..11c0b6651515 100644
--- a/mail/thunderbird/distinfo
+++ b/mail/thunderbird/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1675765010
-SHA256 (thunderbird-102.7.2.source.tar.xz) = 73713a19226a2bee353f5fc4f1e00e5b2df45c35ac8c3866d98094b00995386f
-SIZE (thunderbird-102.7.2.source.tar.xz) = 502932420
+TIMESTAMP = 1676016538
+SHA256 (thunderbird-102.8.0.source.tar.xz) = 716ea922163ad9d92a06198380e074b27bde076e3cf1ff77100fdf065085277e
+SIZE (thunderbird-102.8.0.source.tar.xz) = 500467740
diff --git a/mail/thunderbird/files/patch-bug1799982 b/mail/thunderbird/files/patch-bug1799982
deleted file mode 100644
index dac77d73390b..000000000000
--- a/mail/thunderbird/files/patch-bug1799982
+++ /dev/null
@@ -1,60 +0,0 @@
-Bug 1799982 - Remove uses of inline flags from XPIDL regexps. r=xpcom-reviewers,kmag
-
-Apparently the use of these is being turned into an error in Python 3.11.
-Fortunately, our uses appears to be rather trivial.
-
-For t_multilinecomment and t_LCDATA, I dropped the (?s) flag and just
-replaced the one use of . with (\n|.). (?s) means DOTALL, which means
-that dot includes any character, including a newline. Otherwise it means
-dot includes any character except a newline.
-
-I took the new t_singlelinecomment from IPDL's parser.py, so I assume
-it is reasonable enough. t_multilinecomment is also now the same as
-in IPDL.
-
-Differential Revision: https://phabricator.services.mozilla.com/D161738
-
-diff --git xpcom/idl-parser/xpidl/xpidl.py xpcom/idl-parser/xpidl/xpidl.py
---- xpcom/idl-parser/xpidl/xpidl.py
-+++ xpcom/idl-parser/xpidl/xpidl.py
-@@ -1634,36 +1634,36 @@ class IDLParser(object):
- t_LSHIFT = r"<<"
- t_RSHIFT = r">>"
-
- literals = '"(){}[]<>,;:=|+-*'
-
- t_ignore = " \t"
-
- def t_multilinecomment(self, t):
-- r"/\*(?s).*?\*/"
-+ r"/\*(\n|.)*?\*/"
- t.lexer.lineno += t.value.count("\n")
- if t.value.startswith("/**"):
- self._doccomments.append(t.value)
-
- def t_singlelinecomment(self, t):
-- r"(?m)//.*?$"
-+ r"//[^\n]*"
-
- def t_IID(self, t):
- return t
-
- t_IID.__doc__ = r"%(c)s{8}-%(c)s{4}-%(c)s{4}-%(c)s{4}-%(c)s{12}" % {"c": hexchar}
-
- def t_IDENTIFIER(self, t):
- r"(unsigned\ long\ long|unsigned\ short|unsigned\ long|long\ long)(?!_?[A-Za-z][A-Za-z_0-9])|_?[A-Za-z][A-Za-z_0-9]*" # NOQA: E501
- t.type = self.keywords.get(t.value, "IDENTIFIER")
- return t
-
- def t_LCDATA(self, t):
-- r"(?s)%\{[ ]*C\+\+[ ]*\n(?P<cdata>.*?\n?)%\}[ ]*(C\+\+)?"
-+ r"%\{[ ]*C\+\+[ ]*\n(?P<cdata>(\n|.)*?\n?)%\}[ ]*(C\+\+)?"
- t.type = "CDATA"
- t.value = t.lexer.lexmatch.group("cdata")
- t.lexer.lineno += t.value.count("\n")
- return t
-
- def t_INCLUDE(self, t):
- r'\#include[ \t]+"[^"\n]+"'
- inc, value, end = t.value.split('"')
-