aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Nagy <rnagy@FreeBSD.org>2024-01-10 15:47:13 +0000
committerRobert Nagy <rnagy@FreeBSD.org>2024-01-10 15:48:46 +0000
commitbb5b510ef5c64ddd9a9c3b465f18808900c5780b (patch)
tree7d6cf8c08a9945fef8d5d15f391f619d0e657dc2
parent6bddc6bb2cc20ec022a282a4cbc36d2102af556f (diff)
downloadports-bb5b510ef5c64ddd9a9c3b465f18808900c5780b.tar.gz
ports-bb5b510ef5c64ddd9a9c3b465f18808900c5780b.zip
www/chromium: update to 120.0.6099.216
include a better arm64 cpu feature detection patch from jbeich@ while here Security: https://vuxml.freebsd.org/freebsd/ec8e4040-afcd-11ee-86bb-a8a1599412c6.html
-rw-r--r--www/chromium/Makefile2
-rw-r--r--www/chromium/distinfo14
-rw-r--r--www/chromium/files/patch-third__party_libvpx_source_libvpx_vpx__ports_aarch64__cpudetect.c35
3 files changed, 29 insertions, 22 deletions
diff --git a/www/chromium/Makefile b/www/chromium/Makefile
index 26cec7ebc3ed..7b3ed9a78ca3 100644
--- a/www/chromium/Makefile
+++ b/www/chromium/Makefile
@@ -1,5 +1,5 @@
PORTNAME= chromium
-PORTVERSION= 120.0.6099.199
+PORTVERSION= 120.0.6099.216
CATEGORIES= www wayland
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/ \
https://nerd.hu/distfiles/:external
diff --git a/www/chromium/distinfo b/www/chromium/distinfo
index f90fe1b5e118..ca30afcb16d4 100644
--- a/www/chromium/distinfo
+++ b/www/chromium/distinfo
@@ -1,9 +1,9 @@
-TIMESTAMP = 1704354352
-SHA256 (chromium-120.0.6099.199.tar.xz) = 84009db5c898517f38f7b44b81b8a98e21fd28ca3f9aad9dda07516d8640574c
-SIZE (chromium-120.0.6099.199.tar.xz) = 3285099132
-SHA256 (chrome-linux-120.0.6099.199-llvm16.profdata.tar.xz) = c213cbf92bf6ab498957c36f2c87790b839e66e007d0e85b9f3806fb1c2574b4
-SIZE (chrome-linux-120.0.6099.199-llvm16.profdata.tar.xz) = 29512472
-SHA256 (chromium-120.0.6099.199-testdata.tar.xz) = 089b154017795238f529108edb7cead30fb68bfaa3b976625128060554950ff9
-SIZE (chromium-120.0.6099.199-testdata.tar.xz) = 271532952
+TIMESTAMP = 1704901565
+SHA256 (chromium-120.0.6099.216.tar.xz) = 7e7bea15bf56f3cc920bb015fed1a1b1368267299e132e795935c5cc604adfc0
+SIZE (chromium-120.0.6099.216.tar.xz) = 3296304596
+SHA256 (chrome-linux-120.0.6099.216-llvm16.profdata.tar.xz) = c5f9464f6f9181d697c3be94169e271567f60ed3e867036f135f7df804e17cd5
+SIZE (chrome-linux-120.0.6099.216-llvm16.profdata.tar.xz) = 29508496
+SHA256 (chromium-120.0.6099.216-testdata.tar.xz) = c66136fa24d77fb27c04fca4fd2fec15004efad68f551d156eab038de93f40c6
+SIZE (chromium-120.0.6099.216-testdata.tar.xz) = 271802184
SHA256 (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = a2ca2962daf482a8f943163541e1c73ba4b2694fabcd2510981f2db4eda493c8
SIZE (test_fonts-336e775eec536b2d785cc80eff6ac39051931286.tar.gz) = 32624734
diff --git a/www/chromium/files/patch-third__party_libvpx_source_libvpx_vpx__ports_aarch64__cpudetect.c b/www/chromium/files/patch-third__party_libvpx_source_libvpx_vpx__ports_aarch64__cpudetect.c
index 92163a805c0c..ceeec71c950d 100644
--- a/www/chromium/files/patch-third__party_libvpx_source_libvpx_vpx__ports_aarch64__cpudetect.c
+++ b/www/chromium/files/patch-third__party_libvpx_source_libvpx_vpx__ports_aarch64__cpudetect.c
@@ -1,20 +1,27 @@
---- third_party/libvpx/source/libvpx/vpx_ports/aarch64_cpudetect.c.orig 2024-01-08 12:52:53 UTC
+--- third_party/libvpx/source/libvpx/vpx_ports/aarch64_cpudetect.c.orig 2024-01-09 18:29:07 UTC
+++ third_party/libvpx/source/libvpx/vpx_ports/aarch64_cpudetect.c
-@@ -153,7 +153,16 @@ static int arm_get_cpu_caps(void) {
+@@ -91,9 +91,23 @@ static int arm_get_cpu_caps(void) {
return flags;
}
--#else // end __Fuchsia__
-+#elif defined(__FreeBSD__) // end __Fuchsia__
+-#elif defined(__linux__) // end defined(VPX_USE_ANDROID_CPU_FEATURES)
++#elif defined(__linux__) || defined(__FreeBSD__) // end defined(VPX_USE_ANDROID_CPU_FEATURES)
+
+ #include <sys/auxv.h>
++
++#if defined(__FreeBSD__)
++static unsigned long getauxval(unsigned long type)
++{
++ /* Only AT_HWCAP* return unsigned long */
++ if (type != AT_HWCAP && type != AT_HWCAP2) {
++ return 0;
++ }
+
-+int arm_get_cpu_caps(void) {
-+ int flags = 0;
-+#if HAVE_NEON
-+ flags |= HAS_NEON; // Neon is mandatory in Armv8.0-A.
-+#endif // HAVE_NEON
-+ return flags;
++ unsigned long ret = 0;
++ elf_aux_info(type, &ret, sizeof(ret));
++ return ret;
+}
-+#else // end __FreeBSD__
- #error \
- "Runtime CPU detection selected, but no CPU detection method available" \
- "for your platform. Rerun configure with --disable-runtime-cpu-detect."
++#endif
+
+ // Define hwcap values ourselves: building with an old auxv header where these
+ // hwcap values are not defined should not prevent features from being enabled.