aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-19 16:27:09 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-05-19 17:18:12 +0000
commitbb6d604fa4ad0d9f08294e82c442fa9ddadc23cb (patch)
tree7f06b1b4b5089d9c001dbd92218b2f6123ca1e5c
parent20ee2883f6a5b2eaa308ffeb230b1b9544eac34a (diff)
net/rubygem-grpc: Update to 1.63.0
-rw-r--r--net/rubygem-grpc/Makefile5
-rw-r--r--net/rubygem-grpc/distinfo6
-rw-r--r--net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb11
3 files changed, 9 insertions, 13 deletions
diff --git a/net/rubygem-grpc/Makefile b/net/rubygem-grpc/Makefile
index d11b2a391ecf..40ac7ada7721 100644
--- a/net/rubygem-grpc/Makefile
+++ b/net/rubygem-grpc/Makefile
@@ -1,5 +1,5 @@
PORTNAME= grpc
-PORTVERSION= 1.62.0
+PORTVERSION= 1.63.0
CATEGORIES= net rubygems
MASTER_SITES= RG
@@ -9,8 +9,7 @@ WWW= https://github.com/grpc/grpc/tree/master/src/ruby
LICENSE= BSD3CLAUSE
-LIB_DEPENDS= libcares.so:dns/c-ares \
- libgrpc.so:devel/grpc
+LIB_DEPENDS= libgrpc.so:devel/grpc
RUN_DEPENDS= ca_root_nss>=0:security/ca_root_nss \
rubygem-google-protobuf>=3.25<4:devel/rubygem-google-protobuf \
rubygem-googleapis-common-protos-types>=1.0<2:devel/rubygem-googleapis-common-protos-types
diff --git a/net/rubygem-grpc/distinfo b/net/rubygem-grpc/distinfo
index fe7e94bee447..a035fff068dd 100644
--- a/net/rubygem-grpc/distinfo
+++ b/net/rubygem-grpc/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1709390974
-SHA256 (rubygem/grpc-1.62.0.gem) = f624d44ce89764ed61bd0d8c585bd6d7ec4b75ad421bdc7b370f09f101f6e80f
-SIZE (rubygem/grpc-1.62.0.gem) = 6573056
+TIMESTAMP = 1715843764
+SHA256 (rubygem/grpc-1.63.0.gem) = 5f4383c4ee2886e92c31b90422261b7527f26e3baa585d877e9804e715983686
+SIZE (rubygem/grpc-1.63.0.gem) = 6638080
diff --git a/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb b/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
index a0ef4a9b6749..b15b15fabb59 100644
--- a/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
+++ b/net/rubygem-grpc/files/patch-src_ruby_ext_grpc_extconf.rb
@@ -1,6 +1,6 @@
---- src/ruby/ext/grpc/extconf.rb.orig 2023-12-08 17:22:30 UTC
+--- src/ruby/ext/grpc/extconf.rb.orig 2024-05-18 09:15:48 UTC
+++ src/ruby/ext/grpc/extconf.rb
-@@ -96,11 +96,11 @@ if apple_toolchain && !cross_compiling
+@@ -96,9 +96,9 @@ end
end
# Don't embed on TruffleRuby (constant-time crypto is unsafe with Sulong, slow build times)
@@ -10,12 +10,9 @@
-ENV['EMBED_ZLIB'] = (RUBY_ENGINE != 'truffleruby').to_s
+ENV['EMBED_ZLIB'] = 'false'
--ENV['EMBED_CARES'] = 'true'
-+ENV['EMBED_CARES'] = 'false'
-
ENV['ARCH_FLAGS'] = RbConfig::CONFIG['ARCH_FLAG']
if apple_toolchain && !cross_compiling
-@@ -125,30 +125,10 @@ ENV['BUILDDIR'] = output_dir
+@@ -122,30 +122,10 @@ strip_tool += ' -x' if apple_toolchain
strip_tool = RbConfig::CONFIG['STRIP']
strip_tool += ' -x' if apple_toolchain
@@ -46,7 +43,7 @@
def have_ruby_abi_version()
return true if RUBY_ENGINE == 'truffleruby'
# ruby_abi_version is only available in development versions: https://github.com/ruby/ruby/pull/6231
-@@ -177,13 +157,12 @@ def ext_export_filename()
+@@ -174,13 +154,12 @@ ext_export_file = File.join(grpc_root, 'src', 'ruby',
end
ext_export_file = File.join(grpc_root, 'src', 'ruby', 'ext', 'grpc', ext_export_filename())