aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-13 11:58:18 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-13 11:58:18 +0000
commitbbc144dcfe0da40b2f0cebca7195f63ffdb19c39 (patch)
tree3b3602efc537452d791e56e4c81e87118b7a2752
parent46325e178f28df98675a6006987bd37523eebb02 (diff)
downloadports-bbc144dcfe0da40b2f0cebca7195f63ffdb19c39.tar.gz
ports-bbc144dcfe0da40b2f0cebca7195f63ffdb19c39.zip
www/py-beaker: Update to 1.13.0
- Update WWW - Convert to USE_PYTHON=pep517 - Update pkg-descr Changes: https://github.com/bbangert/beaker/releases
-rw-r--r--www/py-beaker/Makefile10
-rw-r--r--www/py-beaker/distinfo6
-rw-r--r--www/py-beaker/files/patch-setup.py11
-rw-r--r--www/py-beaker/pkg-descr37
4 files changed, 40 insertions, 24 deletions
diff --git a/www/py-beaker/Makefile b/www/py-beaker/Makefile
index 7cd5a4104ed3..0dbc9a44cfed 100644
--- a/www/py-beaker/Makefile
+++ b/www/py-beaker/Makefile
@@ -1,5 +1,5 @@
PORTNAME= beaker
-PORTVERSION= 1.12.1
+PORTVERSION= 1.13.0
CATEGORIES= www python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -7,13 +7,17 @@ DISTNAME= Beaker-${PORTVERSION}
MAINTAINER= python@FreeBSD.org
COMMENT= Session and Caching library with WSGI Middleware
-WWW= https://beaker.readthedocs.io/en/latest/
+WWW= https://beaker.readthedocs.io/en/latest/ \
+ https://github.com/bbangert/beaker
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
+
USES= cpe python
-USE_PYTHON= autoplist distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes
diff --git a/www/py-beaker/distinfo b/www/py-beaker/distinfo
index 6ed913e2f98c..b43ace7ca520 100644
--- a/www/py-beaker/distinfo
+++ b/www/py-beaker/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1677771799
-SHA256 (Beaker-1.12.1.tar.gz) = 57770b40956e6c5cf1d8221dc59519029e470080ed8d3065c4e6ab36ce7e3c81
-SIZE (Beaker-1.12.1.tar.gz) = 67296
+TIMESTAMP = 1713001218
+SHA256 (Beaker-1.13.0.tar.gz) = e956cd8a35ad5de1b5212c7bff8fc01e2b3d34ab92466d24684c666abb8c9c30
+SIZE (Beaker-1.13.0.tar.gz) = 68250
diff --git a/www/py-beaker/files/patch-setup.py b/www/py-beaker/files/patch-setup.py
new file mode 100644
index 000000000000..e9517fa33a2d
--- /dev/null
+++ b/www/py-beaker/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2024-04-13 11:48:38 UTC
++++ setup.py
+@@ -54,7 +54,7 @@ if not sys.platform.startswith('java') and not sys.pla
+ TESTS_REQUIRE.extend(['pylibmc', 'python-memcached'])
+
+
+-setup(name='Beaker',
++setup(name='beaker',
+ version=VERSION,
+ description="A Session and Caching library with WSGI Middleware",
+ long_description=README,
diff --git a/www/py-beaker/pkg-descr b/www/py-beaker/pkg-descr
index 2f461a844976..c3d62c721b43 100644
--- a/www/py-beaker/pkg-descr
+++ b/www/py-beaker/pkg-descr
@@ -1,21 +1,22 @@
-Beaker is built on code from the package MyghtyUtils, originally used
-in the Myghty project. It implements a full set of cache functionality
-along with sessions that can utilize the caches.
+Beaker is a web session and general caching library that includes WSGI
+middleware for use in web applications.
-Beaker includes Cache and Session WSGI middleware to ease integration
-with WSGI capable frameworks, and is automatically used by Pylons.
+As a general caching library, Beaker can handle storing for various times any
+Python object that can be pickled with optional back-ends on a fine-grained
+basis.
Features
- * Fast, robust performance
- * Multiple reader/single writer lock system to avoid duplicate
- simultaneous cache creation
- * Cache back-ends include dbm, file, memory, memcached, and
- database (Using SQLAlchemy for multiple-db vendor support)
- * Signed cookie's to prevent session hijacking/spoofing
- * Extensible Container object to support new back-ends
- * Cache's can be divided into namespaces (to represent templates,
- objects, etc.) then keyed for different copies
- * Create functions for automatic call-backs to create new cache
- copies after expiration
- * Fine-grained toggling of back-ends, keys, and expiration per
- Cache object
+- Fast, robust performance
+- Multiple reader/single writer lock system to avoid duplicate simultaneous
+ cache creation
+- Cache back-ends include dbm, file, memory, memcached, Redis, MongoDB, and
+ database (Using SQLAlchemy for multiple-db vendor support)
+- Signed cookies to prevent session hijacking/spoofing
+- Cookie-only sessions to remove the need for a db or file backend (ideal for
+ clustered systems)
+- Extensible Container object to support new back-ends
+- Caches can be divided into namespaces (to represent templates, objects, etc.)
+ then keyed for different copies
+- Create functions for automatic call-backs to create new cache copies after
+ expiration
+- Fine-grained toggling of back-ends, keys, and expiration per Cache object