aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2023-06-09 05:29:28 +0000
committerCharlie Li <vishwin@FreeBSD.org>2023-06-09 05:32:57 +0000
commitbc106728715d27f7724f51e17e27b90a1b1c0369 (patch)
tree9d7528eeb91158fc376283b6de42bec372d5d3be
parent3835bb252e91cda64657878b8438f6440342f516 (diff)
downloadports-bc10672.tar.gz
ports-bc10672.zip
security/py-sequoia: remove
Deprecated upstream; security/sequoia no longer includes the parts necessary for this to work. PySequoia is the designated replacement and will be ported later, and MOVED will be updated accordingly. PR: 256877 Approved by: phryk-ports[at]wzff[dot]de (maintainer, transfer) Event: SouthEast LinuxFest 2023
-rw-r--r--MOVED1
-rw-r--r--security/Makefile1
-rw-r--r--security/py-sequoia/Makefile32
-rw-r--r--security/py-sequoia/distinfo3
-rw-r--r--security/py-sequoia/files/patch-Makefile12
-rw-r--r--security/py-sequoia/files/patch-setup.py11
-rw-r--r--security/py-sequoia/pkg-descr2
7 files changed, 1 insertions, 61 deletions
diff --git a/MOVED b/MOVED
index b43b2a0a5cde..440e949ceade 100644
--- a/MOVED
+++ b/MOVED
@@ -7635,3 +7635,4 @@ devel/rubygem-fast_gettext1|devel/rubygem-fast_gettext|2023-06-05|Remove obsolet
devel/rubygem-gettext-setup0|devel/rubygem-gettext-setup|2023-06-05|Remove obsoleted port. Use devel/rubygem-gettext-setup instead
archivers/libunrar|archivers/libunrar6|2023-06-06|Remove obsoleted port. Use archivers/libunrar6 instead
x11/radare-cutter||2023-06-07|Has expired: Cutter for radare has been discontinued as Cutter has moved to use rizin as their backend framework
+security/py-sequoia||2023-06-09|Deprecated upstream, broken as based on older dependency
diff --git a/security/Makefile b/security/Makefile
index 8a7c2ec6babd..77a2c542c210 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -1011,7 +1011,6 @@
SUBDIR += py-scrypt
SUBDIR += py-secure
SUBDIR += py-securesystemslib
- SUBDIR += py-sequoia
SUBDIR += py-service_identity
SUBDIR += py-signedjson
SUBDIR += py-social-auth-core
diff --git a/security/py-sequoia/Makefile b/security/py-sequoia/Makefile
deleted file mode 100644
index 2d98929b9696..000000000000
--- a/security/py-sequoia/Makefile
+++ /dev/null
@@ -1,32 +0,0 @@
-PORTNAME= sequoia
-DISTVERSIONPREFIX= v
-DISTVERSION= 0.19.0
-CATEGORIES= security python
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-
-MAINTAINER= phryk-ports@wzff.de
-COMMENT= Python binding of sequoia
-WWW= https://sequoia-pgp.org/
-
-LICENSE= GPLv2+
-LICENSE_FILE= ${WRKSRC}/../../../LICENSE.txt
-
-LIB_DEPENDS= libsequoia_ffi.so:security/sequoia
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1:devel/py-cffi@${PY_FLAVOR}
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1:devel/py-cffi@${PY_FLAVOR}
-
-USES= python:3.4+
-USE_PYTHON= distutils autoplist concurrent
-USE_GITLAB= yes
-
-WRKSRC_SUBDIR= ffi/lang/python
-
-GL_ACCOUNT= sequoia-pgp
-GL_PROJECT= sequoia
-GL_COMMIT= 383133f6be990237044900a4df676488bf8dd71e
-CFLAGS+= -I${LOCALBASE}/include
-
-post-install:
- ${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/_sequoia.abi3*.so
-
-.include <bsd.port.mk>
diff --git a/security/py-sequoia/distinfo b/security/py-sequoia/distinfo
deleted file mode 100644
index df65153d86a0..000000000000
--- a/security/py-sequoia/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1617892127
-SHA256 (sequoia-pgp-sequoia-383133f6be990237044900a4df676488bf8dd71e_GL0.tar.gz) = 729d53ae650f17591e34cbbd50963ea718eab7c133839770413225895f86eecd
-SIZE (sequoia-pgp-sequoia-383133f6be990237044900a4df676488bf8dd71e_GL0.tar.gz) = 2037633
diff --git a/security/py-sequoia/files/patch-Makefile b/security/py-sequoia/files/patch-Makefile
deleted file mode 100644
index ba1ed8a18104..000000000000
--- a/security/py-sequoia/files/patch-Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
---- Makefile.orig 2020-08-21 08:30:55 UTC
-+++ Makefile
-@@ -9,7 +9,8 @@ CFLAGS += -I../../include -I../../../openpgp-ffi/incl
- PYTHON ?= python3
- IPYTHON ?= ipython3
- PYTEST ?= pytest-3
--ifeq ($(shell uname -s), Darwin)
-+
-+ifneq ($(filter Darwin FreeBSD,$(shell uname -s)),"")
- INSTALL ?= ginstall
- else
- INSTALL ?= install
diff --git a/security/py-sequoia/files/patch-setup.py b/security/py-sequoia/files/patch-setup.py
deleted file mode 100644
index 2c2ece851c3e..000000000000
--- a/security/py-sequoia/files/patch-setup.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- setup.py.orig 2020-08-21 08:30:55 UTC
-+++ setup.py
-@@ -34,7 +34,7 @@ setup(
-
- packages=['sequoia'],
-
-- setup_requires=["cffi>=1.0.0", "pytest-runner"],
-+ setup_requires=["cffi>=1.0.0"],
- cffi_modules=["sequoia/sequoia_build.py:ffibuilder"],
- install_requires=["cffi>=1.0.0"],
- tests_require=["pytest"],
diff --git a/security/py-sequoia/pkg-descr b/security/py-sequoia/pkg-descr
deleted file mode 100644
index d83c2cfad2e3..000000000000
--- a/security/py-sequoia/pkg-descr
+++ /dev/null
@@ -1,2 +0,0 @@
-Sequoia is a cool new OpenPGP implementation. It consists of several crates,
-providing both a low-level and a high-level API for dealing with OpenPGP data.