aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2024-04-11 09:27:00 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2024-04-11 09:27:00 +0000
commitbc80854f3bb625b0c53915a2edb94a02375945bf (patch)
tree4f44a9e4c997a388b4e1e46462f76835db77d908
parent43d9a1336ddec3ddb059a4c78b33888272692c36 (diff)
downloadports-bc80854f3bb625b0c53915a2edb94a02375945bf.tar.gz
ports-bc80854f3bb625b0c53915a2edb94a02375945bf.zip
*/*: clean up after swith to cmake:indirect
-rw-r--r--devel/py-lief/Makefile3
-rw-r--r--java/openjfx14/Makefile4
-rw-r--r--science/nwchem/Makefile1
3 files changed, 3 insertions, 5 deletions
diff --git a/devel/py-lief/Makefile b/devel/py-lief/Makefile
index f848e0e0a02b..841090c967d5 100644
--- a/devel/py-lief/Makefile
+++ b/devel/py-lief/Makefile
@@ -10,9 +10,6 @@ WWW= https://github.com/lief-project/lief
LICENSE= APACHE20
-# Note: cmake is needed to build, but distutils is used directly.
-# If USES= cmake is set, the build will not work.
-
USES= cmake:indirect python zip
USE_PYTHON= concurrent distutils
diff --git a/java/openjfx14/Makefile b/java/openjfx14/Makefile
index cb61a0f8389f..00c0a9f0a8e9 100644
--- a/java/openjfx14/Makefile
+++ b/java/openjfx14/Makefile
@@ -33,7 +33,7 @@ LIB_DEPENDS= libasound.so:audio/alsa-lib \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= cmake:indirect gettext-runtime gl gnome jpeg localbase:ldflags ninja pkgconfig \
+USES= gettext-runtime gl gnome jpeg localbase:ldflags ninja pkgconfig \
sqlite xorg
USE_GITHUB= yes
@@ -73,7 +73,7 @@ TEST_VARS= AWT_TEST=true FULL_TEST=true
# Gradle calls CMake during the build
WEBKIT_IMPLIES= MEDIA
WEBKIT_LIB_DEPENDS= libicui18n.so:devel/icu
-WEBKIT_USES= bison gmake gperf perl5 python:build ruby:build
+WEBKIT_USES= bison cmake:indirect gmake gperf perl5 python:build ruby:build
WEBKIT_USE= GNOME=libxslt,libxml2 \
PERL5=build \
XORG=xcomposite,xdamage,xfixes,xrender,xt
diff --git a/science/nwchem/Makefile b/science/nwchem/Makefile
index 30056991fd8f..5356c3fb27be 100644
--- a/science/nwchem/Makefile
+++ b/science/nwchem/Makefile
@@ -78,6 +78,7 @@ OPENMPI_RUN_DEPENDS= openmpi>0:net/openmpi
OPENMPI_VARS= CONFLICTS_BUILD=mpich
LIBXC_DESC= Use libxc
+LIBXC_USES= cmake:indirect
LIBXC_MAKE_ENV= USE_LIBXC=Y
PYTHON_DESC= Enable Python syntax in input files