aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2015-02-01 15:35:15 +0000
committerThierry Thomas <thierry@FreeBSD.org>2015-02-01 15:35:15 +0000
commitbc908db8d7a5a9a33233fcd659cf30ec9ec7d3ea (patch)
treea47da24f43bfa3770ed3dfd509ede0371b6e451b
parent544315a33676634e1b123866b3fca4b88120a3eb (diff)
downloadports-bc908db8d7a5a9a33233fcd659cf30ec9ec7d3ea.tar.gz
ports-bc908db8d7a5a9a33233fcd659cf30ec9ec7d3ea.zip
Minor update to 0.2.13, some select important updates from
http://www.openblas.net/Changelog.txt: * Fix Fortran compiler detection on FreeBSD. (#470, Thanks Mike Nolta) * Fix a bug of sgemm kernel on Intel Sandy Bridge. * Added CBLAS interface for ?omatcopy and ?imatcopy. * Improved axpy and symv performance on AMD Bulldozer. * Improved gemv performance on modern Intel and AMD CPUs. PR: ports/197231 Submitted by: dieterich.joh (at) gmail.com Approved by: phd_kimberlite (at) yahoo.co.jp (maintainer)
Notes
Notes: svn path=/head/; revision=378246
-rw-r--r--math/openblas/Makefile4
-rw-r--r--math/openblas/distinfo4
-rw-r--r--math/openblas/files/patch-c_check15
3 files changed, 7 insertions, 16 deletions
diff --git a/math/openblas/Makefile b/math/openblas/Makefile
index decef1366264..c53d73deb391 100644
--- a/math/openblas/Makefile
+++ b/math/openblas/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= openblas
-PORTVERSION= 0.2.11
+PORTVERSION= 0.2.13
CATEGORIES= math
MASTER_SITES= https://codeload.github.com/${GH_ACCOUNT}/${GH_PROJECT}/legacy.tar.gz/${GH_TAGNAME}?dummy=/:${PORTNAME} \
NL:lapack_tmg
@@ -19,7 +19,7 @@ DIST_SUBDIR= openblas
GH_ACCOUNT= xianyi
GH_PROJECT= OpenBLAS
GH_TAGNAME= ${GH_COMMIT}
-GH_COMMIT= ea8d4e3
+GH_COMMIT= 51ce5ef
LARGE_FILE= large.tgz
TIMING_FILE= timing.tgz
diff --git a/math/openblas/distinfo b/math/openblas/distinfo
index 3e5101cd704c..f204ef871e17 100644
--- a/math/openblas/distinfo
+++ b/math/openblas/distinfo
@@ -1,5 +1,5 @@
-SHA256 (openblas/openblas-0.2.11.tar.gz) = babe5898c05da8a95249c1b038f7fbe14a95e35fee75358d649009f93ef444ed
-SIZE (openblas/openblas-0.2.11.tar.gz) = 9765198
+SHA256 (openblas/openblas-0.2.13.tar.gz) = 909518a34d1b13c3c854153c73f9062c8598436c55a267ae6b4f833c77d8b9f4
+SIZE (openblas/openblas-0.2.13.tar.gz) = 9858159
SHA256 (openblas/large.tgz) = f328d88b7fa97722f271d7d0cfea1c220e0f8e5ed5ff01d8ef1eb51d6f4243a1
SIZE (openblas/large.tgz) = 2595
SHA256 (openblas/timing.tgz) = 999c65f8ea8bd4eac7f1c7f3463d4946917afd20a997807300fe35d70122f3af
diff --git a/math/openblas/files/patch-c_check b/math/openblas/files/patch-c_check
index b471c5682e60..43d77fbe61fe 100644
--- a/math/openblas/files/patch-c_check
+++ b/math/openblas/files/patch-c_check
@@ -1,15 +1,6 @@
---- c_check.orig 2012-02-05 16:25:21.000000000 +0900
-+++ c_check 2012-02-05 16:26:54.000000000 +0900
-@@ -2,7 +2,7 @@
-
- # Checking cross compile
- $hostos = `uname -s | sed -e s/\-.*//`; chop($hostos);
--$hostarch = `uname -m | sed -e s/i.86/x86/`;chop($hostarch);
-+$hostarch = `uname -m | sed -e s/i.86/x86/ | sed -e s/amd64/x86_64/`;chop($hostarch);
-
- $binary = $ENV{"BINARY"};
-
-@@ -215,7 +215,7 @@
+--- c_check.orig 2014-12-03 16:14:21.000000000 +0100
++++ c_check 2015-02-01 01:01:27.784108000 +0100
+@@ -228,7 +228,7 @@
# print $data, "\n";
print MAKEFILE "OSNAME=$os\n";