aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2012-03-04 12:58:30 +0000
committerMartin Wilke <miwi@FreeBSD.org>2012-03-04 12:58:30 +0000
commitbc96fbb7a166e6398e650c075fbe19e0e675f1e8 (patch)
tree202149c3f5ac0151d6358ef5361297fc2c998d06
parent735f01e93ae2bed1d7d29befbcb99cd0092fe04c (diff)
downloadports-bc96fbb7a166e6398e650c075fbe19e0e675f1e8.tar.gz
ports-bc96fbb7a166e6398e650c075fbe19e0e675f1e8.zip
Auto-admin is a set of tools for automating common systems management tasks
from the command line. It is meant as a library of scripts to be used by more specific automated systems management scripts. WWW: http://acadix.biz/auto-admin.php PR: ports/165674 Submitted by: Jason Bacon <jwbacon@tds.net>
Notes
Notes: svn path=/head/; revision=292669
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/auto-admin/Makefile48
-rw-r--r--sysutils/auto-admin/distinfo2
-rw-r--r--sysutils/auto-admin/pkg-descr5
-rw-r--r--sysutils/auto-admin/pkg-plist18
5 files changed, 74 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index d879da3bbec8..d3f47120a7f3 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -44,6 +44,7 @@
SUBDIR += ataidle
SUBDIR += atitvout
SUBDIR += atop
+ SUBDIR += auto-admin
SUBDIR += automounter
SUBDIR += autopsy
SUBDIR += avfs
diff --git a/sysutils/auto-admin/Makefile b/sysutils/auto-admin/Makefile
new file mode 100644
index 000000000000..1f502ee75682
--- /dev/null
+++ b/sysutils/auto-admin/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: auto-admin
+# Date created: 2011-11-01
+# Whom: Jason Bacon <jwbacon@tds.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= auto-admin
+PORTVERSION= 0.1
+CATEGORIES= sysutils
+MASTER_SITES= http://personalpages.tds.net/~jwbacon/Ports/distfiles/ \
+ http://acadix.biz/Ports/distfiles/
+
+MAINTAINER= jwbacon@tds.net
+COMMENT= Tools for automating system management
+
+NO_BUILD= yes
+
+MAN1= auto-admin.1 \
+ auto-append-line.1 \
+ auto-ask.1 \
+ auto-clean-ports.1 \
+ auto-disable-service.1 \
+ auto-enable-service.1 \
+ auto-fastest-mirror.1 \
+ auto-install-packages.1 \
+ auto-ipfw-gateway-setup.1 \
+ auto-ldap-adduser.1 \
+ auto-ldap-client-setup.1 \
+ auto-package-installed.1 \
+ auto-replace-file.1 \
+ auto-service-enabled.1 \
+ auto-update-port-framework.1 \
+ auto-update-xorg.conf.1 \
+ auto-xdm-toggle.1
+
+do-install:
+ ${MKDIR} ${PREFIX}/sbin ${DATADIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/Scripts/* ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/Data/* ${DATADIR}
+ ${INSTALL_MAN} ${WRKSRC}/Doc/auto-admin.man \
+ ${MANPREFIX}/man/man1/auto-admin.1
+ for name in ${WRKSRC}/Scripts/*; do \
+ ${INSTALL_MAN} ${WRKSRC}/Doc/auto-admin.man \
+ ${MANPREFIX}/man/man1/`basename $${name}`.1; \
+ done
+
+.include <bsd.port.mk>
diff --git a/sysutils/auto-admin/distinfo b/sysutils/auto-admin/distinfo
new file mode 100644
index 000000000000..fd9e1f5555a3
--- /dev/null
+++ b/sysutils/auto-admin/distinfo
@@ -0,0 +1,2 @@
+SHA256 (auto-admin-0.1.tar.gz) = 30c076203bb8936b8cc96aa7a9ba1d8127b854c016156bd0909cef5223c89f5e
+SIZE (auto-admin-0.1.tar.gz) = 9478
diff --git a/sysutils/auto-admin/pkg-descr b/sysutils/auto-admin/pkg-descr
new file mode 100644
index 000000000000..db22f391310a
--- /dev/null
+++ b/sysutils/auto-admin/pkg-descr
@@ -0,0 +1,5 @@
+Auto-admin is a set of tools for automating common systems management tasks
+from the command line. It is meant as a library of scripts to be used by
+more specific automated systems management scripts.
+
+WWW: http://acadix.biz/auto-admin.php
diff --git a/sysutils/auto-admin/pkg-plist b/sysutils/auto-admin/pkg-plist
new file mode 100644
index 000000000000..78a40c9d083c
--- /dev/null
+++ b/sysutils/auto-admin/pkg-plist
@@ -0,0 +1,18 @@
+sbin/auto-append-line
+sbin/auto-ask
+sbin/auto-clean-ports
+sbin/auto-disable-service
+sbin/auto-enable-service
+sbin/auto-fastest-mirror
+sbin/auto-install-packages
+sbin/auto-ipfw-gateway-setup
+sbin/auto-ldap-adduser
+sbin/auto-ldap-client-setup
+sbin/auto-package-installed
+sbin/auto-replace-file
+sbin/auto-service-enabled
+sbin/auto-update-port-framework
+sbin/auto-update-xorg.conf
+sbin/auto-xdm-toggle
+%%DATADIR%%/ipfw-rules.sh
+@dirrm %%DATADIR%%