aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2022-07-05 09:59:49 +0000
committerDima Panov <fluffy@FreeBSD.org>2022-07-05 09:59:49 +0000
commitbcc99a70b304f6d0047e227a39122d47b67c4668 (patch)
treea35bd9bbc068853a0ca86ed725fcd770dde3490b
parent3b314cfbafbce5196d15a9651f7350cb0c36ce0e (diff)
www/py-django32: unbreak build for HTML docs (+)
Same fix as 64b2298a6d98dfcc467c328b18293f558fa92c59 for Django40. Django require at least sphinx 4.5.0 to generate offline HTML docs. Set version check for dependency. Another issue is gmake-style construction in docs/Makefile. Force gmake usage for HTMLDOCS option to resolve build issue. Pointyhat to: wen (for skipped dependencies chech) Approved by: portmgr blanket (fix build) MFH: 2022Q3
-rw-r--r--www/py-django32/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/www/py-django32/Makefile b/www/py-django32/Makefile
index bb9be741baf6..f6c60b7e651f 100644
--- a/www/py-django32/Makefile
+++ b/www/py-django32/Makefile
@@ -47,14 +47,15 @@ OPTIONS_GROUP_DATABASE= PGSQL MYSQL SQLITE
OPTIONS_DEFAULT=SQLITE
HTMLDOCS_DESC= Install HTML documentation (requires Sphinx)
-HTMLDOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0,1:textproc/py-sphinx@${PY_FLAVOR}
+HTMLDOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=4.5.0,1:textproc/py-sphinx@${PY_FLAVOR}
HTMLDOCS_IMPLIES= DOCS
+HTMLDOCS_USES= gmake
PGSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}psycopg2>0:databases/py-psycopg2@${PY_FLAVOR}
MYSQL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mysqlclient>=1.3.13:databases/py-mysqlclient@${PY_FLAVOR}
SQLITE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
post-build-HTMLDOCS-on:
- cd ${WRKSRC}/docs && ${MAKE} html SPHINXBUILD=sphinx-build-${PYTHON_VER}
+ cd ${WRKSRC}/docs && ${GMAKE} html SPHINXBUILD=sphinx-build-${PYTHON_VER}
post-install:
${INSTALL_MAN} ${WRKSRC}/docs/man/* ${STAGEDIR}/${MAN1PREFIX}/man/man1