aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-02-12 18:36:39 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2023-02-12 18:36:39 +0000
commitbccc46e0b233d89c0db1e5efb50bacfd0da5296f (patch)
tree35503b7904528a0e0db06dfb3dfe799d56793537
parentf7d702d5947d5fdd86ae76e35e92a2ed3b0859f0 (diff)
downloadports-bccc46e0b233d89c0db1e5efb50bacfd0da5296f.tar.gz
ports-bccc46e0b233d89c0db1e5efb50bacfd0da5296f.zip
dns/libpsl: Convert to meson
- Remove NLS option - Bump PORTREVISION for package change PR: 269314
-rw-r--r--dns/libpsl/Makefile32
1 files changed, 12 insertions, 20 deletions
diff --git a/dns/libpsl/Makefile b/dns/libpsl/Makefile
index a42da91d7eeb..c0eda8c56757 100644
--- a/dns/libpsl/Makefile
+++ b/dns/libpsl/Makefile
@@ -1,6 +1,6 @@
PORTNAME= libpsl
PORTVERSION= 0.21.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= https://github.com/rockdaboot/libpsl/releases/download/${PORTVERSION}/
@@ -13,24 +13,19 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= public_suffix_list>=0:dns/public_suffix_list
-USES= libtool localbase:ldflags pathfix pkgconfig python:build shebangfix tar:lz
-
-CONFIGURE_ARGS= --disable-gtk-doc \
- --disable-gtk-doc-html \
- --disable-gtk-doc-pdf \
- --disable-man \
- --enable-builtin \
- --with-psl-file=${LOCALBASE}/share/public_suffix_list/public_suffix_list.dat \
- --with-psl-testfile=${LOCALBASE}/share/public_suffix_list/test_psl.txt
-GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
+USES= localbase:ldflags meson pkgconfig python:build shebangfix tar:lz
+
+MESON_ARGS= -Dbuiltin=true \
+ -Ddefault_library=both \
+ -Ddocs=false \
+ -Dpsl_file=${LOCALBASE}/share/public_suffix_list/public_suffix_list.dat \
+ -Dpsl_testfile=${LOCALBASE}/share/public_suffix_list/test_psl.txt
USE_LDCONFIG= yes
USE_LOCALE= en_US.UTF-8
SHEBANG_FILES= src/psl-make-dafsa
TEST_TARGET= test
-OPTIONS_DEFINE= NLS
OPTIONS_SINGLE= IDNA
OPTIONS_SINGLE_IDNA= ICU IDN IDN2
OPTIONS_DEFAULT=IDN2
@@ -38,21 +33,18 @@ ICU_DESC= Use devel/icu (IDNA2008 UTS\#46 library)
IDN_DESC= Use dns/libidn (IDNA2003 library)
IDN2_DESC= Use dns/libidn2 (IDNA2008 library)
-ICU_CONFIGURE_ON= --enable-runtime=libicu
ICU_LIB_DEPENDS= libicuuc.so:devel/icu
-IDN_CONFIGURE_ON= --enable-runtime=libidn
+ICU_MESON_ON= -Druntime=libicu
IDN_LIB_DEPENDS= libidn.so:dns/libidn \
libunistring.so:devel/libunistring
+IDN_MESON_ON= -Druntime=libidn
IDN_USES= iconv
-IDN2_CONFIGURE_ON= --enable-runtime=libidn2
IDN2_LIB_DEPENDS= libidn2.so:dns/libidn2 \
libunistring.so:devel/libunistring
+IDN2_MESON_ON= -Druntime=libidn2
IDN2_USES= iconv
-NLS_CONFIGURE_ENABLE= nls
-NLS_USES= gettext
-NLS_USES_OFF= gettext-tools
post-install:
- ${RM} ${STAGEDIR}${PREFIX}/man/man1/psl-make-dafsa.1
+ ${RM} ${STAGEDIR}${PREFIX}/bin/psl-make-dafsa ${STAGEDIR}${PREFIX}/man/man1/psl-make-dafsa.1
.include <bsd.port.mk>