aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2022-05-13 16:37:50 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2022-06-08 16:24:35 +0000
commitbd70827c22827422583d9bd6963636ef4f2d5623 (patch)
treed227d18f0e4043a891ecb0fb18c2f15c2bde1ffc
parentd2153894e76837f45bc21c448f2c610f128ede7c (diff)
downloadports-bd70827c22827422583d9bd6963636ef4f2d5623.tar.gz
ports-bd70827c22827422583d9bd6963636ef4f2d5623.zip
devel/autoconf: update to 2.71
- Copy devel/autoconf to devel/autoconf2.69. - Update devel/autoconf to 2.71. - Allow ports to use 2.69 with USES=autoreconf:2.69. PR: 258046 Exp-run by: antoine
-rw-r--r--Mk/Uses/autoreconf.mk29
-rw-r--r--UPDATING8
-rw-r--r--audio/portaudio/Makefile4
-rw-r--r--comms/conserver-com/Makefile2
-rw-r--r--devel/Makefile1
-rw-r--r--devel/autoconf/Makefile30
-rw-r--r--devel/autoconf/distinfo5
-rw-r--r--devel/autoconf/files/patch-Makefile.in11
-rw-r--r--devel/autoconf/pkg-plist7
-rw-r--r--devel/autoconf2.69/Makefile85
-rw-r--r--devel/autoconf2.69/distinfo3
-rw-r--r--devel/autoconf2.69/files/patch-bin_autoreconf.in10
-rw-r--r--devel/autoconf2.69/files/patch-bin_autoscan.in (renamed from devel/autoconf/files/patch-bin_autoscan.in)0
-rw-r--r--devel/autoconf2.69/files/patch-doc_Makefile.in (renamed from devel/autoconf/files/patch-doc_Makefile.in)0
-rw-r--r--devel/autoconf2.69/files/patch-doc_autoconf.texi (renamed from devel/autoconf/files/patch-doc_autoconf.texi)0
-rw-r--r--devel/autoconf2.69/pkg-descr9
-rw-r--r--devel/autoconf2.69/pkg-plist58
-rw-r--r--devel/autotools/Makefile5
-rw-r--r--devel/libspice-server/Makefile4
-rw-r--r--devel/pire/Makefile2
-rw-r--r--emulators/snes9x-gtk/Makefile4
-rw-r--r--ftp/wzdftpd/Makefile2
-rw-r--r--lang/erlang-runtime21/Makefile4
-rw-r--r--math/latte-integrale/Makefile3
-rw-r--r--math/mpsolve/Makefile4
-rw-r--r--net/asterisk-chan_sccp/Makefile2
-rw-r--r--net/minidlna/Makefile2
-rw-r--r--net/pacemaker1/Makefile.common4
-rw-r--r--net/vinagre/Makefile4
-rw-r--r--sysutils/clsync/Makefile2
-rw-r--r--textproc/hunspell/Makefile4
-rw-r--r--textproc/uim-el/Makefile5
-rw-r--r--textproc/uim/Makefile5
-rw-r--r--www/varnish4/Makefile2
34 files changed, 259 insertions, 61 deletions
diff --git a/Mk/Uses/autoreconf.mk b/Mk/Uses/autoreconf.mk
index 7da3b85d5825..20cdbd588fa1 100644
--- a/Mk/Uses/autoreconf.mk
+++ b/Mk/Uses/autoreconf.mk
@@ -63,6 +63,7 @@
# Feature: autoreconf
# Usage: USES=autoreconf or USES=autoreconf:args
# Valid args: build Don't run autoreconf, only add build dependencies
+# 2.69 Use this legacy version
#
# MAINTAINER: ports@FreeBSD.org
@@ -70,7 +71,7 @@
_INCLUDE_USES_AUTORECONF_MK= yes
_USES_POST+= autoreconf
-AUTORECONF?= ${LOCALBASE}/bin/autoreconf
+AUTORECONF?= ${LOCALBASE}/bin/autoreconf${_AUTORECONF}
AUTORECONF_WRKSRC?= ${WRKSRC}
.endif
@@ -78,20 +79,37 @@ AUTORECONF_WRKSRC?= ${WRKSRC}
.if defined(_POSTMKINCLUDED) && !defined(_INCLUDE_USES_AUTORECONF_POST_MK)
_INCLUDE_USES_AUTORECONF_POST_MK= yes
-BUILD_DEPENDS+= autoconf>=2.69:devel/autoconf \
- automake>=1.16.1:devel/automake
+. if ${autoreconf_ARGS:M2.69}
+_AUTORECONF= 2.69
+BUILD_DEPENDS+= autoconf2.69>=2.69:devel/autoconf2.69
+. else
+_AUTORECONF= 2.71
+BUILD_DEPENDS+= autoconf>=2.71:devel/autoconf
+. endif
+
+BUILD_DEPENDS+= automake>=1.16.5:devel/automake
. if defined(libtool_ARGS) && empty(libtool_ARGS:Mbuild)
BUILD_DEPENDS+= libtoolize:devel/libtool
. endif
-. if empty(autoreconf_ARGS)
+# In case autoconf-switch wrapper scripts are used during build.
+CONFIGURE_ENV+= DEFAULT_AUTOCONF=${_AUTORECONF}
+MAKE_ENV+= DEFAULT_AUTOCONF=${_AUTORECONF}
+
+. if ${autoreconf_ARGS:Nbuild:N2.69}
+IGNORE= incorrect 'USES+=autoreconf:${autoreconf_ARGS}'\
+ expecting 'USES+=autoreconf[:build,2.69]'
+. endif
+
+. if ! ${autoreconf_ARGS:Mbuild}
_USES_configure+= 470:do-autoreconf
do-autoreconf:
. for f in AUTHORS ChangeLog INSTALL NEWS README
# Don't modify time stamps if the files already exist
@test -e ${AUTORECONF_WRKSRC}/${f} || ${TOUCH} ${AUTORECONF_WRKSRC}/${f}
. endfor
+. if ${_AUTORECONF} == 2.69
@(cd ${AUTORECONF_WRKSRC} && \
if test -f configure.ac; then configure=configure.ac; \
else configure=configure.in; fi && \
@@ -103,11 +121,10 @@ do-autoreconf:
then if ! ${LOCALBASE}/bin/intltoolize -f -c; then \
${ECHO_MSG} '===> Mk/Uses/autoreconf.mk: Error running intltoolize'; \
${FALSE}; fi; fi)
+. endif
@(cd ${AUTORECONF_WRKSRC} && if ! ${AUTORECONF} -f -i; then \
${ECHO_MSG} '===> Mk/Uses/autoreconf.mk: Error running ${AUTORECONF}'; \
${FALSE}; fi)
-. elif ! ${autoreconf_ARGS:Mbuild}
-IGNORE= Incorrect 'USES+=autoreconf:${autoreconf_ARGS}' expecting 'USES+=autoreconf[:build]'
. endif
.endif
diff --git a/UPDATING b/UPDATING
index 1ea9812f5a42..249d5a35a937 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,14 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20220608:
+ AFFECTS: devel/autoconf-wrapper, devel/autoconf213
+ AUTHOR: tijl@FreeBSD.org
+
+ These ports have been renamed to devel/autoconf-switch and devel/autoconf2.13
+ respectively. If your favourite port updating tool cannot handle that then
+ just remove the packages with "pkg delete" and then install the new port.
+
20220607:
AFFECTS: security/openssh-portable
AUTHOR: bdrewery@FreeBSD.org
diff --git a/audio/portaudio/Makefile b/audio/portaudio/Makefile
index 3c06eb99bd1c..6864e6fc5f9a 100644
--- a/audio/portaudio/Makefile
+++ b/audio/portaudio/Makefile
@@ -14,8 +14,8 @@ COMMENT= Portable cross-platform Audio API
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= autoreconf cpe dos2unix gmake libtool localbase:ldflags pathfix \
- pkgconfig tar:tgz
+USES= autoreconf:2.69 cpe dos2unix gmake libtool localbase:ldflags \
+ pathfix pkgconfig tar:tgz
USE_LDCONFIG= yes
CPE_VENDOR= portaudio_project
diff --git a/comms/conserver-com/Makefile b/comms/conserver-com/Makefile
index 0bb58bf00ed0..c60a2ae406bf 100644
--- a/comms/conserver-com/Makefile
+++ b/comms/conserver-com/Makefile
@@ -10,7 +10,7 @@ COMMENT= Application that allows multiple users to watch serial consoles
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= autoreconf ssl
+USES= autoreconf:2.69 ssl
USE_GITHUB= yes
USE_RC_SUBR= conserver
diff --git a/devel/Makefile b/devel/Makefile
index dad44f40bfc6..b4cbc073efcc 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -220,6 +220,7 @@
SUBDIR += autoconf-archive
SUBDIR += autoconf-switch
SUBDIR += autoconf2.13
+ SUBDIR += autoconf2.69
SUBDIR += autodia
SUBDIR += autogen
SUBDIR += automake
diff --git a/devel/autoconf/Makefile b/devel/autoconf/Makefile
index d4c1cd8094e7..15a34cefa952 100644
--- a/devel/autoconf/Makefile
+++ b/devel/autoconf/Makefile
@@ -1,8 +1,7 @@
# Created by: ade@FreeBSD.org
PORTNAME= autoconf
-PORTVERSION= 2.69
-PORTREVISION= 4
+PORTVERSION= 2.71
CATEGORIES= devel
MASTER_SITES= GNU
@@ -22,7 +21,7 @@ BUILD_DEPENDS= gm4:devel/m4
RUN_DEPENDS= autoconf-switch>=0:devel/autoconf-switch \
gm4:devel/m4
-VERSION= 2.69
+VERSION= 2.71
USES= perl5 tar:xz
GNU_CONFIGURE= yes
@@ -44,21 +43,17 @@ INFO_USES= makeinfo
INFO_INFO= autoconf${VERSION}
post-patch:
- @${FIND} ${WRKSRC} -name Makefile.in -exec ${REINPLACE_CMD} \
- '/^pkgdatadir =/s/@PACKAGE@/&@VERSION@/' {} +
+ @${REINPLACE_CMD} '/^pkgdatadir =/s/@PACKAGE@/&@VERSION@/' \
+ ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -E \
-e 's/[^-/]auto(conf|header|reconf|scan|update)/&${VERSION}/g' \
- -e 's/config\.guess|config\.sub|ifnames/&${VERSION}/g' \
+ -e 's/ifnames/&${VERSION}/g' \
+ -e '/config\.(guess|sub)/d' \
${WRKSRC}/man/*.1
-# Save timestamps.
- @${LN} ${WRKSRC}/build-aux/config.guess \
- ${WRKSRC}/build-aux/config.guess.orig
- @${LN} ${WRKSRC}/build-aux/config.sub \
- ${WRKSRC}/build-aux/config.sub.orig
post-patch-INFO-on:
@${REINPLACE_CMD} -E 's/autoconf\.(info|texi)/autoconf${VERSION}.\1/g' \
- ${WRKSRC}/doc/Makefile.in
+ ${WRKSRC}/Makefile.in
@${CP} ${WRKSRC}/doc/autoconf.texi ${WRKSRC}/doc/autoconf${VERSION}.texi
@${REINPLACE_CMD} \
-e 's/autoconf\.info/autoconf${VERSION}.info/' \
@@ -68,17 +63,10 @@ post-patch-INFO-on:
s/ \{2,9\}/ / ; }' \
${WRKSRC}/doc/autoconf${VERSION}.texi
# Restore timestamp in .info file.
- @${TOUCH} -r ${WRKSRC}/doc/autoconf.texi.orig \
+ @${TOUCH} -r ${WRKSRC}/doc/autoconf${VERSION}.texi.bak \
${WRKSRC}/doc/autoconf${VERSION}.texi
post-patch-INFO-off:
- @${REINPLACE_CMD} '/^INFO_DEPS =/d' ${WRKSRC}/doc/Makefile.in
-
-post-configure:
-# Restore timestamps to prevent regeneration of man pages.
- @${TOUCH} -r ${WRKSRC}/build-aux/config.guess.orig \
- ${WRKSRC}/build-aux/config.guess
- @${TOUCH} -r ${WRKSRC}/build-aux/config.sub.orig \
- ${WRKSRC}/build-aux/config.sub
+ @${REINPLACE_CMD} '/^INFO_DEPS =/d' ${WRKSRC}/Makefile.in
.include <bsd.port.mk>
diff --git a/devel/autoconf/distinfo b/devel/autoconf/distinfo
index 3359cad88dd4..8505f71992dc 100644
--- a/devel/autoconf/distinfo
+++ b/devel/autoconf/distinfo
@@ -1,2 +1,3 @@
-SHA256 (autoconf-2.69.tar.xz) = 64ebcec9f8ac5b2487125a86a7760d2591ac9e1d3dbd59489633f9de62a57684
-SIZE (autoconf-2.69.tar.xz) = 1214744
+TIMESTAMP = 1651493393
+SHA256 (autoconf-2.71.tar.xz) = f14c83cfebcc9427f2c3cea7258bd90df972d92eb26752da4ddad81c87a0faa4
+SIZE (autoconf-2.71.tar.xz) = 1292296
diff --git a/devel/autoconf/files/patch-Makefile.in b/devel/autoconf/files/patch-Makefile.in
new file mode 100644
index 000000000000..ec90ef28946c
--- /dev/null
+++ b/devel/autoconf/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2021-01-28 21:06:02 UTC
++++ Makefile.in
+@@ -311,7 +311,7 @@ am__dirstamp = $(am__leading_dot)dirstamp
+ am__v_texidevnull_0 = > /dev/null
+ am__v_texidevnull_1 =
+ am__dirstamp = $(am__leading_dot)dirstamp
+-INFO_DEPS = $(srcdir)/doc/autoconf.info $(srcdir)/doc/standards.info
++INFO_DEPS = $(srcdir)/doc/autoconf.info
+ am__TEXINFO_TEX_DIR = $(srcdir)/build-aux
+ DVIS = doc/autoconf.dvi doc/standards.dvi
+ PDFS = doc/autoconf.pdf doc/standards.pdf
diff --git a/devel/autoconf/pkg-plist b/devel/autoconf/pkg-plist
index a1f8fe3aeae6..6111ed2aa925 100644
--- a/devel/autoconf/pkg-plist
+++ b/devel/autoconf/pkg-plist
@@ -11,12 +11,11 @@ man/man1/autom4te%%VERSION%%.1.gz
man/man1/autoreconf%%VERSION%%.1.gz
man/man1/autoscan%%VERSION%%.1.gz
man/man1/autoupdate%%VERSION%%.1.gz
-man/man1/config.guess%%VERSION%%.1.gz
-man/man1/config.sub%%VERSION%%.1.gz
man/man1/ifnames%%VERSION%%.1.gz
%%DATADIR%%/Autom4te/C4che.pm
%%DATADIR%%/Autom4te/ChannelDefs.pm
%%DATADIR%%/Autom4te/Channels.pm
+%%DATADIR%%/Autom4te/Config.pm
%%DATADIR%%/Autom4te/Configure_ac.pm
%%DATADIR%%/Autom4te/FileUtils.pm
%%DATADIR%%/Autom4te/General.pm
@@ -43,6 +42,7 @@ man/man1/ifnames%%VERSION%%.1.gz
%%DATADIR%%/autoconf/programs.m4
%%DATADIR%%/autoconf/specific.m4
%%DATADIR%%/autoconf/status.m4
+%%DATADIR%%/autoconf/trailer.m4
%%DATADIR%%/autoconf/types.m4
%%DATADIR%%/autom4te.cfg
%%DATADIR%%/autoscan/autoscan.list
@@ -50,6 +50,9 @@ man/man1/ifnames%%VERSION%%.1.gz
%%DATADIR%%/autotest/autotest.m4f
%%DATADIR%%/autotest/general.m4
%%DATADIR%%/autotest/specific.m4
+%%DATADIR%%/build-aux/config.guess
+%%DATADIR%%/build-aux/config.sub
+%%DATADIR%%/build-aux/install-sh
%%DATADIR%%/m4sugar/foreach.m4
%%DATADIR%%/m4sugar/m4sh.m4
%%DATADIR%%/m4sugar/m4sh.m4f
diff --git a/devel/autoconf2.69/Makefile b/devel/autoconf2.69/Makefile
new file mode 100644
index 000000000000..308419ef0b64
--- /dev/null
+++ b/devel/autoconf2.69/Makefile
@@ -0,0 +1,85 @@
+# Created by: ade@FreeBSD.org
+
+PORTNAME= autoconf
+PORTVERSION= 2.69
+CATEGORIES= devel
+MASTER_SITES= GNU
+PKGNAMESUFFIX= ${VERSION}
+
+MAINTAINER= tijl@FreeBSD.org
+COMMENT= Generate configure scripts and related files
+
+LICENSE= EXCEPTION GFDL GPLv2+ GPLv3+
+LICENSE_COMB= multi
+LICENSE_NAME_EXCEPTION= AUTOCONF CONFIGURE SCRIPT EXCEPTION
+LICENSE_FILE_EXCEPTION= ${WRKSRC}/COPYING.EXCEPTION
+LICENSE_FILE_GFDL= ${WRKSRC}/doc/fdl.texi
+LICENSE_FILE_GPLv2+ = ${WRKSRC}/COPYING
+LICENSE_FILE_GPLv3+ = ${WRKSRC}/COPYINGv3
+LICENSE_PERMS_EXCEPTION=dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
+
+BUILD_DEPENDS= gm4:devel/m4
+RUN_DEPENDS= autoconf-switch>=0:devel/autoconf-switch \
+ gm4:devel/m4
+
+VERSION= 2.69
+USES= perl5 tar:xz
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --program-suffix=${VERSION} \
+ --without-lispdir
+CONFIGURE_ENV= AWK=${AWK} \
+ EMACS=no \
+ M4=${LOCALBASE}/bin/gm4
+
+DATADIR= ${PREFIX}/share/autoconf${VERSION}
+NO_ARCH= yes
+PORTSCOUT= ignore
+
+PLIST_SUB= VERSION=${VERSION}
+
+OPTIONS_DEFINE= INFO
+OPTIONS_DEFAULT=INFO
+
+INFO_USES= makeinfo
+INFO_INFO= autoconf${VERSION}
+
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.in -exec ${REINPLACE_CMD} \
+ '/^pkgdatadir =/s/@PACKAGE@/&@VERSION@/' {} +
+ @${REINPLACE_CMD} -E \
+ -e 's,([^-/]auto)(conf|header|reconf|scan|update),\1\2${VERSION},g' \
+ -e 's,(config\.guess|config\.sub|ifnames),\1${VERSION},g' \
+ ${WRKSRC}/man/*.1
+# Save timestamps.
+ @${LN} ${WRKSRC}/build-aux/config.guess \
+ ${WRKSRC}/build-aux/config.guess.orig
+ @${LN} ${WRKSRC}/build-aux/config.sub \
+ ${WRKSRC}/build-aux/config.sub.orig
+
+post-patch-INFO-on:
+ @${REINPLACE_CMD} -E 's/autoconf\.(info|texi)/autoconf${VERSION}.\1/g' \
+ ${WRKSRC}/doc/Makefile.in
+ @${CP} ${WRKSRC}/doc/autoconf.texi ${WRKSRC}/doc/autoconf${VERSION}.texi
+ @${REINPLACE_CMD} \
+ -e 's/autoconf\.info/autoconf${VERSION}.info/' \
+ -e '/^@direntry/,/^@end/ { \
+ s/^\*[^-:]*/&${VERSION}/ ; \
+ s/(autoconf)/(autoconf${VERSION})/ ; \
+ s/ \{2,9\}/ / ; }' \
+ ${WRKSRC}/doc/autoconf${VERSION}.texi
+# Restore timestamp in .info file.
+ @${TOUCH} -r ${WRKSRC}/doc/autoconf.texi.orig \
+ ${WRKSRC}/doc/autoconf${VERSION}.texi
+
+post-patch-INFO-off:
+ @${REINPLACE_CMD} '/^INFO_DEPS =/d' ${WRKSRC}/doc/Makefile.in
+
+post-configure:
+# Restore timestamps to prevent regeneration of man pages.
+ @${TOUCH} -r ${WRKSRC}/build-aux/config.guess.orig \
+ ${WRKSRC}/build-aux/config.guess
+ @${TOUCH} -r ${WRKSRC}/build-aux/config.sub.orig \
+ ${WRKSRC}/build-aux/config.sub
+
+.include <bsd.port.mk>
diff --git a/devel/autoconf2.69/distinfo b/devel/autoconf2.69/distinfo
new file mode 100644
index 000000000000..59b8c523205b
--- /dev/null
+++ b/devel/autoconf2.69/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1653672631
+SHA256 (autoconf-2.69.tar.xz) = 64ebcec9f8ac5b2487125a86a7760d2591ac9e1d3dbd59489633f9de62a57684
+SIZE (autoconf-2.69.tar.xz) = 1214744
diff --git a/devel/autoconf2.69/files/patch-bin_autoreconf.in b/devel/autoconf2.69/files/patch-bin_autoreconf.in
new file mode 100644
index 000000000000..6d94c0774c85
--- /dev/null
+++ b/devel/autoconf2.69/files/patch-bin_autoreconf.in
@@ -0,0 +1,10 @@
+--- bin/autoreconf.in.orig 2012-04-24 22:00:28 UTC
++++ bin/autoreconf.in
+@@ -692,6 +692,7 @@ parse_args;
+
+ # Autoreconf all the given configure.ac. Unless `--no-recursive' is passed,
+ # AC_CONFIG_SUBDIRS will be traversed in &autoreconf_current_directory.
++$ENV{'AUTOCONF'} = $autoconf;
+ $ENV{'AUTOM4TE'} = $autom4te;
+ for my $directory (@ARGV)
+ {
diff --git a/devel/autoconf/files/patch-bin_autoscan.in b/devel/autoconf2.69/files/patch-bin_autoscan.in
index a55345cc5593..a55345cc5593 100644
--- a/devel/autoconf/files/patch-bin_autoscan.in
+++ b/devel/autoconf2.69/files/patch-bin_autoscan.in
diff --git a/devel/autoconf/files/patch-doc_Makefile.in b/devel/autoconf2.69/files/patch-doc_Makefile.in
index 8c3263afeb19..8c3263afeb19 100644
--- a/devel/autoconf/files/patch-doc_Makefile.in
+++ b/devel/autoconf2.69/files/patch-doc_Makefile.in
diff --git a/devel/autoconf/files/patch-doc_autoconf.texi b/devel/autoconf2.69/files/patch-doc_autoconf.texi
index 9cca043de0d3..9cca043de0d3 100644
--- a/devel/autoconf/files/patch-doc_autoconf.texi
+++ b/devel/autoconf2.69/files/patch-doc_autoconf.texi
diff --git a/devel/autoconf2.69/pkg-descr b/devel/autoconf2.69/pkg-descr
new file mode 100644
index 000000000000..c0c821a08849
--- /dev/null
+++ b/devel/autoconf2.69/pkg-descr
@@ -0,0 +1,9 @@
+Autoconf is an extensible package of M4 macros that produce shell
+scripts to automatically configure software source code packages.
+These scripts can adapt the packages to many kinds of UNIX-like
+systems without manual user intervention. Autoconf creates a
+configuration script for a package from a template file that lists the
+operating system features that the package can use, in the form of M4
+macro calls.
+
+WWW: https://www.gnu.org/software/autoconf/
diff --git a/devel/autoconf2.69/pkg-plist b/devel/autoconf2.69/pkg-plist
new file mode 100644
index 000000000000..a1f8fe3aeae6
--- /dev/null
+++ b/devel/autoconf2.69/pkg-plist
@@ -0,0 +1,58 @@
+bin/autoconf%%VERSION%%
+bin/autoheader%%VERSION%%
+bin/autom4te%%VERSION%%
+bin/autoreconf%%VERSION%%
+bin/autoscan%%VERSION%%
+bin/autoupdate%%VERSION%%
+bin/ifnames%%VERSION%%
+man/man1/autoconf%%VERSION%%.1.gz
+man/man1/autoheader%%VERSION%%.1.gz
+man/man1/autom4te%%VERSION%%.1.gz
+man/man1/autoreconf%%VERSION%%.1.gz
+man/man1/autoscan%%VERSION%%.1.gz
+man/man1/autoupdate%%VERSION%%.1.gz
+man/man1/config.guess%%VERSION%%.1.gz
+man/man1/config.sub%%VERSION%%.1.gz
+man/man1/ifnames%%VERSION%%.1.gz
+%%DATADIR%%/Autom4te/C4che.pm
+%%DATADIR%%/Autom4te/ChannelDefs.pm
+%%DATADIR%%/Autom4te/Channels.pm
+%%DATADIR%%/Autom4te/Configure_ac.pm
+%%DATADIR%%/Autom4te/FileUtils.pm
+%%DATADIR%%/Autom4te/General.pm
+%%DATADIR%%/Autom4te/Getopt.pm
+%%DATADIR%%/Autom4te/Request.pm
+%%DATADIR%%/Autom4te/XFile.pm
+%%DATADIR%%/INSTALL
+%%DATADIR%%/autoconf/autoconf.m4
+%%DATADIR%%/autoconf/autoconf.m4f
+%%DATADIR%%/autoconf/autoheader.m4
+%%DATADIR%%/autoconf/autoscan.m4
+%%DATADIR%%/autoconf/autotest.m4
+%%DATADIR%%/autoconf/autoupdate.m4
+%%DATADIR%%/autoconf/c.m4
+%%DATADIR%%/autoconf/erlang.m4
+%%DATADIR%%/autoconf/fortran.m4
+%%DATADIR%%/autoconf/functions.m4
+%%DATADIR%%/autoconf/general.m4
+%%DATADIR%%/autoconf/go.m4
+%%DATADIR%%/autoconf/headers.m4
+%%DATADIR%%/autoconf/lang.m4
+%%DATADIR%%/autoconf/libs.m4
+%%DATADIR%%/autoconf/oldnames.m4
+%%DATADIR%%/autoconf/programs.m4
+%%DATADIR%%/autoconf/specific.m4
+%%DATADIR%%/autoconf/status.m4
+%%DATADIR%%/autoconf/types.m4
+%%DATADIR%%/autom4te.cfg
+%%DATADIR%%/autoscan/autoscan.list
+%%DATADIR%%/autotest/autotest.m4
+%%DATADIR%%/autotest/autotest.m4f
+%%DATADIR%%/autotest/general.m4
+%%DATADIR%%/autotest/specific.m4
+%%DATADIR%%/m4sugar/foreach.m4
+%%DATADIR%%/m4sugar/m4sh.m4
+%%DATADIR%%/m4sugar/m4sh.m4f
+%%DATADIR%%/m4sugar/m4sugar.m4
+%%DATADIR%%/m4sugar/m4sugar.m4f
+%%DATADIR%%/m4sugar/version.m4
diff --git a/devel/autotools/Makefile b/devel/autotools/Makefile
index 3828698dca55..eb42b4ae3a62 100644
--- a/devel/autotools/Makefile
+++ b/devel/autotools/Makefile
@@ -1,7 +1,7 @@
# Created by: Ade Lovett <ade@FreeBSD.org>
PORTNAME= autotools
-PORTVERSION= 20220527
+PORTVERSION= 20220528
CATEGORIES= devel
MAINTAINER= tijl@FreeBSD.org
@@ -9,7 +9,8 @@ COMMENT= Autotools meta-port
RUN_DEPENDS= libtoolize:devel/libtool \
autoconf2.13:devel/autoconf2.13 \
- autoconf>=2.69:devel/autoconf \
+ autoconf2.69:devel/autoconf2.69 \
+ autoconf>=2.71:devel/autoconf \
automake>=1.15:devel/automake
USES= metaport
diff --git a/devel/libspice-server/Makefile b/devel/libspice-server/Makefile
index 528064f3c604..fbd96a2d2a64 100644
--- a/devel/libspice-server/Makefile
+++ b/devel/libspice-server/Makefile
@@ -32,8 +32,8 @@ SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
STATISTICS_CONFIGURE_ENABLE= statistics
-USES= autoreconf compiler:c++11-lang cpe gmake gnome jpeg libtool \
- localbase:ldflag pkgconfig python ssl tar:bzip2 xorg
+USES= autoreconf:2.69 compiler:c++11-lang cpe gmake gnome jpeg \
+ libtool localbase:ldflag pkgconfig python ssl tar:bzip2 xorg
USE_GNOME= glib20
USE_XORG= pixman
diff --git a/devel/pire/Makefile b/devel/pire/Makefile
index 874454cdb28c..334d946c4694 100644
--- a/devel/pire/Makefile
+++ b/devel/pire/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USE_GITHUB= yes
GH_ACCOUNT= yandex
-USES= autoreconf bison compiler:c++11-lib libtool
+USES= autoreconf:2.69 bison compiler:c++11-lib libtool
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/emulators/snes9x-gtk/Makefile b/emulators/snes9x-gtk/Makefile
index 35fb267514ad..bcbbcb5bb1b4 100644
--- a/emulators/snes9x-gtk/Makefile
+++ b/emulators/snes9x-gtk/Makefile
@@ -20,8 +20,8 @@ LIB_DEPENDS= libpng.so:graphics/png
USE_GITHUB= yes
GH_ACCOUNT= snes9xgit
-USES= autoreconf compiler:c11 desktop-file-utils gettext gmake gnome \
- localbase perl5 pkgconfig sdl tar:bzip2 xorg
+USES= autoreconf:2.69 compiler:c11 desktop-file-utils gettext gmake \
+ gnome localbase perl5 pkgconfig sdl tar:bzip2 xorg
USE_GNOME= cairo gdkpixbuf2 gtk20 intltool libxml2
USE_SDL= sdl2
USE_XORG= x11 xext
diff --git a/ftp/wzdftpd/Makefile b/ftp/wzdftpd/Makefile
index e2763d47dc21..7db6799f0a57 100644
--- a/ftp/wzdftpd/Makefile
+++ b/ftp/wzdftpd/Makefile
@@ -12,7 +12,7 @@ COMMENT= Modular FTP server configurable online using SITE commands
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= autoreconf cpe gettext-tools libtool localbase pkgconfig
+USES= autoreconf:2.69 cpe gettext-tools libtool localbase pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --sysconfdir=${ETCDIR} --disable-bonjour --disable-static
INSTALL_TARGET= install-strip
diff --git a/lang/erlang-runtime21/Makefile b/lang/erlang-runtime21/Makefile
index 1ea27a8c3200..79e7853e9247 100644
--- a/lang/erlang-runtime21/Makefile
+++ b/lang/erlang-runtime21/Makefile
@@ -15,7 +15,7 @@ LICENSE= APACHE20
BROKEN_sparc64= Fails to build: error: fp_except undeclared
-USES= compiler autoreconf:build cpe gmake ncurses perl5
+USES= compiler autoreconf:build,2.69 cpe gmake ncurses perl5
USE_GITHUB= nodefault
GH_ACCOUNT= erlang:otp,corba
GH_PROJECT= otp:otp corba:corba
@@ -113,7 +113,7 @@ MAKE_ARGS+= ARCH=arm
.endif
pre-configure:
- @cd ${WRKSRC} && ./otp_build autoconf
+ @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./otp_build autoconf
pre-configure-WX-off:
echo "disabled by port options" > ${WRKSRC}/lib/debugger/SKIP
diff --git a/math/latte-integrale/Makefile b/math/latte-integrale/Makefile
index da6314f37f77..050d310c6a7b 100644
--- a/math/latte-integrale/Makefile
+++ b/math/latte-integrale/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= lib4ti2util.so:math/4ti2 \
RUN_DEPENDS= lrs:math/lrslib \
points2triangs:math/topcom
-USES= autoreconf compiler:c++11-lang gmake libtool localbase:ldflags
+USES= autoreconf:2.69 compiler:c++11-lang gmake libtool \
+ localbase:ldflags
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-static \
--with-topcom=${LOCALBASE} --with-4ti2=${LOCALBASE} --with-cddlib=${LOCALBASE} --with-gmp=${LOCALBASE} --with-ntl=${LOCALBASE}
diff --git a/math/mpsolve/Makefile b/math/mpsolve/Makefile
index e2952e060029..b4593f6802d7 100644
--- a/math/mpsolve/Makefile
+++ b/math/mpsolve/Makefile
@@ -12,8 +12,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libgmp.so:math/gmp \
libtcmalloc_minimal.so:devel/google-perftools
-USES= autoreconf compiler:c++11-lang gettext-runtime gmake gnome \
- libtool localbase pkgconfig shared-mime-info tar:bz2
+USES= autoreconf:2.69 compiler:c++11-lang gettext-runtime gmake \
+ gnome libtool localbase pkgconfig shared-mime-info tar:bz2
USE_GNOME= atk cairo gdkpixbuf2 glib20 gtk30 pango
USE_LDCONFIG= yes
diff --git a/net/asterisk-chan_sccp/Makefile b/net/asterisk-chan_sccp/Makefile
index 54e41ada0574..9f60db642595 100644
--- a/net/asterisk-chan_sccp/Makefile
+++ b/net/asterisk-chan_sccp/Makefile
@@ -18,7 +18,7 @@ FLAVOR?= ${FLAVORS:[1]}
LIB_DEPENDS= libltdl.so:devel/libltdl
-USES= autoreconf compiler:c11 gettext-tools iconv libtool \
+USES= autoreconf:2.69 compiler:c11 gettext-tools iconv libtool \
localbase ssl
USE_GITHUB= yes
diff --git a/net/minidlna/Makefile b/net/minidlna/Makefile
index 8d8ffb36f589..62cc75de1c6e 100644
--- a/net/minidlna/Makefile
+++ b/net/minidlna/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libsqlite3.so:databases/sqlite3 \
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-db-path=/var/db/minidlna \
--with-os-url="http://www.FreeBSD.org"
-USES= autoreconf cpe gettext-tools iconv jpeg localbase
+USES= autoreconf:2.69 cpe gettext-tools iconv jpeg localbase
CPE_VENDOR= minidlna_project
diff --git a/net/pacemaker1/Makefile.common b/net/pacemaker1/Makefile.common
index 8eac3a113c4e..c31359ecce09 100644
--- a/net/pacemaker1/Makefile.common
+++ b/net/pacemaker1/Makefile.common
@@ -31,8 +31,8 @@ USE_GITHUB= yes
GH_ACCOUNT= ClusterLabs
GH_PROJECT= pacemaker
-USES= autoreconf corosync cpe gmake gnome libtool ncurses pathfix \
- pkgconfig python:3.6+ shebangfix
+USES= autoreconf:2.69 corosync cpe gmake gnome libtool \
+ ncurses pathfix pkgconfig python:3.6+ shebangfix
CPE_VENDOR= clusterlabs
USE_BINUTILS= yes
USE_GNOME= glib20
diff --git a/net/vinagre/Makefile b/net/vinagre/Makefile
index bf1e6093e8e7..768901797cde 100644
--- a/net/vinagre/Makefile
+++ b/net/vinagre/Makefile
@@ -29,8 +29,8 @@ RUN_DEPENDS= gnome-icon-theme>=0:misc/gnome-icon-theme
PORTSCOUT= limitw:1,even
-USES= autoreconf desktop-file-utils gettext gmake gnome localbase \
- pathfix pkgconfig shared-mime-info tar:xz xorg
+USES= autoreconf:2.69 desktop-file-utils gettext gmake gnome \
+ localbase pathfix pkgconfig shared-mime-info tar:xz xorg
USE_GNOME= cairo gtk30 intlhack libxml2 vte3
USE_XORG= x11
GNU_CONFIGURE= yes
diff --git a/sysutils/clsync/Makefile b/sysutils/clsync/Makefile
index ae5f6ef9e7d9..3e7d94e7b01b 100644
--- a/sysutils/clsync/Makefile
+++ b/sysutils/clsync/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv3
LIB_DEPENDS= libinotify.so:devel/libinotify
GNU_CONFIGURE= yes
-USES= autoreconf compiler:features gmake gnome libtool pkgconfig
+USES= autoreconf:2.69 compiler:features gmake gnome libtool pkgconfig
USE_GNOME= glib20
USE_RC_SUBR= clsync
diff --git a/textproc/hunspell/Makefile b/textproc/hunspell/Makefile
index 3d02d15e6c94..50f84c2d8372 100644
--- a/textproc/hunspell/Makefile
+++ b/textproc/hunspell/Makefile
@@ -19,8 +19,8 @@ LICENSE_FILE_MPL11= ${WRKSRC}/COPYING.MPL
CONFLICTS_INSTALL= tinker
CONFIGURE_ARGS= --disable-nls ${ICONV_CONFIGURE_ARG} --with-readline --with-ui
GNU_CONFIGURE= yes
-USES= autoreconf compiler:c++11-lib cpe libtool:keepla pathfix \
- iconv ncurses readline shebangfix perl5
+USES= autoreconf compiler:c++11-lib cpe gettext-tools libtool:keepla \
+ pathfix iconv ncurses readline shebangfix perl5
CPE_VENDOR= ${PORTNAME}_project
USE_GITHUB= yes
SHEBANG_FILES= src/tools/ispellaff2myspell
diff --git a/textproc/uim-el/Makefile b/textproc/uim-el/Makefile
index 1722836fcc8c..0d71b9d406cb 100644
--- a/textproc/uim-el/Makefile
+++ b/textproc/uim-el/Makefile
@@ -14,7 +14,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= uim-el-agent:textproc/uim
-USES= autoreconf:build emacs gettext gmake gnome iconv libtool pathfix perl5 pkgconfig
+USES= autoreconf:build,2.69 emacs gettext gmake gnome iconv libtool \
+ pathfix perl5 pkgconfig
USE_GNOME= intltool
USE_PERL5= build
@@ -42,7 +43,7 @@ PLIST_SUB+= DOCSDIR_JA="${DOCSDIR_JA:S,^${PREFIX}/,,}"
OPTIONS_DEFINE= DOCS
pre-configure:
- cd ${WRKSRC} && ./autogen.sh
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh
post-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index 4d219955df42..9bc819d04daf 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -16,7 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_riscv64= fails to configure: ./include/private/gcconfig.h:492:5: The collector has not been ported to this machine/OS combination
-USES+= autoreconf:build gettext gmake gnome iconv libedit libtool pathfix pkgconfig sqlite
+USES+= autoreconf:build,2.69 gettext gmake gnome iconv libedit \
+ libtool pathfix pkgconfig sqlite
USE_LDCONFIG= yes
USE_GNOME+= glib20 intltool
@@ -98,7 +99,7 @@ post-extract:
${CP} -R ${WRKSRC_libgcroots}/* ${WRKSRC}/sigscheme/libgcroots
pre-configure:
- cd ${WRKSRC} && ./autogen.sh
+ cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} ./autogen.sh
do-build:
.if !defined(UIM_SLAVE)
diff --git a/www/varnish4/Makefile b/www/varnish4/Makefile
index 1d19b913258b..d84e76326950 100644
--- a/www/varnish4/Makefile
+++ b/www/varnish4/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libpcre.so:devel/pcre
CONFLICTS= varnish6 varnish7
-USES= autoreconf cpe gmake libedit libtool ncurses pathfix \
+USES= autoreconf:2.69 cpe gmake libedit libtool ncurses pathfix \
pkgconfig python:build readline shebangfix
SHEBANG_FILES= lib/libvcc/vmodtool.py
CPE_VENDOR= varnish-cache